Autore Topic: CentOS 5.2 e AHCI  (Letto 2706 volte)

Offline Giando76

  • Jr. Member
  • **
  • Post: 27
    • Mostra profilo
    • E-mail
CentOS 5.2 e AHCI
« il: 31 Gennaio 2009, 16:14:23 »
Salve a tutti,
possiedo un pc con una scheda madre Asua M2N32 WS Pro e con CentOS 5.2 installata sul disco sda. Questa scheda madre integra due controller SATA uno direttamente nel chipset nForce ed un altro esterno al chiset della Marvell ed esattamente il Marvell 88SE6145. Al controller Marvell sono installati due dischi. Tutto funziona regolarmente. Decido di rifare l'installazione della CentOS su un altro disco, questa volta pero ottengo degli errori di riconoscimento del Controller Marvell gia in fase di avvio di initrd.img quindi alla fine del boot linux non riconosce il controller e non vedo i dischi se non facendo questa operazione

modprobe -r pata_marvell
modprobe -r ahci

poi

modprobe ahci

ci sta un pochino e poi riconosce il controller e vedo i dischi.

Come mai? da cosa puo dipendere l'anomalia della seconda installazione?
(Eppure non ricordo di avere dato dei parametri particolari in fase di installazione tantomeno di aver modificato il BIOS.).

Attendo suggerimenti
Grazie 1000
G.


PS: copiando il file initrd.img da quella funzionante e sstituendolo all'initrd.img dell'installazione malfunzionante tutto sembra ok riconosce tutto fin dall'inizio. Quindi il problema nel secondo initrd. Gli manca qualcosa, ma cosa?
Con Fedora 10 non c' verso.. nont rovo neanche il modulo ahci.ko