Autore Topic: Da raid 1 a raid 5 (SW raid) Vale la pena?  (Letto 4474 volte)

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Da raid 1 a raid 5 (SW raid) Vale la pena?
« il: 04 Maggio 2009, 11:07:56 »
Allora ho un "desktop" linux (centos 5.3) che fa da da server casalingo (printer server, backup server per gli altri pc di casa, host per una VM Windows ecc...).
Al momento va con 2 dischi da 320 in raid 1 (su partizionati con LVM).
Dato che ora mi trovo con altri 2 dischi da 320 pensavo di passare da raid 1 ad un raid 5 a 3 dischi e ne avrei 1 di riserva (ho solo un'altro connettore sata libero sul pc).
Per via del LVM credo che la procedura di upgrade sarà più complessa, di quelle che si trovano nei vari howto su internet, quindi volevo sapere se qualcuno è in grado di dirmi quanto peggiorano le prestazioni in scrittura rispetto al raid1 (la cpu è un Intel E5200).

Grazie
Cya

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #1 il: 04 Maggio 2009, 13:34:44 »
Come regola non dovresti avere degrado in scrittura, il consiglio è di usare tutti e 4 i dischi da 320 in raid 5.
La scrittura in raid 1 è pari alla velocità del singolo disco mentre per il raid 5 è "minimo" la velocità del singolo disco, in quanto utilizzi più meccaniche per scrivere i dati. In lettura invece avendo un raid 5 su 4 dischi avresti una velocità fino a 3 volte superiore rispetto al singolo disco.

Ciao

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #2 il: 04 Maggio 2009, 15:20:19 »
il 3 è dovuto al fatto di avere un solo spinotto sata ancora libero.
Sulla mb ce ne sono 4 ma 1 è usato da un lettore di compact flash su cui risiede la partizione /boot (così il S.o. riesce ad avviare anche se uno dei due dischi muore ;) )

al momento le tutte le guide guide sulle conversioni raid1 -> raid5 che ho provato (le ho eseguite  in una macchina virtuale) hanno fallito miseramente (credo sia dovuto al fatto che la partizione sul raid sia LVM e non viene riconosciuta).

credo ci voglia un approccio più brutale (backup della partizione con dd e successivo ripristino)

vedo di riprovarci domani

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #3 il: 04 Maggio 2009, 17:06:07 »
Concordo con il backup e la creazione da zero.

Se hai uno slot pci libero puoi pensare di comprare un controller sata2 a due porte, costa sui 20 euro ed è abastanza affidabile.


Ciao

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #4 il: 04 Maggio 2009, 17:21:41 »
si è un ipotesi, ma per lo slot libero avrei altri piani ;)

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #5 il: 06 Maggio 2009, 10:27:23 »
sembra che il problema sia da imputarsi all'initrd.
Allora con un bel po' di pazienza, unita a chroot sono riuscito a rifare avviare l'ambiente virtuale dopo la conversione in raid5. Ma ora mi trovo un pò di errori riguardo dei moduli "già inseriti".
Forse potrebbe aiutare una qualche sorta di procedure di reinstallazione del kernel?

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #6 il: 06 Maggio 2009, 16:40:44 »
Mi sembra veramente anomalo come cosa. Prova ad aggiornare eventualmente il kernel!

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #7 il: 06 Maggio 2009, 17:07:39 »
il kernel è all'ultima versione, quindi non lo fa aggiornare ^_^
dovrei rimuoverlo e reinstallarlo ma temo che la procedura non sia proprio auspicabile.

Offline Kirys

  • Newbie
  • *
  • Post: 16
    • Mostra profilo
Re: Da raid 1 a raid 5 (SW raid) Vale la pena?
« Risposta #8 il: 20 Giugno 2009, 14:21:36 »
Alla fine ho trovato un pò di tempo e ho fatto un pò di esperimenti.
E' proprio un problema intrinseco del raid5, anche installando da zero da quell'errore, sembra che mkinitrd in caso di raid 5 per qualche strana ragione metta due volte il modulo raid456 nell'immagine generando l'errore.