Autore Topic: Nokia E65 modem USB  (Letto 2840 volte)

Offline adrianokr

  • Jr. Member
  • **
  • Post: 42
    • Mostra profilo
    • E-mail
Nokia E65 modem USB
« il: 08 Aprile 2011, 20:21:56 »
Dopo aver risolto il problema del disco (grazie Dakan77 e LonelyWolf) posto in questa sezione, che mi sembra più adatta, il problema della navigazione tramite telefono.

Ricordo che ho un CentOS 5.5 64 bit e un nokia E65

Appurato che NetworkManager non gestisce (almeno cosi ho letto) connessioni con modem usb del telefono mi sono rivolto a wvdial.
Dunque il plug-and-play dovrebbe funzionare bene infatti appena lo collego facendo qualche controllo l'esito è positivo.

Codice: [Seleziona]
[adriano@centos-sassc ~]$ ls /dev/ttyACM*
/dev/ttyACM0

[adriano@centos-sassc ~]$ lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 003: ID 04f2:b159 Chicony Electronics Co., Ltd
Bus 003 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 03f0:231d Hewlett-Packard
Bus 008 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 005 Device 001: ID 0000:0000  
Bus 006 Device 006: ID 0421:0508 Nokia Mobile Phones E65 (PC Suite mode)
Bus 006 Device 001: ID 0000:0000  
Bus 007 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  



Seguendo questa guida ( http://tareqalam.wordpress.com/2008/07/11/connect-your-nokia-phone-with-linux-without-pc-suite/ )

sono andato avanti con i seguenti comandi:


Codice: [Seleziona]
sudo /sbin/modprobe usbserial vendor=0x421 product=0x508

[adriano@centos-sassc ~]$ wvdialconf create    
Scanning your serial ports for a modem.

ttyS0<Info>: Device or resource busy
Port Scan<*1>: S0  
ttyS1<Info>: Device or resource busy
Port Scan<*1>: S1  
ttyS2<Info>: Device or resource busy
Port Scan<*1>: S2  
ttyS3<Info>: Device or resource busy
Port Scan<*1>: S3  
ttyACM0<Info>: Device or resource busy
Port Scan<*1>: ACM0
ttyUSB0<Info>: Device or resource busy
Port Scan<*1>: USB0


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wvdial/

If you still have problems, send mail to wvdial-list@lists.nit.ca.



Il secondo dei due ha dato, non so perchè, esito negativo.
In ogni caso io l'ho ignorato, sono andato avanti e ho configurato wvdial.conf nel seguente modo (non è proprio identico a quello proposto nella guida ma dovrebbe andare bene)

Codice: [Seleziona]
[adriano@centos-sassc ~]$ sudo gedit /etc/wvdial.conf

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ISDN = 0
Modem Type = Analog Modem
Phone = *99#
Username =
Password =
Stupid Mode = 1


a questo punto al lancio mi da esito negativo:

Codice: [Seleziona]
[adriano@centos-sassc ~]$ wvdial    
--> WvDial: Internet dialer version 1.54.0
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy

Inoltre facendo l'aggiornamento dei pacchetti (era uscita la segnalazione che ce ne erano nuovi disponibili), dopo aver dato la conferma all'aggiunta di alcune dipendenze che gli servivano, compare la finestra "Errore di aggiornamento software. Si sono verificati degli errori nel tentare di aggiornare i software selezionati."

Ora guardando i dettagli  (copio solo l'ultima parte perchè è troppo lunga e il post non lo contiene)

Codice: [Seleziona]

file /usr/share/i18n/charmaps/VIDEOTEX-SUPPL.gz from install of glibc-common-2.5-58.i386 conflicts with file from package glibc-common-2.5-49.el5_5.7.x86_64
file /usr/share/i18n/charmaps/VISCII.gz from install of glibc-common-2.5-58.i386 conflicts with file from package glibc-common-2.5-49.el5_5.7.x86_64
file /usr/share/i18n/charmaps/WINDOWS-31J.gz from install of glibc-common-2.5-58.i386 conflicts with file from package glibc-common-2.5-49.el5_5.7.x86_64
file /usr/kerberos/man/man5/krb5.conf.5.gz from install of krb5-libs-1.6.1-55.el5.i386 conflicts with file from package krb5-libs-1.6.1-36.el5_5.6.x86_64
file /usr/include/libdevmapper-event.h from install of device-mapper-1.02.55-2.el5.i386 conflicts with file from package device-mapper-1.02.39-1.el5_5.2.x86_64
file /usr/include/libdevmapper.h from install of device-mapper-1.02.55-2.el5.i386 conflicts with file from package device-mapper-1.02.39-1.el5_5.2.x86_64
file /usr/share/man/man8/dmsetup.8.gz from install of device-mapper-1.02.55-2.el5.i386 conflicts with file from package device-mapper-1.02.39-1.el5_5.2.x86_64
file /etc/rc.d/init.d/haldaemon from install of hal-0.5.8.1-62.el5.i386 conflicts with file from package hal-0.5.8.1-59.el5.x86_64
file /usr/bin/bdftops from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/dvipdf from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/eps2eps from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/fixmswrd.pl from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/font2c from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gsbj from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gsdj from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gsdj500 from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gslj from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gslp from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/gsnd from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/lprsetup.sh from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pdf2dsc from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pdf2ps from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pdfopt from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pf2afm from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pfbtopfa from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/printafm from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2ascii from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2epsi from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2pdf from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2pdf12 from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2pdf13 from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2pdf14 from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2pdfwr from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/ps2ps from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/pv.sh from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/unix-lpr.sh from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/bin/wftopfa from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/lib/cups/filter/pstopxl from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/cups/model/pxlcolor.ppd from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/cups/model/pxlmono.ppd from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/dvipdf.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/font2c.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/gsnd.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/pdf2dsc.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/pdf2ps.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/pdfopt.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/printafm.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/ps2ascii.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/ps2pdf.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/ps2ps.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/de/man1/wftopfa.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/dvipdf.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/font2c.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/gs.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/gslp.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/gsnd.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/pdf2dsc.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/pdf2ps.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/pdfopt.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/pf2afm.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/pfbtopfa.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/printafm.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/ps2ascii.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/ps2epsi.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/ps2pdf.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/ps2pdfwr.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/ps2ps.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man1/wftopfa.1.gz from install of ghostscript-8.70-6.el5.i386 conflicts with file from package ghostscript-8.15.2-9.12.el5_5.x86_64
file /usr/share/man/man5/pam_krb5.5.gz from install of pam_krb5-2.2.14-18.el5.i386 conflicts with file from package pam_krb5-2.2.14-15.x86_64
file /usr/share/man/man8/pam_krb5.8.gz from install of pam_krb5-2.2.14-18.el5.i386 conflicts with file from package pam_krb5-2.2.14-15.x86_64
file /etc/gconf/schemas/metacity.schemas from install of metacity-2.16.0-16.el5.i386 conflicts with file from package metacity-2.16.0-15.el5.x86_64
file /sbin/mkinitrd from install of mkinitrd-5.1.19.6-68.el5.i386 conflicts with file from package mkinitrd-5.1.19.6-61.el5_5.2.x86_64
file /usr/bin/huge_page_setup_helper.py from install of libhugetlbfs-1.3-8.2.el5.i386 conflicts with file from package libhugetlbfs-1.3-7.el5.x86_64
file /usr/bin/huge_page_setup_helper.pyc from install of libhugetlbfs-1.3-8.2.el5.i386 conflicts with file from package libhugetlbfs-1.3-7.el5.x86_64
file /usr/bin/huge_page_setup_helper.pyo from install of libhugetlbfs-1.3-8.2.el5.i386 conflicts with file from package libhugetlbfs-1.3-7.el5.x86_64
file /etc/redhat-lsb/lsb_start_daemon from install of redhat-lsb-4.0-2.1.4.el5.i386 conflicts with file from package redhat-lsb-3.1-12.3.EL.el5.centos.x86_64
file /usr/share/man/man1/lsb_release.1.gz from install of redhat-lsb-4.0-2.1.4.el5.i386 conflicts with file from package redhat-lsb-3.1-12.3.EL.el5.centos.x86_64

sembra che vadano in conflitto i pacchetti della versione a 64 bit con quelli della versione a 32.
Prima d'ora non mi aveva mai dato un problema del genere.