Autore Topic: Problemi con ndiswrapper e wireless  (Letto 2759 volte)

Offline Niubbo come pochi

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
Problemi con ndiswrapper e wireless
« il: 13 Febbraio 2009, 14:03:41 »
Buongiorno a tutti, ho installato CentOS proprio ieri dopo un lungo passato con Slackware, Debian e varie altre.
Appena installata ho scaricato i sorgenti di ndiswrapper 1.54 dal loro sito e li ho compilati, ho lanciato i vari ndiswrapper -i, -m, -ma, -mi e ndiswrapper -l mi dice che il dispositivo è presente, quindi fin qui è tutto a posto.
Però l'interfaccia wlan0 non si crea, e se lancio ifconfig wlan0 up me la segnala come connessione ethernet.

Come posso fare?

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Problemi con ndiswrapper e wireless
« Risposta #1 il: 14 Febbraio 2009, 08:50:07 »
Ciao che tipo di scheda wifi hai? Quale distro di centos stai usando e che kernel? Perchè non usi il comando iwconfig al posto di ifconfig? Hai creato il file ifcfg-wlan0 con tutte le sue informazioni?



Ciao



Offline Niubbo come pochi

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
Re: Problemi con ndiswrapper e wireless
« Risposta #2 il: 14 Febbraio 2009, 14:10:39 »
Dankan, credo di aver capito il problema dal tuo post.
La distro è CentOS 5 con il kernel di base e uso ifconfig perchè ero abituato a fare ifconfig e poi wpa_supplicant.
Credo che il problema sia questo file ifcfg-wlan0, come va creato e cosa deve contenere?

Grazie ;-)

PS: ma è solo CentOS che usa questo file? Non lo avevo mai creato con le altre distro




EDIT: Risolto, grazie ;-)
« Ultima modifica: 14 Febbraio 2009, 21:33:19 da Niubbo come pochi »