* * *
Benvenuto! Effettua l'accesso oppure registrati.
06 Marzo 2021, 19:04:59

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Problema Join dominio e configurazione Pam  (Letto 2810 volte)

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Problema Join dominio e configurazione Pam
« il: 07 Settembre 2011, 16:32:23 »
Ciao a tutti sono nuovo di questa community...
provo a chiedere qui se magari qualcuno di Voi ha gi avuto esperienza in merito....
L'operazione che voglio realizzare e far fare al mio Linux Centos 6 una join a un dominio AD 2008
Per ora ho configurato tutta la macchina e Kerberos il quale testandolo con i comandi Kinit e klist funziona.
Il problema che dopo aver configurato Pam e Ldap e NSSSwitch ho provato a fare un test per verificare il corretto funzionamento di LDAP
e mi ritorna questo msg....
comando  ldapsearch  -x -h localhost -b "dc=portlab,dc=com" "(objectclass=*)"
risultato   
ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

cosa sbaglio?o che cosa posso verificare?
premetto anche che iptables stoppato.
Grazie a tutti per le risposte

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: Problema Join dominio e configurazione Pam
« Risposta #1 il: 09 Settembre 2011, 09:48:56 »
girami la tua procedura!!!!!!!!!!!!!!!!!!!!!!!
Mayers

Where there is a shell, there is a way

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Problema Join dominio e configurazione Pam
« Risposta #2 il: 12 Settembre 2011, 18:17:07 »
Ciao Mayers,
allora finora ho configurato Kerberos,NTP,winbind e PAM...
ora il test con kinit "user" e klist funziona mi viene chiesta anche la password...
Il problema che io ora vorrei loggarmi alla shell ssh con le utenze ad e se faccio logout da root e inserisco
user@nomedominio la cosa cosi non va....
Cosa posso controllare?ho letto forse che dentro PAM va configurato qualche altra cosa relativamente al permesso di loggarsi alla shell linux con le utenze AD tu ne sai qualcosa?
Poi se vuoi ti mando i file per posta...

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Mayers

Where there is a shell, there is a way

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Problema Join dominio e configurazione Pam
« Risposta #4 il: 13 Settembre 2011, 16:49:46 »
Non ho risolto...il kinit con l'utenza ad funziona ma il login ssh no se hai una mail ti giro i file....
dimmi quali pam,winbind, sshd di pam,kerberos e basta credo...
Fammi sapere grazie mille...la mia cmq una centos 6

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: Problema Join dominio e configurazione Pam
« Risposta #5 il: 13 Settembre 2011, 16:54:51 »
hai dato un occhiata alla mia guida?

http://www.centos-italia.org/index.php?page=82
Mayers

Where there is a shell, there is a way

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Problema Join dominio e configurazione Pam
« Risposta #6 il: 14 Settembre 2011, 15:54:48 »
si si l'ho vista...
e funiziona la prova con kinit...ma tu sei riuscito anche a loggarti in ssh con l'utenza di dominio?

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Problema Join dominio e configurazione Pam
« Risposta #7 il: 14 Settembre 2011, 17:13:00 »
ne aproffito per chiederti se oltre kinit e klist esiste un comando e la sintassi per vedere se ldap funziona....
grazie

Offline fabry_xx77

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Problema Join dominio e configurazione Pam
« Risposta #8 il: 14 Settembre 2011, 17:37:30 »
io ho provato cosi ma non so cosa sbaglio cmq kinit e klist rispondo ed eseguono i test...
per ldap ho provato cosi verso il mio dc
ldapsearch -x -h 192.168.0.10 -D cn=userlinux,cn=Linux,cn=portlab,cn=com
ma non funziona o sbaglio il comando o non so...
grazie

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: Problema Join dominio e configurazione Pam
« Risposta #9 il: 15 Settembre 2011, 16:02:05 »
Guarda kinit klist non centrano con ldap nel mio sistema non proprio stato utilizzato ldap ma winbind samba e kerberos!!!!
Nella guida unix attribute uso ldap.

No io non ho mai provato a loggarmi in ssh

Ma nei log non vedi nulla
Mayers

Where there is a shell, there is a way

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: Problema Join dominio e configurazione Pam
« Risposta #10 il: 19 Settembre 2011, 15:39:30 »
ok con questo dovresti essere ok

http://home.roadrunner.com/~computertaijutsu/adsamba.html

sappimi dire ciao
Mayers

Where there is a shell, there is a way

 

Notizie

Se vuoi migrare il tuo server windows a CentOS sei nel posto giusto !!

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 5959
  • Ultimo: Sina
Statistiche
  • Post in totale: 13154
  • Topic in totale: 2960
  • Online Oggi: 229
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 199
Totale: 199

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50