Autore Topic: Problemi mount  (Letto 4015 volte)

Offline dado

  • Jr. Member
  • **
  • Post: 28
    • Mostra profilo
Problemi mount
« il: 02 Aprile 2013, 12:22:42 »
Ciao ragazzi, sto incontrando qualche problemino per montare una cartella condivisa

La situazione:
Freenas, gestito da terzi  con export nfs in accesso "libero" cosi mi riferiscono
server centos 6.3
lancio il comando per il mount:
mount -t nfs 192.168.1.12:AGO/ /mnt/nas

mi appare:
mount.nfs: access denied by server while mounting 192.168.1.12:AGO/

Sto sbagliando qualcosa io, oppure non ho le autorizzazioni necessaire sul nas ?

Ciao e grazie

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re:Problemi mount
« Risposta #1 il: 02 Aprile 2013, 12:59:07 »
non uso nfs, ma il messaggio "access denied by server" mi fa pensare la seconda..

Offline divagazioni

  • Jr. Member
  • **
  • Post: 25
    • Mostra profilo
Re:Problemi mount
« Risposta #2 il: 02 Aprile 2013, 17:25:58 »
mmm... non è che sbagli sintassi?
a me da lo stesso identico errore se tralascio lo / prima della mia risorsa condivisa. prova così:

mount -t nfs 192.168.1.12:/AGO/ /mnt/nas

Offline dado

  • Jr. Member
  • **
  • Post: 28
    • Mostra profilo
Re:Problemi mount
« Risposta #3 il: 02 Aprile 2013, 18:30:43 »
no, stesso msg

Offline divagazioni

  • Jr. Member
  • **
  • Post: 25
    • Mostra profilo
Re:Problemi mount
« Risposta #4 il: 02 Aprile 2013, 18:40:00 »
showmount -e 192.168.1.12

risponde qualcosa?

Offline dado

  • Jr. Member
  • **
  • Post: 28
    • Mostra profilo
Re:Problemi mount
« Risposta #5 il: 02 Aprile 2013, 19:00:58 »
mi sa che avevo info sbagliate, la condivisione era cifs ed era sbagliato anche il percorso
ho provato con  mount //192.168.1.12/backup/AGO /mnt/nas
mi chiede la pw ed una volta inserita sembra ok
ho provato a spostare qualcosa e controllando da windows sembra funzionare
col comando mv del file mi dice che non può preservare il proprietario del file sul punto di destinazione, ma non dovrebbe preoccuparmi.

eseguo:
# showmount -e 192.168.1.12
Export list for 192.168.1.12:
/mnt/Raid5 192.168.1.0

????? non capisco
controllo   fstab ma non trovo niente su mnt/Raid5

mentre se voglio automatizzare il processo inserisco qui
\\192.168.1.12\backup\AGO /mnt/nas cifs
ma dove metto la password ?

 

Offline divagazioni

  • Jr. Member
  • **
  • Post: 25
    • Mostra profilo
Re:Problemi mount
« Risposta #6 il: 02 Aprile 2013, 19:14:00 »
calma, calma, calma...

se la condivisione è cifs lo showmount non ti serve a niente e soprattutto lascia stare /etc/fstab.

per visualizzare le condivisioni cifs (o samba):

smbclient -L //192.168.1.12

e per fare il mount senza inserire la pwd:

mount -t cifs -o username=xxxxxx,password=xxxxxx //192.168.1.12/backup/AGO /mnt/nas