Autore Topic: Macchina Virtuale no funge da Router con iptables!!  (Letto 2192 volte)

Offline shark-1986

  • Newbie
  • *
  • Post: 1
    • Mostra profilo
    • E-mail
Macchina Virtuale no funge da Router con iptables!!
« il: 16 Maggio 2015, 13:00:20 »
Salve a tutti, ho un problema su cui sbatto da diverso tempo. Vi spiego dentro il mio Windows, dentro VirtualBox, ho una macchina Centos(che chiamer˛ Net) dentro la quale ho una rete costituita da 2switch:OVS0 e OVS1(openvswitch) e altre 3 macchine virtuali:VM0 e VM1(collegate ai due switch attraverso le rispettive interfacce etho-->OVS0 e eth1-->OVS1,in entrambe le macchine)e la HOST (sempre Centos)direttamente collegata a OVS1...la configurazione decisa in VB per la Net Ŕ una scheda Nat! Vorrei poter far collegare verso la rete pubblica la macchina HOST (a cui ho aggiunto una route verso il 10.0.2.2)attraverso la connessione di VM0 (fornita dal gateway canonico di VB 10.0.2.2 che Ŕ quello che riscrive i pacchetti e fa il Nat) per far questo ho abilitato l'ip forwarding chiaramente in VM0 e settato le seguenti iptables:
# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
# iptables -A FORWARD -i eth0 -o eth1 -m state  --state RELATED,ESTABLISHED -j ACCEPT
# iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT
supponendo che la VM0 riceva da eth1 e debba rilanciare verso eth0. Quando da HOST pingo un ip di google non ho il riscontro che mi aspetto nel senso che quell'host non Ŕ raggiungibile. Le configurazioni agli switch sono corrette nel senso che prevedo le dovute flow-entry il punto Ŕ che la VM0 non mi forwarda come dovrebbe (ricevere da eth1 forwardare attraverso eth0 verso il 10.0.2.2 passando da OVS0, poi eventualmente permettere il percorso di ritorno. Domanda devo per caso modificare queste regole anche in senso di chai PREROUTING???Grazie a chi innanzitutto cercherÓ di capirmi vista la non semplicitÓ dell'esposizione del tutto. Grazie ancora!

Offline agenore

  • Full Member
  • ***
  • Post: 93
    • Mostra profilo
    • E-mail
Re:Macchina Virtuale no funge da Router con iptables!!
« Risposta #1 il: 24 Agosto 2015, 09:01:35 »
scusami, ma onestamente non ho capito come Ŕ costruito il tutto.
Potresti essere pi¨ chiaro per favore?