Autore Topic: problemi con samba  (Letto 2627 volte)

Offline serpent0

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
problemi con samba
« il: 28 Aprile 2015, 12:52:20 »
Ciao a tutti,

ho un file server con sistema operativo centos 6.4, dove installato samba per effettuare la condivisione di cartelle con sistemi windows.
Il server in rete pingandolo raggiungibile, le condivisioni sono impostate sulle cartelle con i comandi setfacl, e dando getfacl riesco a visualizzarle. Il file smb.conf impostato correttamente. L'utente su windows c' e ha le stesse credenziali su centos. Non so pi dove andare a controllare. la schermata di errore su windows impossibile connettersi al server remoto, quali possono essere le cause del non accesso?

Grazie a tutti

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re:problemi con samba
« Risposta #1 il: 28 Aprile 2015, 17:35:32 »
ciao
tu ci stai dicendo, in sintesi "ho fatto tutto bene ma non funziona", senza darci un messaggio di errore n un file smb.conf per verificare..

il primo suggerimento quello di guardare nei log di samba (postando qui le parti eventualmente interessanti)
il secondo quello di postare qui smb.conf
il terzo di dirci se il server, dai client, lo richiami per ip o per nome.. e, nel secondo caso, se pingandolo per nome esso risponde

come regola generale, se vuoi aiuto, devi aiutarci ad aiutarti ;-)

Offline serpent0

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Re:problemi con samba
« Risposta #2 il: 28 Aprile 2015, 18:09:40 »
adesso accedo ,per solo con indirizzo ip, con nome ancora non va. Per non capisco perch nonostante ci siano le condivisioni infatti accedendo da windows a \\192.168.1.10 riesco ad entrare, poi vedo tutte le cartelle in condivisione, ovvero musica etc. Per se clicco sulla cartella musica mi richiede ancora le credenziali nella finestrella di login windows. Per i permessi ce li avrei su quella cartella in quanto gli ho dato il comando setfacl -m g:music:rwx /home/musica
e se faccio getfacl /home/musica riesco a vedere che i permessi sono impostati correttamente per il gruppo music nella cartella musica. L'utente mio fa sicuramente parte del gruppo music in quanto se do il comando /etc/group il mio utente appare facente parte del gruppo music. Come ne esco? Grazie mille

ps. ovviamente nel file smb.conf nell'ultima sezione [shared files] ho aggiunto la regola [musica] con path [home/musica] e le altri opzioni di default.
« Ultima modifica: 28 Aprile 2015, 18:11:29 da serpent0 »

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re:problemi con samba
« Risposta #3 il: 28 Aprile 2015, 20:07:37 »
rileggi il mio messaggio, attentamente