* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
14 Agosto 2020, 01:53:45

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Tabella di routing...  (Letto 4253 volte)

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Tabella di routing...
« il: 18 Ottobre 2011, 12:13:40 »
Ciao a tutti. Premetto che ci capisco poco sulle tabelle di routing, ma credo che proprio qui stia il mio problema.
Ho 2 schede di rete installate (eth0 e eth1). eth0 è collegata alla mia rete locale ed ha indirizzo 192.168.0.22/255.255.248.0. eth1 è collegata direttamente ad un router che mi da un servizio Voip ed ha indirizzo 1.111.162.189/255.255.255.252. Infatti in questa macchina è installato un centralino Asterisk (Trixbox).

Il problema è che non riesco a registrare telefoni IP esterni alla mia rete. Succede questo: la richiesta di registrazione dall'esterno avviene regolarmente sulla porta 5060 ed il mio firewall la inoltra correttamente al centralino (192.168.0.22). Il flusso di ritorno però, non torna attraverso il firewall (eth0), ma bensì attraverso l'altra scheda di rete (eth1) e li si perde...

Ho quindi la necessità di configurare la macchina in modo che su eth1 esca solo ed esclusivamente il traffico verso l'IP 80.74.178.24 (centrale Voip del mio operatore), mentre tutto il resto esca attraverso l'eth0.

Spero di essere stato sufficientemente chiaro...

Ringrazio anticipatamente chiunque sappia aiutarmi.

Ciao
Matteo

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Tabella di routing...
« Risposta #1 il: 18 Ottobre 2011, 12:41:37 »
Prova a postare un :
route -n

cosi cerchiamo di capirci qualcosa insieme :-)


Ciao

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Tabella di routing...
« Risposta #2 il: 18 Ottobre 2011, 14:18:46 »
Prova a postare un :
route -n

cosi cerchiamo di capirci qualcosa insieme :-)


Ciao

Intanto ti ringrazio per la disponibilità. Questo è il route -n richiesto:

Kernel IP routing table
Destination     Gateway         Genmask              Flags Metric Ref    Use Iface
1.111.162.188   0.0.0.0         255.255.255.252    U     0      0        0 eth1
80.74.178.24    1.111.162.189   255.255.255.252 UG    0      0        0 eth1
192.168.0.0     0.0.0.0         255.255.248.0         U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0            U     0      0        0 eth1
0.0.0.0         1.111.162.189   0.0.0.0                 UG    0      0        0 eth1

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Tabella di routing...
« Risposta #3 il: 18 Ottobre 2011, 14:42:14 »
Scusa: l'IP di eth1 è 1.111.162.188. Il .189 è il gateway.

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Tabella di routing...
« Risposta #4 il: 18 Ottobre 2011, 17:34:26 »
Ciao,
come regola dovresti indicare le regole a runtime

route add -net 0.0.0.0 netmask 0.0.0.0 gw "gateway di eth0"
route del -net 0.0.0.0 netmask 0.0.0.0 dev eth1
route add -host 80.74.178.24 gw 1.111.162.189

Ti consiglio di mettere tutto su un unica riga separato da ; per evitare di segarti fuori prima di modificare il routing
Se tutto funziona regolarmente c'è da fissare le regole modificando lo /etc/sysconfig/static-routes
con le seguenti righe

any net 0.0.0.0 netmask 0.0.0.0 gw "gateway di eth0"
any host 80.74.178.24 gw 1.111.162.189

commentando le altre eventuali righe e verificando che in

/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth1

eventuali entry GATEWAY siano commentate.

Spero di essere stato esaustivo.

Ciao

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Tabella di routing...
« Risposta #5 il: 18 Ottobre 2011, 18:13:26 »
Grazie mille. Questa sera provo e domani ti faccio sapere! ;)

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Tabella di routing...
« Risposta #6 il: 19 Ottobre 2011, 10:31:19 »
Funziona! :) Sei un grande!!
Ho lanciato i primi tre comandi route separati da ; e tutto si è messo ad andare. Come suggerivi ora dovrei fissare le modifiche, però nel percorso da te fornito (/etc/sysconfig), non trovo il file static-routes. Lo devo creare io manualmente inserendo le due righe indicate?

Ti ringrazio ancora.


Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: Tabella di routing...
« Risposta #7 il: 19 Ottobre 2011, 14:31:34 »
Confermo che devi creare i file se non esiste già.


Ciao

Offline teo2811

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re: Tabella di routing...
« Risposta #8 il: 20 Ottobre 2011, 12:29:02 »
Ottimo. Grazie. Ho creato il file, commentato in ifcfg-eth0 e 1, riavviato e tutto funziona! Ora i miei telefoni SIP esterni alla LAN si registrano regolarmente. Mi riamane il problema che non funziona l'audio con le chiamate verso questi telefoni, ma credo sia legato ad Asterisk....  >:(

Ti ringrazio ancora per il valido aiuto.

Ciao

 

Notizie

Benvenuto su CentOS-Italia.org , disponibile anche su mobile con Tapatalk

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 6336
  • Ultimo: merthin
Statistiche
  • Post in totale: 13083
  • Topic in totale: 2945
  • Online Oggi: 345
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 344
Totale: 344

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c'è mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50