Autore Topic: Aggiornamento CentOS5.4. Problema con i repostry  (Letto 184986 volte)

Offline MrMagoo

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Aggiornamento CentOS5.4. Problema con i repostry
« il: 12 Ottobre 2018, 18:13:54 »
Vorrei aggiornare un vecchio server con CentoOS 5.4, ma i repostry sono irraggiungibili. Yum mi da errore al comando #" yum update glibc\* -y
mi da il seguente errore:
"Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http or file.
 Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/addons/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: addons"
Chiaramente è un problema di vetustà degli indirizzi. La domanda che segue è: posso cambiare gli indirizzi manualmente in CentOS-Base.repo? Oppure mi conviene procurarmi la distro e metterla su chiavetta? oppure...? Grazie per l'aiuto.
« Ultima modifica: 12 Ottobre 2018, 18:15:41 da MrMagoo »

Offline MrMagoo

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Re:Aggiornamento CentOS5.4. Problema con i repostry
« Risposta #1 il: 12 Ottobre 2018, 18:15:07 »
al comando #" yum update glibc\* -y
mi da il seguente errore:
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http or file.
 Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/addons/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: addons
Chiaramente è un problema di vetustà degli indirizzi. La domanda che segue è: posso cambiare gli indirizzi manualmente in CentOS-Base.repo? Oppure mi conviene procurarmi la distro e metterla su chiavetta? oppure...? Grazie per l'aiuto.

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1396
    • Mostra profilo
    • Traversate dei laghi
Re:Aggiornamento CentOS5.4. Problema con i repostry
« Risposta #2 il: 15 Ottobre 2018, 08:46:52 »
Non è più possibile aggiornare, è una versione fuori supporto.

Offline gianlucaceci

  • Newbie
  • *
  • Post: 8
    • Mostra profilo
Re:Aggiornamento CentOS5.4. Problema con i repostry
« Risposta #3 il: 11 Maggio 2020, 12:50:37 »
Se vuoi aggiornare da 5 a 6, tipo, devi far partire il server con la release che vuoi aggiornare ma ricordati che i 32bit ormai non ci sono più o quanto meno sono molto poco seguiti dato degradanti