Autore Topic: Installazione SHUTTER su centos7  (Letto 20367 volte)

Offline ljt

  • Newbie
  • *
  • Post: 4
    • Mostra profilo
    • E-mail
Installazione SHUTTER su centos7
« il: 10 Luglio 2018, 10:20:15 »
Salve a tutti,

considerando che mi sono avvicinato al mondo linux solo da poco tempo sicuramente farò delle domande banali. Comunque ecco il mio quesito:

Scenario: installare il programma shutter in ambiente centos 7 su circa 15 computer.

Passaggi effettuati:
aggiornamento di tutti i pc tramite:
yum update

Installato il repository epel su tutti i pc.

Su 12 computer SHUTTER è stato installato correttamente tramite il comando:
yum install shutter

Su 3 computer mi viene restituito il seguente messaggio:

Risoluzione delle dipendenze completata
Errore: Pacchetto: perl-Gtk2-ImageView-0.04-9.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: shutter-0.93.1-1.el6.nux.noarch (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Gnome2-1.042-8.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Goo-Canvas-0.06-11.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Proc-Simple-1.26-5.el6.nux.noarch (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Gnome2-Wnck-0.16-12.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Gtk2-Unique-0.05-2.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: shutter-0.93.1-1.el6.nux.noarch (nux-dextop)
            Richiede: perl(Net::DBus)
Errore: Pacchetto: perl-Gnome2-VFS-1.081-8.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-X11-Protocol-Other-18-1.el6.nux.noarch (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
Errore: Pacchetto: perl-Gnome2-Canvas-1.002-16.el6.nux.x86_64 (nux-dextop)
            Richiede: perl(:MODULE_COMPAT_5.10.1)
 Si può provare ad usare --skip-broken per aggirare il problema
 Provare ad eseguire: rpm -Va --nofiles --nodigest

Ho provato a installare perl con il comando:
yum install perl
Messaggio restituito:
Il pacchetto 4:perl-5.16.3-292.el7.x86_64 è già installato e aggiornato all'ultima versione
Niente da fare

Ho provato a scaricare e installare il pacchetto mancante:
RPM resource perl(:MODULE_COMPAT_5.10.1)
dal sito:
https://www.rpmfind.net/linux/rpm2html/search.php?query=perl%28%3AMODULE_COMPAT_5.10.1%29&submit=Search+...&system=centos+7&arch=
ma ho notato che è solo per la versione centos 6.x
e comunque il problema mi è rimasto.

Chiarimento:
tutti i pc con cento7 hanno tutti gli stessi repository e lo stesso livello di aggiornamento.

Domanda:
come posso risolvere???


Ringrazio anticipatamente tutti colore che avranno pietà  :D