* * *
Benvenuto! Effettua l'accesso oppure registrati.
26 Settembre 2021, 23:08:25

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Crontab e script php  (Letto 507 volte)

Offline morph3us

  • Jr. Member
  • **
  • Post: 26
    • Mostra profilo
    • E-mail
Crontab e script php
« il: 24 Luglio 2021, 11:18:51 »
CIao,
ho un problema di questo tipo:
schedulato su crontab il lncio di uno script php tramite
Codice: [Seleziona]
55 16 * * * root  /usr/bin/php /var/www/html/scalare/mailScalare.php >> /var/log/controllaScalare.log
ma purtroppo incappo inquest errore
Codice: [Seleziona]
PHP Warning:  require(/vendor/autoload.php): Failed to open stream: No such file or directory in /var/www/html/scalare/mailScalare.php on line 12
PHP Fatal error:  Uncaught Error: Failed opening required '/vendor/autoload.php' (include_path='.:/usr/share/pear:/usr/share/php:/usr/share/pear:/usr/share/php') in /var/www/html/scalare/mailScalare.php:12
Stack trace:
#0 {main}
  thrown in /var/www/html/scalare/mailScalare.php on line 12

come posso risolvere?

PS
lo script lanciato a mano da browser funziona correttamente ed il cron tab eseue la sua schedula

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1396
    • Mostra profilo
    • Traversate dei laghi
Re:Crontab e script php
« Risposta #1 il: 05 Agosto 2021, 11:41:28 »
Scusa ma fino ad oggi non riuscivo ad accedere al sito!

Potrebbe essere un problema di permessi per l'utenza con cui gira il cron, prova ad aggiungere l'utenza con cui deve essere avviato lo script.

Offline morph3us

  • Jr. Member
  • **
  • Post: 26
    • Mostra profilo
    • E-mail
Re:Crontab e script php
« Risposta #2 il: 05 Agosto 2021, 16:43:46 »
Ciao, si anche io per alcuni giorni non sono riuscito ad accedere, grazie cmq per la tua risposta.

Ho risolto cosi

12 7 * * * /usr/bin/curl http://10.1.1.41/scalare/mailScalare.php

dove in pratia mi pare di aver capito che la 8 non volgia indicato lo user ed ho optato per curl onde evitare i problemi di percosi delle varie dipendenze dello script php

:)

 

Notizie

Registrati ora per avere pieno accesso a tutte le risorse della community , necessaria anche per area download, i link nei post, e altre funzioni.

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 5958
  • Ultimo: Sina
Statistiche
  • Post in totale: 13166
  • Topic in totale: 2964
  • Online Oggi: 439
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 253
Totale: 253

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50