Autore Topic: dubbio su yum  (Letto 3292 volte)

Offline lluuccaa

  • Newbie
  • *
  • Post: 8
    • Mostra profilo
dubbio su yum
« il: 29 Maggio 2009, 13:19:28 »
domandona
ho centos nella versione 4.4

se lancio un aggiornamento con il comendo yum, mi aggiorna anche il sistema operativo alla versione 5?

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: dubbio su yum
« Risposta #1 il: 29 Maggio 2009, 15:45:22 »
No. Aggiorna solamente i pacchetti, questo perch nella configurazione dei repository di yum c' indicato la versione del s.o. 3, 4,5  e del kernel 32 o 64 bit.


Ciao



Offline lluuccaa

  • Newbie
  • *
  • Post: 8
    • Mostra profilo
Re: dubbio su yum
« Risposta #2 il: 30 Maggio 2009, 11:05:00 »
ti ringrazio per avermi tolto questo dubbio, gestisco il server centos dall'interfaccia di webmin, dove c' un tasto con scritto "yum update" non sapevo mai quali rischi correvo ad aggiornare.

lanciandolo da webmin ho visto degli errori, che per non ho salvato, ho poi deciso di rilanciare il comando da putty in questo caso non ho degli errori ma non ho chiaro se tutto ok.

proprio brutta l'ignoranza..... com' andato l'aggiornamento secondo te?
(ti ringrazio anticipatamente per la pazienza)


Loading "fastestmirror" plugin
Setting up Update Process
Setting up repositories
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package crash.i386 0:4.0-5.0.0.1 set to be updated
---> Package tcp_wrappers.i386 0:7.6-37.4 set to be updated
---> Package openssl.i686 0:0.9.7a-43.17.el4_7.2 set to be updated
---> Package NetworkManager.i386 0:0.3.1-5.el4 set to be updated
---> Package net-tools.i386 0:1.60-39.el4 set to be updated
---> Package libpng.i386 2:1.2.7-3.el4_7.2 set to be updated
---> Package httpd.i386 0:2.0.52-41.ent.2.centos4 set to be updated
---> Package numactl.i386 0:0.6.4-1.40 set to be updated
---> Package fontconfig.i386 0:2.2.3-13.el4 set to be updated
---> Package vim-enhanced.i386 1:6.3.046-1.el4_7.5z set to be updated
---> Package tcpdump.i386 14:3.8.2-12.el4_6.1 set to be updated
---> Package sendmail.i386 0:8.13.1-3.3.el4 set to be updated
---> Package audit-libs.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package kudzu.i386 0:1.1.95.23-1 set to be updated
---> Package perl.i386 3:5.8.5-36.el4_6.3 set to be updated
---> Package librdmacm.i386 0:1.0.7-1.el4 set to be updated
---> Package coreutils.i386 0:5.2.1-31.8.el4_7.centos.1 set to be updated
---> Package ethtool.i386 0:6-1 set to be updated
---> Package ipsec-tools.i386 0:0.3.3-7.el4_7 set to be updated
---> Package libibverbs.i386 0:1.1.1-9.el4 set to be updated
---> Package dapl.i386 0:2.0.7-2.el4 set to be updated
---> Package selinux-policy-targeted.noarch 0:1.17.30-2.150.el4 set to be updated
---> Package iproute.i386 0:2.6.9-4.el4 set to be updated
---> Package bzip2.i386 0:1.0.2-14.el4_7 set to be updated
---> Package cpio.i386 0:2.5-16.el4 set to be updated
---> Package OpenIPMI.i386 0:1.4.14-1.4E.20 set to be updated
---> Package man-pages.noarch 0:1.67-15.el4 set to be updated
---> Package autofs.i386 1:4.1.3-234.el4.1 set to be updated
---> Package initscripts.i386 0:7.93.33-1.centos4 set to be updated
---> Package bind-utils.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package ash.i386 0:0.3.8-20.el4_7.1 set to be updated
---> Package elfutils-libelf.i386 0:0.97.1-5 set to be updated
---> Package OpenIPMI-libs.i386 0:1.4.14-1.4E.20 set to be updated
---> Package bind-libs.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.9.27.el4_7.5 set to be updated
---> Package ed.i386 0:0.2-36.el4_7.1 set to be updated
---> Package diskdumputils.i386 0:1.4.1-5 set to be updated
---> Package apr.i386 0:0.9.4-24.9 set to be updated
---> Package util-linux.i386 0:2.12a-20.el4 set to be updated
---> Package popt.i386 0:1.9.1-26_nonptl set to be updated
---> Package man.i386 0:1.5o1-11.el4 set to be updated
---> Package centos-release.i386 6:4-7 set to be updated
---> Package file.i386 0:4.10-5.el4 set to be updated
---> Package dhcpv6_client.i386 0:0.10-24_EL4 set to be updated
---> Package krb5-workstation.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package vim-common.i386 1:6.3.046-1.el4_7.5z set to be updated
---> Package cups.i386 1:1.1.22-0.rc1.9.27.el4_7.5 set to be updated
---> Package libacl.i386 0:2.2.23-5.4.el4 set to be updated
---> Package openldap.i386 0:2.2.13-12.el4 set to be updated
---> Package rhnlib.noarch 0:2.1.2-11.el4 set to be updated
---> Package cpp.i386 0:3.4.6-10 set to be updated
---> Package diffutils.i386 0:2.8.1-12.1.el4 set to be updated
---> Package device-mapper.i386 0:1.02.25-2.el4 set to be updated
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.52 set to be updated
---> Package libxslt.i386 0:1.1.11-1.el4_7.2 set to be updated
---> Package libsdp.i386 1:1.1.99-10.el4 set to be updated
---> Package quota.i386 1:3.12-7.el4 set to be updated
---> Package vixie-cron.i386 4:4.1-50.el4 set to be updated
---> Package rpm-libs.i386 0:4.3.3-26_nonptl set to be updated
---> Package pcre.i386 0:4.5-4.el4_6.6 set to be updated
---> Package dhclient.i386 7:3.0.1-62.EL4 set to be updated
---> Package lynx.i386 0:2.8.5-18.2.el4_7.1 set to be updated
---> Package rpmdb-CentOS.i386 2:4.7-0.20080805 set to be updated
---> Package libxml2-python.i386 0:2.6.16-12.6 set to be updated
---> Package curl.i386 0:7.12.1-11.1.el4_7.1 set to be updated
---> Package postfix.i386 2:2.2.10-1.2.1.el4_7 set to be updated
---> Package udev.i386 0:039-10.22.el4_7.1 set to be updated
---> Package mdadm.i386 0:1.12.0-5 set to be updated
---> Package mkinitrd.i386 0:4.2.1.13-1 set to be updated
---> Package slocate.i386 0:2.7-13.el4.8 set to be updated
---> Package postfix-pflogsumm.i386 2:2.2.10-1.2.1.el4_7 set to be updated
---> Package bind.i386 20:9.2.4-30.el4_7.2 set to be updated
---> Package httpd-suexec.i386 0:2.0.52-41.ent.2.centos4 set to be updated
---> Package binutils.i386 0:2.15.92.0.2-25 set to be updated
---> Package hal.i386 0:0.4.2-8.EL4 set to be updated
---> Package telnet.i386 1:0.17-31.EL4.5 set to be updated
---> Package sysklogd.i386 0:1.4.1-27.el4 set to be updated
---> Package openssh.i386 0:3.9p1-11.el4_7 set to be updated
---> Package bluez-libs.i386 0:2.10-3 set to be updated
---> Package gzip.i386 0:1.3.3-17.rhel4 set to be updated
---> Package newt.i386 0:0.51.6-10.el4 set to be updated
---> Package mod_ssl.i386 1:2.0.52-41.ent.2.centos4 set to be updated
---> Package gd.i386 0:2.0.28-5.4E.el4_6.1 set to be updated
---> Package hwdata.noarch 0:0.146.33.EL-11 set to be updated
---> Package acpid.i386 0:1.0.3-2.el4_7.1 set to be updated
---> Package openssh-clients.i386 0:3.9p1-11.el4_7 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-9_RHEL4_U7.el4 set to be updated
---> Package make.i386 1:3.80-7.EL4 set to be updated
---> Package sos.noarch 0:1.7-6.6.el4 set to be updated
---> Package bzip2-libs.i386 0:1.0.2-14.el4_7 set to be updated
---> Package libstdc++.i386 0:3.4.6-10 set to be updated
---> Package e2fsprogs.i386 0:1.35-12.17.el4 set to be updated
---> Package pdksh.i386 0:5.2.14-30.6 set to be updated
---> Package sed.i386 0:4.1.2-7.el4 set to be updated
---> Package netdump.i386 0:0.7.16-14 set to be updated
---> Package libxml2.i386 0:2.6.16-12.6 set to be updated
---> Package procps.i386 0:3.2.3-8.12 set to be updated
---> Package libuser.i386 0:0.52.5-1.el4.3 set to be updated
---> Package policycoreutils.i386 0:1.18.1-4.13 set to be updated
---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.52 set to be updated
---> Package acl.i386 0:2.2.23-5.4.el4 set to be updated
---> Package authconfig.i386 0:4.6.10-7.el4 set to be updated
---> Package python.i386 0:2.3.4-14.7.el4 set to be updated
---> Package cryptsetup.i386 0:0.1-6 set to be updated
---> Package xinetd.i386 2:2.3.13-4.5.el4 set to be updated
---> Package gcc.i386 0:3.4.6-10 set to be updated
---> Package shadow-utils.i386 2:4.0.3-66.RHEL4 set to be updated
---> Package nscd.i386 0:2.3.4-2.41.el4_7.1 set to be updated
---> Package comps.i386 2:4.7CENTOS-0.20080805 set to be updated
---> Package pam_krb5.i386 0:2.1.17-6.el4 set to be updated
---> Package libpcap.i386 14:0.8.3-12.el4_6.1 set to be updated
---> Package procmail.i386 0:3.22-14.1.el4 set to be updated
---> Package specspo.noarch 0:9.0.92-3 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.22.0.EL.4.6-1.el4 set to be updated
---> Package iputils.i386 0:20020927-21.el4 set to be updated
---> Package tcsh.i386 0:6.13-10.el4 set to be updated
---> Package bash.i386 0:3.0-19.7.el4_7.1 set to be updated
---> Package openssh-server.i386 0:3.9p1-11.el4_7 set to be updated
---> Package bluez-utils.i386 0:2.10-2.4 set to be updated
---> Package apr-util.i386 0:0.9.4-22.el4 set to be updated
---> Package rpm.i386 0:4.3.3-26_nonptl set to be updated
---> Package lvm2.i386 0:2.02.37-3.el4 set to be updated
---> Package freetype.i386 0:2.1.9-8.el4.6 set to be updated
---> Package mgetty.i386 0:1.1.31-14.el4 set to be updated
---> Package libmthca.i386 0:1.0.4-9.el4 set to be updated
---> Package kbd.i386 0:1.12-2.el4.5 set to be updated
---> Package nss_ldap.i386 0:253-5.el4_7.1 set to be updated
---> Package nfs-utils.i386 0:1.0.6-87.EL4 set to be updated
---> Package tzdata.noarch 0:2009f-1.el4 set to be updated
---> Package libselinux.i386 0:1.19.1-7.4 set to be updated
---> Package tcl.i386 0:8.4.7-4.el4 set to be updated
---> Package perl-DBI.i386 0:1.40-9 set to be updated
---> Package openib.i386 0:1.3-5.el4 set to be updated
---> Package pam.i386 0:0.77-66.25 set to be updated
---> Package logwatch.noarch 0:5.2.2-4.el4 set to be updated
---> Package vsftpd.i386 0:2.0.1-6.el4 set to be updated
---> Package krb5-libs.i386 0:1.3.4-60.el4_7.2 set to be updated
---> Package usermode.i386 0:1.74-2.el4.1 set to be updated
---> Package ftp.i386 0:0.17-23.el4_6.1 set to be updated
---> Package audit.i386 0:1.0.16-3.el4_7.1 set to be updated
---> Package setup.noarch 0:2.5.37-1.7 set to be updated
---> Package lftp.i386 0:3.0.6-4.el4 set to be updated
---> Package module-init-tools.i386 0:3.1-0.pre5.3.10 set to be updated
---> Package rp-pppoe.i386 0:3.5-22.2.RHEL4.1 set to be updated
---> Package parted.i386 0:1.6.19-22.EL set to be updated
---> Package rhpl.i386 0:0.148.6-1 set to be updated
---> Package compat-dapl-1.2.5.i386 0:2.0.7-2.el4 set to be updated
---> Package logrotate.i386 0:3.7.1-10.RHEL4 set to be updated
---> Package unzip.i386 0:5.51-10.el4 set to be updated
---> Package libtiff.i386 0:3.6.1-12.el4_7.2 set to be updated
---> Package libgcc.i386 0:3.4.6-10 set to be updated
---> Package zip.i386 0:2.3-29.EL4 set to be updated
---> Package yum.noarch 0:2.4.3-4.el4.centos set to be updated
---> Package vim-minimal.i386 1:6.3.046-1.el4_7.5z set to be updated
---> Package up2date.i386 0:4.7.1-17.el4.centos set to be updated
---> Package rpm-python.i386 0:4.3.3-26_nonptl set to be updated
---> Package at.i386 0:3.1.8-82.el4 set to be updated
---> Package net-snmp-libs.i386 0:5.1.2-13.el4_7.3 set to be updated
---> Package elfutils.i386 0:0.97.1-5 set to be updated
---> Package ncurses.i386 0:5.4-15.el4 set to be updated
---> Package db4.i386 0:4.2.52-7.3.el4 set to be updated
--> Running transaction check
--> Processing Dependency: glibc > 2.3.4-2.39 for package: pam
--> Processing Dependency: glibc >= 2.3.4-2.40 for package: authconfig
--> Processing Dependency: yum-metadata-parser for package: yum
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package yum-metadata-parser.i386 0:1.0-8.el4.centos set to be updated
--> Running transaction check
--> Processing Dependency: glibc > 2.3.4-2.39 for package: pam
--> Processing Dependency: glibc >= 2.3.4-2.40 for package: authconfig
--> Finished Dependency Resolution
Error: Missing Dependency: glibc > 2.3.4-2.39 is needed by package pam
Error: Missing Dependency: glibc >= 2.3.4-2.40 is needed by package authconfig



Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1396
    • Mostra profilo
    • Traversate dei laghi
Re: dubbio su yum
« Risposta #3 il: 31 Maggio 2009, 08:37:54 »
Non andato.
Dopo aver contollato le dipendenze dei vari pacchetti si fermato perch non hai glibc alla versione necessaria.

Error: Missing Dependency: glibc >= 2.3.4-2.40

Installa prima quello e poi procedi con l'update.

Offline lluuccaa

  • Newbie
  • *
  • Post: 8
    • Mostra profilo
Re: dubbio su yum
« Risposta #4 il: 31 Maggio 2009, 10:50:31 »
ma questo pacchetto cos importante? o posso lasciar perdere?