Autore Topic: Problema con package updater  (Letto 3129 volte)

Offline gae75

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Problema con package updater
« il: 24 Dicembre 2012, 10:50:16 »
Salve a tutti, ieri ho installato centos su un vecchio portatile acer e fin lý tutto ok; appena avviato, package updater mi dice che ci sono circa 200 aggiornamenti disponibili e lo faccio partire sennonchŔ a un certo punto si impalla tutto e non va + avanti lo riavvio e quando provo ad aggiornarlo mi da questo messaggio:
"Missing Dependency: gecko-libs = 1.9 is needed by package nspluginwrapper-0.9.91.5-21.el5.x86_64 (installed)
Missing Dependency: gecko-libs = 1.9 is needed by package nspluginwrapper-0.9.91.5-21.el5.i386 (installed)".
Altro problema, si avvia solo root. Grazie

Offline monsee

  • Full Member
  • ***
  • Post: 106
    • Mostra profilo
Re: Problema con package updater
« Risposta #1 il: 25 Dicembre 2012, 12:35:23 »
Hai un problema di dipendenze fra pacchetti.
La miglior cosa -a parer mio- Ŕ quella di deselezionare l'aggiornamento del pacchetto incriminato (controlla il nome tu, ma dovrebbe avere a che fare strettamente con "gecko").
Il fatto che si avvii soltanto come root mi suona assai bizzarro.
... Hai provveduto a creare anche un User? (o l'hai scordato, al primo avvio?)

Buon Natale!  :)

Offline gae75

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Re: Problema con package updater
« Risposta #2 il: 25 Dicembre 2012, 20:38:15 »
user creato, ma inserito nome utente e passwd mi fa vedere per pochi secondi il desktop e poi torna al men¨ di login.

Offline monsee

  • Full Member
  • ***
  • Post: 106
    • Mostra profilo
Re: Problema con package updater
« Risposta #3 il: 26 Dicembre 2012, 14:12:27 »
Non so davvero cosa dirti  ??? ... se fossi al posto tuo, mi sa che rifarei daccapo l'installazione (badando a crear l'Utente al momento dovuto).

Offline gianlucaceci

  • Newbie
  • *
  • Post: 8
    • Mostra profilo
Re: Problema con package updater
« Risposta #4 il: 05 Gennaio 2013, 13:59:23 »
Ciao il problema Ŕ molto semplice la versione di Centos che hai installato non ha i driver corretti per la scheda grafica che ha il tuo vecchio pc quindi ti conviene settare il boot in shell editando il file /etc/inttab e portare il valore 5 di questa riga a 3 id:5:initdefault:

Poi fai fare gli aggiornamenti se si dovesse replicare l'errore allora ti sarÓ sufficiente usare l'opzione "yum --exclude=packagename" :)

Gianluca