* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
20 Luglio 2019, 05:37:43

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: MB Asus P5M2 con vecchia Ubuntu preinstallata  (Letto 2542 volte)

Offline Aliberto

  • Newbie
  • *
  • Post: 3
    • Mostra profilo
MB Asus P5M2 con vecchia Ubuntu preinstallata
« il: 06 Marzo 2014, 12:47:29 »
Ciao a tutti, mi scuso in anticipo per la newbaggine XD

Ho ereditato un serverino Asus con MB P5M2 con sistema raid hw ed una vecchia distribuzione di Ubuntu installata sopra. In azienda ho installato su diversi server Asus vergini la Centos 6.5 senza nessun problema, ma quando provo su questa ho un errore all'avvio dell'installazione dopo il seguente avviso:
Citazione
disks sda,sdb contains BIOS RAID metadata but are not part of any recognized
BIOS RAIDsets.  Ignoring disks sda, sdb
una finestra di dialogo mi dice:
Citazione
anaconda 13.21.82 exception report
Traceback (most recent call first)
File "/usr/lib/anaconda/iw/cleardisks_gui.py", line 154, in getScreen
. .. ... IndexError: list index out of range
Ho smanettato su google ed ho trovato commenti tipo questi:
Citazione
Then I left dd running at the end of the day to write zeros right
to the end of the drives.  (WARNING: the following command wipes all data
from disks, including partition tables...)
# dd if=/dev/zero of=/dev/sda bs=8192
# dd if=/dev/zero of=/dev/sdb bs=8192
Citazione
May also need to boot from rescue media and remove the BIOS FakeRAID metadata from the disks using
Code: Select all
    dmraid -r -E /dev/sdX

Ed ora le domande da niubbo, è necessario avviare la macchina con una live per eseguire questi comandi? In alcuni siti li consigliano entrambi in altri solo gli uni o gli altri, quali uso? In alternativa posso risolvere da Bios o agendo direttamente sulla MB a livello Hardware? Non ho capito una mazza del problema e sono fuori strada XD?

Grazie in anticipo per le gradite risposte, Aliberto

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re:MB Asus P5M2 con vecchia Ubuntu preinstallata
« Risposta #1 il: 06 Marzo 2014, 14:52:45 »
raid hw su una mb del genere è, al 99,99%, un fake-raid

entra nel bios, stronca il raid hw, usa i dischi singoli e lascia che sia centos a creare il raid sw

Offline Aliberto

  • Newbie
  • *
  • Post: 3
    • Mostra profilo
Re:MB Asus P5M2 con vecchia Ubuntu preinstallata
« Risposta #2 il: 08 Marzo 2014, 08:37:19 »
Ancora niente, ho fatto questi tentativi. Il bios sera andato, nel senso che la MB aveva la batteria scarica e si erano perse tutte le impostazioni, ho caricato quelle di default e settato come IDE i dischi invece che come RAID, niente da fare stesso errore. Allora ho creato il raid hw da bios, c'è' proprio uno switch sulla mb per le due modalità (winzoz/redhat) che mi ha fatto avviare uno softwarino al boot con cui ho creato il tutto, anche in questo caso stesso errore, sembra quasi che il programma di installazione trovi traccia nel disco di una configurazione raid che però poi non gli risulta non si capisce bene dove. Allora preso da sconforto ho tolto il radi, rimosso fisicamente un disco, ed ho formattato in NTFS ed installato su una vecchia copia di XP, nel senso che ora se starto la macchina da HD parte XP regolarmente!  ... bene ... se metto il DVD con la Centos stesso errore!!!  :o

Cosa posso provare?  aggiorno il bios?

edit: orzunque ..... purtroppo penso sia un bugghino, e questo è un problema porca piseriaccia. Ho tolto fuori dal cassetto la Centos 5.5 .... e l'ho installata perfettamente senza nessun problema!! Il sistema ora è perfetto, ma quando provo ad installare la 6 sempre la solita scritta "Disk sda contains BIOS RAID metadata, but is not party of any recognized BIOS RAID sets. Ignoring disk sda.". Nel log verso la fine ci sono le scritte:

INFO : Running... ['dmsetup','info','--columns','--noheadings','-o','devno','/dev/sr0']
ERROR : Device sr0 not found
ERROR : Command failed

Com'è possibile che la 5.5 si installi perfettamene e la 6 no?  :(

« Ultima modifica: 08 Marzo 2014, 09:43:10 di Aliberto »

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1339
    • Mostra profilo
    • Traversate dei laghi
Re:MB Asus P5M2 con vecchia Ubuntu preinstallata
« Risposta #3 il: 08 Marzo 2014, 10:53:50 »
Mi è capitato con un paio di dischi ma non è un bug. A memoria non ricordo il comando dovrei vedere lunedì in ufficio se me lo sono appuntato.
In sostanza si avvia in modo da avere una Shell e poi si da il comando per cancellare dal disco i dati del raid.

Inviato dal mio GT-I9505 utilizzando Tapatalk


Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1339
    • Mostra profilo
    • Traversate dei laghi
Re:MB Asus P5M2 con vecchia Ubuntu preinstallata
« Risposta #4 il: 10 Marzo 2014, 11:17:43 »
dmraid -r -E /dev/tuodisco

Do you really want to erase “pdc” ondisk metadata on /dev/sdc ? [y/n] :
ovviamente rispondi con yes!
Con un disco ho dovuto eseguirlo due volte.

Offline Aliberto

  • Newbie
  • *
  • Post: 3
    • Mostra profilo
Re:MB Asus P5M2 con vecchia Ubuntu preinstallata
« Risposta #5 il: 11 Marzo 2014, 09:10:17 »
Ha funzionato, grazie mille  :)

 

Notizie

NON REGISTRATEVI CON EMAIL HOTMAIL/LIVE/OUTLOOK SPESSO NON ARRIVANO LE MAIL

Collegamenti

Posts Recenti

Utenti
Statistiche
  • Post in totale: 13004
  • Topic in totale: 2917
  • Online Oggi: 244
  • Massimi online: 975
  • (03 Novembre 2018, 08:19:28)
Utenti Online
Utenti: 0
Visitatori: 254
Totale: 254

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

inetryconydot

08 Settembre 2017, 07:44:23

inetryconydot

20 Maggio 2017, 10:00:13
Stromectol is used for treating infections caused by certain parasites. Stromectol is an anthelmintic. It works by killing sensitive parasites.
 
Stromectol as known as: Ivectin, Ivenox, Ivera, Ivergot, Ivermec, Ivermectina, Ivermectine, Ivermectinum, Ivert, Ivexterm, Kilox, Mectizan, Quan

Mostra ultimi 50