Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - INVY

Pagine: [1] 2
1
Server / MySQL 5.5 e memcached
« il: 09 Novembre 2015, 18:01:41 »
Ciao,

qualcuno ha già implementato memcached  su MySQL 5.5?



2
Supporto Generale / Controllo stato dei dischi raid
« il: 27 Aprile 2014, 12:13:52 »
Su una macchina con Linux Centos come posso fare per controllare/monitorare lo stato dei dischi raid? cioè, essere avvisato se un disco è prossimo alla rottura?

Grazie per gli eventuali consigli :-)

3
Server / error_log: disabilitare tutti i warn
« il: 02 Febbraio 2014, 10:52:43 »
Ciao,

vorrei che il file error_log contenesse solo gli [error] e non i [warn], nessun [warn] di alcun genere.

ho inserito nel file php.ini il comando:

error_reporting = E_ALL & ~E_WARNING & ~E_DEPRECATED

e riavviato httpd, ma nei log si registrano ancora dei [warn]

Dove sbaglio?

4
Supporto Generale / Error: Multilib version problems found.
« il: 08 Dicembre 2013, 23:25:19 »
Ciao,

mi trovo questo errore durante l'aggiornamento:

Codice: [Seleziona]

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for nss-softokn-freebl which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of nss-softokn-freebl of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude nss-softokn-freebl.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of nss-softokn-freebl installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of nss-softokn-freebl installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: nss-softokn-freebl-3.14.3-9.el6.x86_64 != nss-softokn-freebl-3.14.3-3.el6_4.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

e non ne vengo fuori...

Qualche consiglio? grazie :-)

5
Server / Aggiornamento PHP non riuscito
« il: 27 Febbraio 2013, 07:31:19 »
Ciao,

su un server con CentOS6.3 - con reposity atomic attivato oltre che quelli di default - ho provato ad aggiornare PHP dalla versione 5.3.21 alla 5.3.22, cosa che ho eseguito su altri server senza problemi, ma non ci sono riuscito per via di "Protected multilib versions":

Loading mirror speeds from cached hostfile
 * atomic: mir01.syntis.net
 * base: mirrors.prometeus.net
 * extras: mirrors.prometeus.net
 * updates: mirrors.prometeus.net
183 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
....
Error: Protected multilib versions: php-common-5.3.22-15.el6.art.x86_64 != php-common-5.3.21-14.el6.art.i686
Error: Protected multilib versions: php-5.3.21-14.el6.art.i686 != php-5.3.22-15.el6.art.x86_64
Error: Protected multilib versions: php-cli-5.3.21-14.el6.art.i686 != php-cli-5.3.22-15.el6.art.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
.. install failed!

No packages were installed. Check the messages above for the cause of the error.

Prima di combinare guai, mi date delle "dritte" su come proseguire?

Grazie :-)

6
Server / killare processi httpd in caso di sovraccarico...
« il: 11 Febbraio 2013, 09:44:53 »
Ciao a tutti,

a volte capita che un server abbia dei sovraccarichi e che il riavvio automatico di httpd avvenga solo proprio quando il server non ce la fa più...

Così ho pensato a uno script che ogni tot di tempo controlli il carico e nel caso esegua un killall dei processi httpd.

A voi chiedo: può essere una buona soluzione?

Vi posto li script con le varianti di "killaggio", così mi date un parere:

Codice: [Seleziona]

#!/bin/sh
checkload=`uptime | cut -d, -f4 | cut -d: -f2 | cut -d. -f1`
if [ $checkload -ge 10 ]
then

#/etc/init.d/httpd restart
# kill -9 `ps -ef | grep ?httpd? | grep -v grep | awk ?{print $2}?`
# killall -HUP httpd
 killall -9 httpd


echo "Killing httpd processes - Load Average $checkload" | mail -s "Load Monitor" mia@email.xx
fi



Quale "killaggio" è consigliato?

#/etc/init.d/httpd restart
# kill -9 `ps -ef | grep ?httpd? | grep -v grep | awk ?{print $2}?`
# killall -HUP httpd
# killall -9 httpd

Grazie e buona navigazione

7
Hardware / WARNING: Kernel Errors Present
« il: 08 Luglio 2012, 08:17:41 »
Ciao,

ho ricevuto il report Logwatch con questo avviso:

WARNING: Kernel Errors Present
Add. Sense: Unrecovered read error ...: 1916 Time(s)
sd 0:1:0:0: SCSI error: return code = 0 ...: 6146 Time(s)
sda: Current: sense key: Medium Error ...: 6146 Time(s)


come di devo comportare?


8
Sicurezza / escludere directory clamav
« il: 20 Marzo 2012, 10:28:36 »
Ciao,

attualmente lancio clamav con il seguente comando:

clamscan -ri /var/www/vhosts/

ma vorrei escludere tutte le sottodirectory

/var/www/vhosts/NomeDominio/statistics/

per evitare di fargli fare la scansione dei vari file di log ecc.

Poichè i domini sono diversi, non posso indicare tutte le sottodirecotry /var/www/vhosts/NomeDominio/statistics/ una a una per l'esclusione: esiste un comando solo che mi può fare questo?

Grazie :-)

9
Server / ffmpeg ecc.
« il: 21 Agosto 2011, 11:24:08 »
Ciao a tutti,

si è provveduto ad installare su un server CentOS 5.6 (e con PLESK) ffmpeg, lame, Libogg + Libvorbis, Mencoder, flvtool2, FFMpeg-PHP e tutto è andato a buon fine.

L'applicativo phpmotion che utilizza tutta "sta roba" funziona, nessun problema... ma...

Perchè ogni volta che si installa phpmotion o altro applicativo nelle schermate di avvio, quando controllano se i requisiti ci sono, indicano sempre che non è installato ffmpeg, mencoder, flvtool2? i percorsi sono corretti (/usr/bin/ffmpeg /usr/bin/flvtool2 /usr/bin/mencoder) e se si fa infophp appare installato e caricato FFMpeg-PHP.


Il codice di un applicativo, che esegue il controllo dei requisiti, è:

Codice: [Seleziona]
case "ffmpeg":
{
$ffmpeg_path = exec("which ffmpeg");
$ffmpeg_version = shell_output("$ffmpeg_path -version");

$version = false;
preg_match("/SVN-r([0-9]+)/i",$ffmpeg_version,$matches);
if(@$matches[1])
$version = 'r'.$matches[1];
preg_match("/version ([0-9.]+)/i",$ffmpeg_version,$matches);
if(@$matches[1])
$version = $matches[1];

if(!$version)
$return['err'] = _("Unable to find ffmpeg");
else
$return['msg'] = sprintf(_("Found FFMPEG %s : %s"),$version,$$ffmpeg_path);
}
break;

Su un altro server CentOS 5.6 SENZA PLESK invece il riconoscimento avviene senza problemi.

Cosa ci sfugge? Grazie per i suggerimenti:-)

10
Supporto Generale / Rotazione Log MySQL
« il: 16 Giugno 2011, 11:03:23 »
Ciao,

ho notato che ho un LOG MYSQL di ben 400 MByte... non c'è un modo di rendere automatica una rotazione dei log di MySQL?

Grazie  :)

11
Supporto Generale / WARNING: Kernel Errors Present....
« il: 11 Giugno 2011, 09:10:05 »
Ricevo da Logwatch:

 --------------------- Kernel Begin ------------------------

 
 WARNING:  Kernel Errors Present
        Add. Sense: Unrecovered read error ...:  1 Time(s)
    end_request: I/O error, dev sdb, sector ...:  1 Time(s)
    sd 1:0:0:0: SCSI error: return code = 0 ...:  1 Time(s)
    sdb: Current: sense key: Medium Error ...:  1 Time(s)
 
 ---------------------- Kernel End -------------------------

in parole povere... cosa dovrei fare?

12
Supporto Generale / Logwatch limitato
« il: 24 Maggio 2011, 09:22:36 »
Ciao a tutti  :)

su un server Logwatch mi funziona limitato, cioè non mi inviata più tutte le varie informazioni ma solo alcune. Non ho effettuato particolari interventi sul server (centos 5.5 aggiornato a 5.6, con installato PLESK 8.6), solo i soliti aggiornamenti che ho eseguito anche su altri server nello stesso modo.

Ho controllato i log (/var/log/*) notando che su questo server sono vuoti i log messages (1, 2, 3) e cron (1,2,3). Allego immagini di un server con i log "pieni" e di quello "vuoto".

Cosa può essere successo? come rimediare?

Grazie per i suggerimenti!

13
Ciao,

ho effettuato oggi l'aggiornamento di un server con Centos 5.5 (aggiornatissimo fino a una settimana fa) con circa 150 pacchetti vari e l'upgrade a centos 5.6

Il server ha installato PLESK 8.6 per la gestione dei domini.

Tutto sembra filato liscio (ho eseguito l'upgrade suddividendo i pacchetti, tralasciando solo l'upgrade a php 5.3) ma su selinux-policy è apparso tutto questo che vi riporto:

..........................
Now updating selinux-policy ..

      Installing package(s) with command yum -y install selinux-policy ..

      Loaded plugins: dellsysid, fastestmirror
      Loading mirror speeds from cached hostfile
       * addons: mirrors.prometeus.net
       * atomic: www6.atomicorp.com
       * base: mirrors.prometeus.net
       * extras: mi.mirror.garr.it
       * updates: mirrors.prometeus.net
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      --> Processing Dependency: selinux-policy = 2.4.6-279.el5_5.2 for package: selinux-policy-targeted
      ---> Package selinux-policy.noarch 0:2.4.6-300.el5 set to be updated
      --> Running transaction check
      ---> Package selinux-policy-targeted.noarch 0:2.4.6-300.el5 set to be updated
      --> Finished Dependency Resolution

      Dependencies Resolved

      ================================================================================
       Package                      Arch        Version               Repository
                                                                                 Size
      ================================================================================
      Updating:
       selinux-policy               noarch      2.4.6-300.el5         base      414 k
      Updating for dependencies:
       selinux-policy-targeted      noarch      2.4.6-300.el5         base      1.2 M

      Transaction Summary
      ================================================================================
      Install       0 Package(s)
      Upgrade       2 Package(s)

      Total download size: 1.6 M
      Downloading Packages:
      --------------------------------------------------------------------------------
      Total                                           4.3 MB/s | 1.6 MB     00:00     
      Running rpm_check_debug
      Running Transaction Test
      Finished Transaction Test
      Transaction Test Succeeded
      Running Transaction
        Updating       : selinux-policy                                           1/4
        Updating       : selinux-policy-targeted                                  2/4


XXXXXX homedir /var/www/vhosts/NomeDominio or its parent directory conflicts with a
defined context in /etc/selinux/targeted/contexts/files/file_contexts,
/usr/sbin/genhomedircon will not create a new context.
This usually indicates an incorrectly defined system account. 
If it is a system account please make sure its login shell is /sbin/nologin.

Cleanup        : selinux-policy-targeted                                  3/4
  Cleanup        : selinux-policy                                           4/4

Updated:

Dependency Updated:

Complete!

.. install complete.
........................................

Ho riportato l'avviso di conflitto solo per un dominio, ma questo era ripetuto per tutti i domini residenti sul server.

Attualmente pare che non ci siano problemi, ma devo preoccuparmi per questi conflitti?

Grazie per le risposte  :)

14
Lancio l'installazione di un programma (centova) e mi esce questo:

# ./install.sh
which: no useradd in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin)
Error: Installer requires a working copy of the useradd utility in your path.

Che faccio? che vuole dire?


15
Ciao a tutti,

mi capita questo:

----------------------------------------------------
# php -v
Failed loading /usr/lib64/php/modules//php_ioncube_loader_lin_5.1_x86_64.so:  /usr/lib64/php/modules//php_ioncube_loader_lin_5.1_x86_64.so: undefined symbol: zend_unmangle_property_name_ex
PHP 5.2.16 (cli) (built: Dec 19 2010 11:52:45)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with eAccelerator v0.9.6-svn358-dev, Copyright (c) 2004-2007 eAccelerator, by eAccelerator
    with the ionCube PHP Loader v3.3.20, Copyright (c) 2002-2010, by ionCube Ltd.
-----------------------------------------------------

se cambio nel file /etc/php.d/ioncube-loader.ini

zend_extension=/usr/lib64/php/modules//php_ioncube_loader_lin_5.1_x86_64.so

in

zend_extension=/usr/lib64/php/modules//php_ioncube_loader_lin_5.2_x86_64.so

mi capita questo:

-----------------------------------------------------
# php -v
PHP Warning:  Module 'ionCube Loader' already loaded in Unknown on line 0
The ionCube PHP Loader is disabled because of startup problems.
Segmentation fault
-----------------------------------------------------

come risolvere?

Grazie :-)

Pagine: [1] 2