Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - morph3us

Pagine: [1] 2
1
Problemi di Installazione / Re:Crontab e script php
« il: 05 Agosto 2021, 16:43:46 »
Ciao, si anche io per alcuni giorni non sono riuscito ad accedere, grazie cmq per la tua risposta.

Ho risolto cosi

12 7 * * * /usr/bin/curl http://10.1.1.41/scalare/mailScalare.php

dove in pratia mi pare di aver capito che la 8 non volgia indicato lo user ed ho optato per curl onde evitare i problemi di percosi delle varie dipendenze dello script php

:)

2
Problemi di Installazione / Crontab e script php
« il: 24 Luglio 2021, 11:18:51 »
CIao,
ho un problema di questo tipo:
schedulato su crontab il lncio di uno script php tramite
Codice: [Seleziona]
55 16 * * * root  /usr/bin/php /var/www/html/scalare/mailScalare.php >> /var/log/controllaScalare.log
ma purtroppo incappo inquest errore
Codice: [Seleziona]
PHP Warning:  require(/vendor/autoload.php): Failed to open stream: No such file or directory in /var/www/html/scalare/mailScalare.php on line 12
PHP Fatal error:  Uncaught Error: Failed opening required '/vendor/autoload.php' (include_path='.:/usr/share/pear:/usr/share/php:/usr/share/pear:/usr/share/php') in /var/www/html/scalare/mailScalare.php:12
Stack trace:
#0 {main}
  thrown in /var/www/html/scalare/mailScalare.php on line 12

come posso risolvere?

PS
lo script lanciato a mano da browser funziona correttamente ed il cron tab eseue la sua schedula

3
Problemi di Installazione / Re:Configurazione nuovo server
« il: 08 Gennaio 2014, 11:29:26 »
Ciao, ti lascio mio contatto skyoe cosi ne parliamo meglio

francesco@fradage.it

by mobile...


4
Server / Re:problemi avvio open ldap
« il: 13 Novembre 2013, 15:07:39 »
ok, diciamo che sono riuscito a reinstallarlo, dopo aver semi distrutto il server!!
cmq adesso se non altro incorro in:

ldap_bind: Invalid credentials (49)

ovviamente dopo che il servizio si avvia (incongruente con webmin, ma lo ignoro)

sto provando a seguire questo how-to:  http://www.howtoforge.com/linux_openldap_setup_server_client

5
Server / Re:problemi avvio open ldap
« il: 13 Novembre 2013, 08:47:27 »
accidenti qui faccio brutta figura e mstro tutta la mia incompetenza... ho lanciato make uninstall ma ottengo:

make: *** No rule to make target `uninstall'.  Stop.

Sono fragato vero? Non mi resta che eliminare tutte le cartelle a manina?

6
Server / Re:problemi avvio open ldap
« il: 12 Novembre 2013, 16:10:42 »
ehmm piccolo particolare... mi sono accorto che la cartella slap.d non esiste pi!! Ho provato a copiarla da un altra installazione ma il servizio non parte ancora, se controllo lo status mi dice : slapd inattivo ma subsys bloccato

 ::) ::)

7
Server / Re:problemi avvio open ldap
« il: 12 Novembre 2013, 10:46:22 »
ehm scusate nella fretta/disperazione sono stato un po troppo sintetico  :'(

dunque, ho installato sia com yum i pacchetti openldap che scaricato e compilato il tutto, eseguento un make test non ottengo errori e quindi suppongo che tutto possa funzionare.

nel path /etc/openldap ho il file di conf mente in  /usr/local/etc/openldap/ ho la dir schema.
da prima il servizio si avviava ma avevo problemi di autenticazione e permessi, cosi ho impostato come prorpietario ldap e sono riuscito a far eseguire ldaptest senza errori, ma per contro adesso non parte il servizio slapd.
la cosa assurda e che da webmin il servizio sembra attivo mentre in realta non lavora ed ottengo errori ad ogni tentativo di modifica. Non so se mi son spiegato molto bene ma anche io capisco proprio poco!!!

log da postare non ne ho in quanto non ottengo errori se non un 'Avvio di slapd: [FALLITO]' oppure  'slaptest
5281fa23 bdb_monitor_db_open: monitoring disabled; configure monitor database to enable
config file testing succeeded'

il file di conf non stato ancora modificato.



8
Server / problemi avvio open ldap
« il: 12 Novembre 2013, 09:08:51 »
Ciao,
sto provando ad installare openldap su una macchina centos 6 64bit, ma proprio non riesco a far partire il servizio,  ho provato sia a compilare il pacchetto che ad eseguire l'installazione con yum, credo di aver pasticciato non poco la macchina!!! Possibile rimuovere tutto completamente e ripartire da zero? o in alternativa qualche anima pia che mi voglia aiutare?

ps
sono ad un passo dal reinstallare il s.o.  :-X

grazie a tutti

9
Problemi di Installazione / Re: Crontab Aiuto
« il: 22 Febbraio 2012, 09:34:03 »
Ciao, mi intrometto anche io con lo stesso problema.

vediamo di essere chiari:

- creato uno script nel percorso /var/Script
- chmod -x script.sh

lancio lo script /var/Script/./script.sh  e tutto va alla perfezione
edito il file /etc/crontab oppure utilizzo crontab -e

schedulo l'operazione

15 13 * * * root /varScript/script.sh > /dev/null

e mi aspetto che alle 13.15 di ogni giorno il server mi esegua il mio script. nel log /var/log/cron:

crontab[11213]: (root) BEGIN EDIT (root)
crontab[11213]: (root) REPLACE (root)
crontab[11213]: (root) END EDIT (root)
crond[1684]: (root) RELOAD (/var/spool/cron/root)
crontab[11289]: (root) LIST (root)
CROND[11300]: (root) CMD (root /var/Script/script.sh > /dev/null)

ma ovviamente non ho risultati  :'(
questo lo script:

Codice: [Seleziona]
echo prova >fra.log
ll > fra1.log
mount 10.1.1.193:public /mnt/nas

non mi sembra nulla di cosi difficile, ma proprio nn riesco a farlo eseguire.....



10
scusa ma..
macchina SME server 8, centos5 based (usa gli rpm di centos5).. a 32bit, ma penso cambi poco:

Codice: [Seleziona]
[root@sviluppo ~]# yum --enablerepo=epel install freetds
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: mirror.silyus.net
 * epel: ftp.nluug.nl
 * smeaddons: ftp.nluug.nl
 * smeextras: ftp.nluug.nl
 * smeos: ftp.nluug.nl
 * smeupdates: ftp.nluug.nl
 * updates: mirrors.ircam.fr
epel                                                                                                                                             | 3.7 kB     00:00     
epel/primary_db                                                                                                                                  | 3.1 MB     00:02     
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package freetds.i386 0:0.91-1.el5 set to be updated
--> Processing Dependency: libodbcinst.so.1 for package: freetds
--> Processing Dependency: libodbc.so.1 for package: freetds
--> Running transaction check
---> Package unixODBC.i386 0:2.2.11-7.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================================
 Package                                  Arch                                 Version                                       Repository                            Size
========================================================================================================================================================================
Installing:
 freetds                                  i386                                 0.91-1.el5                                    epel                                 987 k
Installing for dependencies:
 unixODBC                                 i386                                 2.2.11-7.1                                    base                                 832 k

Transaction Summary
========================================================================================================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 1.8 M
Is this ok [y/N]:

quindi evidentemente un problema nella tua configurazione


no un problema di ignoranza ed incompetenza  :'( :'(
mi sono andato ad incasinare seguendo la guida di php ma avendo scarse conoscenze....... mi perdevo nel compilare
installando la repo epel incorrevo in problemi di dipendenza....

ho risolto cosi

RI-RIFORMATTATO
installata la repo atomic
eseguito un bel update
e magicamente  trovo freetds e phpmssql pronti da installare
yum install freetds php-mssql
service httpd restart
e tutto funziona a meraviglia!!!!!!!

scusate lo sfogo ma dopo tre giorni mi prenderei a schiaffi da solo.. grazie comunque a tutti

11
intanto grazie per la pazienza....
ma con yum non ho la possibilit di installare ne la libreria ne freetds e php-mssql non lo trova se non aggiungendo come mi hai consigliato epel

 ??? ???

12
Ciao, torno alla carica scusate ma proprio non ne vengo a capo!!!!

allora ho formattato e  macchina pulita provato ad installare la libreria seguendo la guida di php.net

scarico il pacchetto freetds e lo installo correttamente (scompatta, compila ed installa)
scarico i sorgenti di php ma dopo essere entrato in ext/mssql ed aver eseguito phpize
scrivo make e pufff

Codice: [Seleziona]
/bin/sh /var/download/php-5.3.9/ext/mssql/libtool --mode=compile cc  -I. -I/var/download/php-5.3.9/ext/mssql -DPHP_ATOM_INC -I/var/download/php-5.3.9/ext/mssql/include -I/var/download/php-5.3.9/ext/mssql/main -I/var/download/php-5.3.9/ext/mssql -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/usr/local/freetds/include  -DHAVE_CONFIG_H  -g -O2   -c /var/download/php-5.3.9/ext/mssql/php_mssql.c -o php_mssql.lo
libtool: compile:  cc -I. -I/var/download/php-5.3.9/ext/mssql -DPHP_ATOM_INC -I/var/download/php-5.3.9/ext/mssql/include -I/var/download/php-5.3.9/ext/mssql/main -I/var/download/php-5.3.9/ext/mssql -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/usr/local/freetds/include -DHAVE_CONFIG_H -g -O2 -c /var/download/php-5.3.9/ext/mssql/php_mssql.c  -fPIC -DPIC -o .libs/php_mssql.o
/var/download/php-5.3.9/ext/mssql/php_mssql.c:181: error: ‘PHP_FE_END’ undeclared here (not in a function)
/var/download/php-5.3.9/ext/mssql/php_mssql.c: In function ‘php_mssql_do_connect’:
/var/download/php-5.3.9/ext/mssql/php_mssql.c:767: warning: cast from pointer to integer of different size
/var/download/php-5.3.9/ext/mssql/php_mssql.c: In function ‘php_mssql_get_column_content_without_type’:
/var/download/php-5.3.9/ext/mssql/php_mssql.c:1120: warning: passing argument 1 of ‘spprintf’ from incompatible pointer type
/usr/include/php/main/spprintf.h:40: note: expected ‘char **’ but argument is of type ‘unsigned char **’
make: *** [php_mssql.lo] Error 1

accidenti  :-[
con la repo epel invece credo di far solo dei pasticci.....


13
ALT!

se ti si chiede "che riga di comando usi?" dovresti scrivere qui la riga di comando, altrimenti non andiamo lontano..

se poi incolli, oltre che la riga, tutte le successive fino al nuovo prompt, meglio

grazie

chiedo venia  :)


rpm -Uvh epel-release-5-4.noarch.rpm
e poi
yum install php....
o
yum install freetds

ma incappo nello stesso errore, cerca il file sopra citato

mentre se provo a manina seguendo php.net
phpize
'command not found' nonostante abbia installato php-devel

spero d esser stato un pochino pi chiaro

14
come lo stai installando? che riga di comando usi? che procedimento hai seguito?

lo sto installando come root da shell procedure credo di averle provate tutte partendo dalla pi chiara di php.net passando per alcune in rete e per il sito di freetds

15
grazie, ho fatto alcuni passi avanti ma ancora mi blocco a wquesto:

Error: Package: freetds-0.91-1.el5.x86_64 (epel)
           Requires: libodbcinst.so.1()(64bit)
Error: Package: freetds-0.91-1.el5.x86_64 (epel)
           Requires: libgnutls.so.13()(64bit)
Error: Package: freetds-0.91-1.el5.x86_64 (epel)
           Requires: libgnutls.so.13(GNUTLS_1_3)(64bit)
Error: Package: php53-mssql-5.3.3-1.el5.x86_64 (epel)
           Requires: php53-pdo >= 5.3.3
Error: Package: freetds-0.91-1.el5.x86_64 (epel)

sapessi dove trovare questi file credo che riuscirei a risolvere

Pagine: [1] 2