Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - matteo78it

Pagine: [1] 2
1
Server / installazione vsftp
« il: 12 Settembre 2011, 17:09:43 »
Salve ,

stò cercando d' installare vsftp sul mio server però mi mi dice che il pacchetto non è diponibile:

Citazione
[root@matteocolombini ~]# yum list installed | grep ftp
ftp.x86_64                             0.17-35.el5                     installed
lftp.x86_64                            3.7.11-4.el5_5.3                installed

come posso installarlo ? Grazie

2
Server / Re: cambiare porta di apache
« il: 04 Settembre 2011, 13:28:35 »
non lo so, visto che non sappiamo la tua configurazione..

ma la mia domanda era: spiega perchè devi spostare apache sulla 8080 e non come hai fatto.. spesso la soluzione ad un problema non è la prima che viene in mente..

Bastava dirlo .......

Comunque mi server sposare apache sulla 8080 dato che sulla 80 ci voglio mettere Nginx per fargli fare da reverse proxy ad apche come descritto in questa guida :

http://www.salaserver.com/10514/configurare-nginx-come-reverse-proxy-per-apache/

3
Server / Re: cambiare porta di apache
« il: 04 Settembre 2011, 10:53:25 »
spiega il problema, non la soluzione, grazie

Bha ......

Comunque vediamo se riesco ad essere ANCORA più chiaro .

Come mai se sposto la porta di ascoto di apache dalla 80 alla 8080 non viene visulizzato più la index del sito tenedo conto che tale porta non è bloccata da nessun firewall ?

4
Server / cambiare porta di apache
« il: 03 Settembre 2011, 13:41:16 »
Ciao ,

stoc ercando di cambiare la porta di ascolto di apache da 80 a 8080 .

Modifico il listan su httpd.conf riavvio apache però non mi visualizza la index , mentre se la riporto sulla 80 non ci sono problemi .

Come posso risolvere ?

La porta non è chiusa nel sul firewall hw neè su iptables

5
Server / Re: con flitto php53-common whith php-common
« il: 11 Agosto 2011, 13:47:31 »
allorsa è semplice: devi abilitare il repo che hai usato per installare quella versione di php (non standard su centos) ed installare gli rpm necessari..

tu stai dicendo al sistema di installarti php usando i repo standard.. ecco che nasce il conflitto

ok grazie . Risolto , tutto !!!! ;D

6
Server / Re: con flitto php53-common whith php-common
« il: 11 Agosto 2011, 12:02:04 »
spiega cosa devi fare.. hai già php a bordo.. cosa vuoi ottenere?

Si ho già installato php 5.3
Citazione
[root@matteocolombini ~]# php -v
PHP 5.3.3 (cli) (built: Mar 30 2011 13:51:54)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

mi server per farci girare drupal 7 . Senza alcune librerie  :dom ;  gd ; pdo non mi prosegue nell' installazione .

Ho provato a cercarle con il comando che trovi nel primo post ma come vedi mi nasce questo conflitto tra le due librerie .

Ho provato anche con un yum upgrade con riavvio ma non cambia nulla

7
Server / con flitto php53-common whith php-common
« il: 11 Agosto 2011, 10:11:30 »
Ciao ,

per necessità ho dovuto installare php5.3 e non ci sono stati problemi .

Ora però mi si è creato il conflitto in oggetto e non sò come rimediare

Citazione
[root@matteo ~]# yum install php*
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.crazynetwork.it
 * extras: centos.crazynetwork.it
 * updates: centos.crazynetwork.it
Setting up Install Process
Package php53-5.3.3-1.el5_6.1.x86_64 already installed and latest version
Package php-dbase is obsoleted by php-common, trying to install php-common-5.1.6-27.el5_5.3.x86_64 instead
Package php53-cli-5.3.3-1.el5_6.1.x86_64 already installed and latest version
Package php53-common-5.3.3-1.el5_6.1.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-bcmath.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-cli.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-common.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-dba.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-devel.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: autoconf for package: php-devel
--> Processing Dependency: automake for package: php-devel
---> Package php-gd.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-imap.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: libc-client.so.1()(64bit) for package: php-imap
---> Package php-ldap.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-mbstring.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-mcrypt.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt
---> Package php-mhash.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: libmhash.so.2()(64bit) for package: php-mhash
---> Package php-mssql.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: libsybdb.so.5()(64bit) for package: php-mssql
---> Package php-mysql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-ncurses.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-odbc.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: libodbc.so.1()(64bit) for package: php-odbc
---> Package php-pdo.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-pear.noarch 1:1.4.9-6.el5 set to be updated
---> Package php-pear-Auth-SASL.noarch 0:1.0.2-4.el5.centos set to be updated
---> Package php-pear-DB.noarch 0:1.7.13-1.el5.centos set to be updated
---> Package php-pear-Date.noarch 0:1.4.7-2.el5.centos set to be updated
---> Package php-pear-File.noarch 0:1.2.2-1.el5.centos set to be updated
---> Package php-pear-HTTP-Request.noarch 0:1.4.2-1.el5.centos set to be updated
---> Package php-pear-Log.noarch 0:1.9.13-1.el5.centos set to be updated
---> Package php-pear-MDB2.noarch 0:2.4.1-2.el5.centos set to be updated
---> Package php-pear-MDB2-Driver-mysql.noarch 0:1.4.1-3.el5.centos set to be updated
---> Package php-pear-Mail.noarch 0:1.1.14-1.el5.centos set to be updated
---> Package php-pear-Mail-Mime.noarch 0:1.4.0-1.el5.centos set to be updated
---> Package php-pear-Net-SMTP.noarch 0:1.2.10-1.el5.centos set to be updated
---> Package php-pear-Net-Sieve.noarch 0:1.1.5-2.el5.centos set to be updated
---> Package php-pear-Net-Socket.noarch 0:1.0.8-1.el5.centos set to be updated
---> Package php-pear-Net-URL.noarch 0:1.0.15-1.el5.centos set to be updated
---> Package php-pecl-Fileinfo.x86_64 0:1.0.4-3.el5.centos set to be updated
---> Package php-pecl-memcache.x86_64 0:2.2.3-1.el5_2 set to be updated
---> Package php-pgsql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-readline.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
---> Package php-snmp.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: net-snmp for package: php-snmp
--> Processing Dependency: libnetsnmp.so.10()(64bit) for package: php-snmp
---> Package php-soap.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php-tidy.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml
---> Package php-xmlrpc.x86_64 0:5.1.6-27.el5_5.3 set to be updated
---> Package php53-bcmath.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-dba.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-devel.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-gd.x86_64 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libXpm.so.4()(64bit) for package: php53-gd
---> Package php53-imap.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-intl.x86_64 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libicudata.so.36()(64bit) for package: php53-intl
--> Processing Dependency: libicuio.so.36()(64bit) for package: php53-intl
--> Processing Dependency: libicuuc.so.36()(64bit) for package: php53-intl
--> Processing Dependency: libicui18n.so.36()(64bit) for package: php53-intl
---> Package php53-ldap.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mbstring.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mysql.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-odbc.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-pdo.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-pgsql.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-process.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-pspell.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-snmp.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-soap.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-xml.x86_64 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-xmlrpc.x86_64 0:5.3.3-1.el5_6.1 set to be updated
--> Running transaction check
---> Package autoconf.noarch 0:2.59-12 set to be updated
--> Processing Dependency: imake for package: autoconf
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package freetds.x86_64 0:0.64-11.el5.centos set to be updated
---> Package libXpm.x86_64 0:3.5.5-3 set to be updated
---> Package libc-client.x86_64 0:2004g-2.2.1 set to be updated
---> Package libicu.x86_64 0:3.6-5.16 set to be updated
---> Package libmcrypt.x86_64 0:2.5.8-4.el5.centos set to be updated
---> Package libtidy.x86_64 0:0.99.0-12.20070228.el5.centos set to be updated
---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
---> Package mhash.x86_64 0:0.9.9-1.el5.centos set to be updated
---> Package net-snmp.x86_64 1:5.3.2.2-9.el5_5.1 set to be updated
--> Processing Dependency: libsensors.so.3()(64bit) for package: net-snmp
---> Package net-snmp-libs.x86_64 1:5.3.2.2-9.el5_5.1 set to be updated
---> Package unixODBC.x86_64 0:2.2.11-7.1 set to be updated
--> Running transaction check
---> Package imake.x86_64 0:1.0.2-3 set to be updated
---> Package lm_sensors.x86_64 0:2.10.7-9.el5 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
You have mail in /var/spool/mail/root

ora la libreria php-common non è installata . Come posso venirne a capo ?

8
Server / Re: dipendenze phpmyadmin - php
« il: 01 Agosto 2011, 18:26:18 »
Ho risolto !  ;D

Questa è la procedura che ho seguito

Citazione
yum purge php php-*

che mi ha eliminato il php non standard

ho installato questo programma da yum
Citazione
# yum install yum-priorities

ed ho aggiunto questi repository
Citazione
# rpm -Uvh http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm
# rpm -Uvh http://dl.iuscommunity.org/pub/ius/stable/Redhat/5/i386/ius-release-1.0-8.ius.el5.noarch.rpm

ed ho reinstallato php con questi comandi
Citazione
yum install php53u-pear php53u php53u-cli php53u-common php53u-devel php53u-gd php53u-mbstring php53u-mcrypt php53u-mysql php53u-pdo php53u-soap php53u-xml php53u-xmlrpc php53u-bcmath php53u-pecl-apc php53u-pecl-memcache php53u-snmp

dopo di che ho installato phpmyadmin con yum
Citazione
# yum install phpmyadmin

9
Server / Re: dipendenze phpmyadmin - php
« il: 01 Agosto 2011, 17:42:07 »
Citazione
di dirci la versione di centOS

versione 5 a 64 bit

Citazione
, e di come hai installato php

http://www.webtatic.com/packages/php53/

Citazione
, quel php, che AFAIK non è standard nemmeno in centos6

questa non l' ho capita  ???

10
Server / dipendenze phpmyadmin - php
« il: 01 Agosto 2011, 15:54:07 »
Salve ,

stò cercando d' installare , come descritto nell' how-to presente nel sito phpmyadmin . Soltanto quando lancio il comando mi restituisce questo errore :
Citazione
[root@matteocolombini ~]# yum --enablerepo=rpmforge install phpMyAdmin
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.crazynetwork.it
 * extras: centos.crazynetwork.it
 * rpmforge: fr2.rpmfind.net
 * updates: centos.crazynetwork.it
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package phpmyadmin.noarch 0:2.11.11.3-2.el5.rf set to be updated
--> Processing Dependency: php-mysql >= 4.1.0 for package: phpmyadmin
--> Processing Dependency: php-mbstring >= 4.1.0 for package: phpmyadmin
--> Processing Dependency: php-mcrypt for package: phpmyadmin
--> Running transaction check
---> Package php-mbstring.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mbstri                                                                                                                                                                                               ng
---> Package php-mcrypt.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt
---> Package php-mysql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mysql
--> Processing Dependency: php-pdo for package: php-mysql
--> Running transaction check
---> Package libmcrypt.x86_64 0:2.5.8-4.el5.centos set to be updated
---> Package php-mbstring.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mbstri                                                                                                                                                                                               ng
---> Package php-mcrypt.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
---> Package php-mysql.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mysql
---> Package php-pdo.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-pdo
--> Finished Dependency Resolution
php-pdo-5.1.6-27.el5_5.3.x86_64 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php                                                                                                                                                                                               -pdo-5.1.6-27.el5_5.3.x86_64 (base)
php-mysql-5.1.6-27.el5_5.3.x86_64 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php                                                                                                                                                                                               -mysql-5.1.6-27.el5_5.3.x86_64 (base)
php-mbstring-5.1.6-27.el5_5.3.x86_64 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php                                                                                                                                                                                               -mbstring-5.1.6-27.el5_5.3.x86_64 (base)
php-mcrypt-5.1.6-15.el5.centos.1.x86_64 from extras has depsolving problems
  --> Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1                                                                                                                                                                                               .6-15.el5.centos.1.x86_64 (extras)
Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.                                                                                                                                                                                               1.6-15.el5.centos.1.x86_64 (extras)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package ph                                                                                                                                                                                               p-pdo-5.1.6-27.el5_5.3.x86_64 (base)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package ph                                                                                                                                                                                               p-mysql-5.1.6-27.el5_5.3.x86_64 (base)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package ph                                                                                                                                                                                               p-mbstring-5.1.6-27.el5_5.3.x86_64 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

però php risulta correttamente installato
Citazione
[root@matteocolombini ~]# php -v
PHP 5.3.6 (cli) (built: Mar 19 2011 07:44:03)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

Cosa mi sono dimenticato ?

11
Supporto Generale / aggiornamento centos 5.6 a centos 6
« il: 25 Luglio 2011, 18:09:50 »
Salve ,

sulla mia vps unmenaged ho istallato di defult la versione 5.6 . Ora vorrei passare alla 6 . Ma come devo fare ? Ho seguito varie guide in rete ma mi rimane sempre alla 5.6

12
Server / Re: instllazione mysql
« il: 22 Luglio 2011, 12:00:01 »
dovrebbero essere quelli di default ma non sò come trovare la lista per postarli

13
Server / instllazione mysql
« il: 22 Luglio 2011, 11:28:19 »
Ciao a tutti ,

stò cercando d' installare mysql sul nuvo server ma quando tento d' installarlo tramite yum mi dà questo output:

Citazione
[root@studio ~]# yum install mysql mysql-devel mysql-server
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.prometeus.net
 * extras: mirrors.prometeus.net
 * updates: mirrors.prometeus.net
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package mysql available.
No package mysql-devel available.
  * Maybe you meant: MySQL-devel
No package mysql-server available.
  * Maybe you meant: MySQL-server
Nothing to do

dove sbaglio ?

14
Server / Re: server centos: aggiornamenti e backup
« il: 10 Luglio 2011, 16:47:22 »
scusate se mi aggancio a questo post ma visto che si parla di aggiornamenti forse potete essermi d' aiuto .

Sul mio server vorrei vedere se è possibile fare degli update ma il il processo si blocca dicendo che c' è questo servizio in esecuzione yum-updatesd-he . Cosa significa ?

15
Sicurezza / Re: disabilitare telnet
« il: 08 Luglio 2011, 09:12:53 »
Ciao,
il file non esiste perché il pacchetto telnet-server non è installato.
ciao.

Ok . Grazie per la risposta  ;)

Pagine: [1] 2