Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - LonelyWolf

Pagine: [1] 2 3 ... 89
1
Server / Problema con systemd [Risolto]
« il: 07 Gennaio 2019, 10:01:48 »
Nelle ultime 2 settimane mi sono capitati starni problemi su un CentOS Linux release 7.5.1804 (Core), come ad esempio il comando df che non si completa e rimane "zombie", i servizi che rilevano spazio insufficiente sul disco (in realtà ci sono oltre 2 tera disponibili!), ecc problemi che con il riavvio di proc-sys-fs-binfmt_misc.mount si risolvono, ma non definitivamente.

Oggi rientrando in ufficio trovo i cronjob di yum "zombie", yum che non funziona, servizi che non si avviano perchè non rilevano spazio, a parte yum con il riavvio del processo come indicato sopra tutto torna normale.

Da una ricerca in rete sembra ci sia un problema con le tabelle di routing, proprio dall 7.5 di centos; controllando la tbella di routing però non vedo nulla di strano:
Codice: [Seleziona]
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         pfsense         0.0.0.0         UG    100    0        0 eno1
x.x.x.0       0.0.0.0         255.255.255.0   U     100    0        0 eno1

Se provo il ping tutto funziona regolarmente, gli indirizzi vengono risolti e le risposte arrivano.

Questo problema si dovrebbe anche risolvere con un aggiornamento di systemd, che però non riesco ad eseguire in quanto yum rimane bloccato.

Edit:
dopo aver "eliminato" i file /var/lib/rpm/__db.00* yum è tornato a funzionare, ho fatto l'update di systemd, verificherò se è la soluzione definitiva o meno, poi aggiornerò il topic.

Ri-Edit:
Aggiornato systemd il problema non si è ripresentato.

2
Server / Re:eseguibili exe server centos7
« il: 28 Ottobre 2018, 20:33:33 »
Il problema sono i permessi che ha il file exe e/o l'utente windows

3
Non è più possibile aggiornare, è una versione fuori supporto.

4
Supporto Generale / Re:Installare estensioni gnome shell
« il: 27 Settembre 2018, 08:37:53 »
Prima di tutto benvenuto, in seconda battuta: non ti si può dire cosa manca se prima tu non ci dici cosa vuoi fare.

5
Server / Re:Failed to start The Apache HTTP Server
« il: 26 Settembre 2018, 08:31:26 »
Hai un problema di permessi/autorizzazioni di accesso ai file, non di riga nel file di configurazione.
Quel comando ha solo detto alla macchina di ignorare la cosa, inoltre al prossimo riavvio tutto tornerà com'era prima.

6
Server / Re:Failed to start The Apache HTTP Server
« il: 25 Settembre 2018, 17:47:04 »
Ripeto, senza i log non si può sapere dov'è il problema, cerca nella cartella /var/log quello di apache e leggi cosa succede.
In base a quello che scrivi posso supporre che il problema sia dovuto ai permessi dei file di configurazione "sites-enabled/*.conf" o al percorso errato.

7
Server / Re:Failed to start The Apache HTTP Server
« il: 25 Settembre 2018, 08:55:37 »
Per sapere cosa non va servirebbero i log, leggendo quello che hai scritto non è possibile capire dove sta il problema.

La modifica al file hosts non permette di identificare i domini (eventualmente presenti), ma solo l'host che li (dovrebbe) ospitare.

Per tentativi:
i permessi file/cartelle che hai creato sono a posto?
I permessi sui file di configurazione sono a posto?

8
Server / Re:Conessione a server CentOS con Putty
« il: 18 Settembre 2018, 09:14:09 »
Stiamo andando un po' OT rispetto al problema, comunque: il router non si aspetta nulla, il fatto che la 443 sia utilizzata per https, la 80 per http, ecc è una "convenzione umana".

Un router semplicemente la instrada verso la destinazione corretta: è come lo scambio di un binario della ferrovia, che stia passando un treno ad alta velocità o una vecchia locomotiva a vapore per lui è lo stesso, deve solo sapere da dove arriva e dove mandarlo.

9
Server / Re:Help correzione disco
« il: 17 Settembre 2018, 13:50:16 »
Se il disco non è guasto non ci saranno correzioni nemmeno con la sintassi corretta del comando.

Una ricerca veloce con google (acronis xfs) al primo posto ha la kb di acronis con titolo: 2910: Acronis Product Hangs When Backing Up an XFS Partition: https://kb.acronis.com/content/2910


10
Server / Re:Conessione a server CentOS con Putty
« il: 17 Settembre 2018, 13:42:43 »
Scusa ma sono confuso, e spero di aver capito bene il tuo problema....
come giustamente indicato da LonelyWolf in genere quando esci non hai problemi di porte, ma al contrario no....la 443 è la porta utilizzata da https e mi viene da pensare che il router in ingresso si aspetti una tale richiesta da reindirizzare ad un web server....quindi...a meno che qualcuno non instradi la tua richiesta (e nessuno lo farà) dalla 443 al tuo server ... non ci arriverai mai.
Posso solo supporre che tu voglia fare questo

server <- LAN <- router aziendale (IP Pubblico) <- client di test (tipo cellulare android)

considerazioni finali.
1) non utilizzare mai porte al di sotto della 1024 ma sopratutto quelle che appartengono a servizi noti.
2) in lan ti funziona tutto perchè non hai servizi https che girano sul tuo server.
Ciao.
Non capisco questo tuo post, lui è stato chiarissimo, non gli interessa https ma la connessione SSH (usando putty nello specifico).

11
Server / Re:systemectl in CentOS 7
« il: 14 Settembre 2018, 11:17:21 »
Citazione
Dopo avere eseguito con successo tutti i comandi elencati, accedendo all' ip del server non mi appare la pagina di cortesia di Apache.
il server è configurato per accettare le connessioni dall'esterno (vedi firewall)?

Citazione
Nella directory /var/www/html non ho trovato il classico "index.html"
Perchè se non lo crei tu non c'è; se ti riferisci invece alla pagina di default di Apache non è quello il posto dove cercare.

12
Server / Re:systemectl in CentOS 7
« il: 14 Settembre 2018, 09:15:47 »
E' tutto corretto.
Il comando systemectl non esiste, quello corretto è systemctl!
;)

13
Networking / Re:configurazione per andare in internet
« il: 07 Settembre 2018, 08:45:19 »
Quasi sicuramente la soluzione al tuo problema:
1) Sul router devi fare un port forward dalla WAN verso l'indirizzo del server sulla LAN
2) Sul server aprire le porte del firewall per l'accesso SSH
(Per il punto 1 scegli una porta non standard)

In alternativa, cosa molto più sbrigativa, falli collegare con teamviewer/ammy/altro ad un pc windows sulla LAN  e da lì si collegheranno con putty al server

14
Server / Re:Conessione a server CentOS con Putty
« il: 28 Agosto 2018, 10:58:59 »
Quando dico router intendo il router.

Per semplificare (molto) questo è lo schema:

LAN -> router -> WAN

Quindi: Server -> router -> WAN (IP Pubblico)

Per il percorso "in uscita" dalla LAN generalmente una volta messo il gateway non serve configurare nulla; per il percorso inverso, ovvero dalla WAN alla LAN, bisogna configurare il router affinché permetta il passaggio.


15
Server / Re:Conessione a server CentOS con Putty
« il: 28 Agosto 2018, 09:27:41 »
Prima di tutto, il firewall deve avere le regole che permettano l'accesso, anche se il server è solo per test, mai disabilitato.

in seconda battuta, e questo è il tuo problema, il router è configurato per inoltrare la richiesta dalla wan  verso il tuo server? Non mi sembra di aver letto che l'hai fatto.

Pagine: [1] 2 3 ... 89