Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - FabioB

Pagine: 1 [2] 3
16
Seguendo i tuoi suggerimenti (ma smb.conf), ho impostato il file /etc/samba/smb.conf così

Codice: [Seleziona]
[documenti]
comment = Cartella Documenti
valid users = @smbgrp
guest ok = no
path = /home/doc
browseable = yes
writable = yes
read only = no
writable = yes
create mask = 775
directory mask = 775

Così dovrebbe essere?

17
Grazie per la risposta.
Questa è l'impostazione della condivisione sul file /etc/samba/smb.conf

Codice: [Seleziona]
[documenti]
comment = Cartella Documenti
valid users = @smbgrp
guest ok = no
path = /home/doc
browseable = yes
writable = yes
read only = no
writable = yes

18
Buongiorno a tutti e grazie per l'interesse mostrato.
Ho creato un server con CentOS 7.4 con l'unico scopo di condividere i file in rete, una sorta di NAS insomma. Tutti i client che si collegano sono Windows.
Ho creato un utente amministratore chiamato "admin" e vari utenti che per comodità chiamerò "uno", "due", "tre" e così via.
Poi ho creato un gruppo chiamato "smbgrp" a cui ho aggiunto tutti gli utenti.
Successivamente vi ho riversato una notevole quantità di cartelle e file e finita questa operazione ho impostato i permessi alla cartella principale con questo comando:

Codice: [Seleziona]
chown -R admin:smbgrp nomecartellaprincipale
Fin qui tutto bene, il problema si pone quando un client, che ricordo essere tutti Windows, vanno a creare un file, diventa di sua esclusiva proprietà almeno in scrittura.
Se per esempio "uno" crea un file, a tutti gli altri il file risulterà in sola lettura e non potrà essere salvato se si apportano modifiche.
Se vado a vedere le proprietà con il comando ls -al troverò come risultato"uno uno".
Invece la funzione dovrebbe essere che chiunque acceda al server possa vedere e poter modificare questi file.
Grazie a tutti.

19
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 07 Ottobre 2017, 13:09:12 »
Nel mio caso i client Windows 7 e 10 non avevano problemi ed ora grazie a te non li hanno più nemmeno quelli con XP. Sicuramente starò ben lontano dall'aggiornare il server, se non quando spariranno questi due client con XP.

20
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 05 Ottobre 2017, 19:38:44 »
Ciao a tutti, scusate il tempo trascorso ma non avevo avuto modo di riprovare.
La questione è stata risolta grazie a queste sole due direttive come da penultimo post di LonelyWolf:

Codice: [Seleziona]
lanman auth = yes
ntlm auth = yes

Con "ntlm auth = no" come da ultimo post di smeserver non funzionava.
Grazie in ogni caso a tutti e due per le risposte.

21
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 28 Settembre 2017, 08:39:24 »
Vero, è la versione Pro.
Come si fa a "specificare nelle opozioni server e client (max/min protocol)".
Grazie!

22
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 26 Settembre 2017, 13:43:57 »
Accidenti ho scoperto che così mi da lo stesso problema anche con i computer con Windows 7 e 10.

23
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 26 Settembre 2017, 13:23:46 »
Purtroppo non mi funziona nemmeno così, l'unica cosa che è cambiata è che ci ragiona un po' di più prima di ridarmi la finestra di login ed invece che restituirmi il nome utente sotto la forma dominio\nomeutente mi da indirizzoip\nomeutente.
Riporto il file smb.conf modificato

Codice: [Seleziona]
# See smb.conf.example for a more detailed config file or
# read the smb.conf manpage.
# Run 'testparm' to verify the config is correct after
# you modified it.

[global]
workgroup = colori2010
server string = Samba Server %v
netbios name = DocServer
map to guest = bad user
dns proxy = no
security = user
protocol = LANMAN2
client lanman auth = yes
client ntlmv2 auth = yes
lanman auth = yes
ntlm auth = yes

passdb backend = tdbsam

; printing = cups
; printcap name = cups
; load printers = yes
; cups options = raw

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = root
create mask = 0664
directory mask = 0775

[documenti]
comment = Cartella Documenti
valid users = @smbgrp
guest ok = no
path = /home/doc
browseable = yes
writable = yes
read only = no
writable = yes

24
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 25 Settembre 2017, 20:52:47 »
Sì praticamente quella macchina virtuale è inutile, io ho trovato le cose così e cerco di lasciarle, tra l'altro ho provato ad installare Uranium Backup sul server con Windows 2008 e non si installa, come non si installa nessun altro programma di backup, in verità ho provato solo Iperius Backup oltre ad Uranium, entrambi hanno lo stesso comportamento: quando clicchi due volte il file di installazione non succede nulla.
E poi c'è sempre questo XP virtualizzato sul Mac del titolare che vuole sia così: comprano i Mac per poi virtualizzare Windows!
Purtroppo però con le tue indicazioni non mi funziona.
Ti mostro come è configurato il file smb.conf

Codice: [Seleziona]
# See smb.conf.example for a more detailed config file or
# read the smb.conf manpage.
# Run 'testparm' to verify the config is correct after
# you modified it.

[global]
workgroup = colori2010
server string = Samba Server %v
netbios name = DocServer
map to guest = bad user
dns proxy = no
security = user

passdb backend = tdbsam

; printing = cups
; printcap name = cups
; load printers = yes
; cups options = raw

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = root
create mask = 0664
directory mask = 0775

[documenti]
comment = Cartella Documenti
valid users = @smbgrp
guest ok = no
path = /home/doc
browseable = yes
writable = yes
read only = no
writable = yes

protocol = LANMAN2
client lanman auth = yes
client ntlmv2 auth = yes
lanman auth = yes
ntlm auth = yes

Magari le direttive l'ho messe in un posto sbagliato.


25
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 25 Settembre 2017, 17:29:42 »
Grazie di nuovo per la risposta. Questa rete è un po' confusionale cercherò di farti capire: come ho detto questa macchina virtuale ha esclusivamente installato Windows XP ed Uranium Backup per il backup non solo dei dati ma anche di vari database SQL Server.
I backup non vengono salvati su Windows XP ma su un NAS. Pertanto Uranium Backup prende i database da Windows 2008 e dovrebbe prendere i documenti da questa macchina virtuale con Centos per poi salvarli in un NAS.
In più il titolare ha un computer Mac su cui ha una macchina virtuale sempre con Windows XP da cui vorrebbe accedere al server Centos con i documenti, non ne conosco bene la motivazione ma vuole che sia così.
La versione di Samba è 4.6.2.

26
Networking / Re:Client Window XP non accedono a cartella condivisa
« il: 25 Settembre 2017, 14:08:41 »
Grazie per la risposta. Come faccio a sapere quale versione ho di samba? Considerando che dovrebbe essere l'ultima versione perché il server è completamente aggiornato.
Il client Windows XP è una macchina virtuale che ha esclusivamente installato Uranium Backup che chiaramente non funziona per il motivo esplicato.
La sicurezza del server Centos non è un particolare problema perché fa esclusivamente da NAS senza nessun'altro servizio, non è nemmeno collegato ad Internet. Mi serve però che Uranium Backup possa fare il backup dei documenti che stanno su questo server. La questione che il client Windows XP ha la sua regolare licenza, mentre se cambio dovrei comprare un'altra licenza. Pertanto qualunque soluzione è ben accetta anche se mette a rischio la sicurezza.

27
Networking / Client Window XP non accedono a cartella condivisa
« il: 23 Settembre 2017, 21:38:00 »
Buongiorno a tutti,
ho installato un server con Centos ultima versione 7.4.1708, quando tento di accedere al questo server dai client con Windows XP mi apre la finestra con la cartella condivisa ma se provo ad aprire la cartella condivisa mi rifiuta l'accesso richiedendomi continuamente utente e password, nonostante siano corretti. Con i client Windos 7 e 10 non ho problemi. Qualcuno saprebbe indicami una soluzione?
Grazie!

28
Supporto Generale / Re:Installare programmi - Yum repositories
« il: 19 Settembre 2017, 14:53:55 »
Qualche giorno fa ho installato CentOS server da zero utilizzando l'ultima versione 7.4.1708 e ho avuto lo stesso problema, stesso messaggio di errore e di conseguenza impossibilità di fare alcun aggiornamento e installare epel, nemmeno tramite rpm.
Sperando che sia utile condivido la soluzione che mi ha risolto il problema e precisamente con il comando "dhclient" senza nessun parametro. Per me è stato risolutivo solo questo di tutte le soluzioni che si trovano in giro che non hanno avuto successo.
Comunque ho fatto una nuova installazione anche stamattina e non c'è stato alcun problema, credo che abbiano aggiustato qualcosa che non andava.

29
Ho risolto inserendo questa direttiva su  /etc/samba/smb.conf:

map to guest = bad user

30
Buongiorno a tutti,
ho installato come macchina virtuale su Xen Server un server Centos 7. Ho creato la cartella /ripostiglio alla quale vorrei accedere liberamente, ossia senza nessuna richiesta di credenziali.
Subito dopo aver installato il server e gli aggiornamenti ho proceduto come segue:

- ho configurato un IP statico;
- ho installato EPEL;
- ho installato Samba con il comando:
Codice: [Seleziona]
yum install samba samba-client samba-common- ho configurato la condivisione su /etc/samba/smb.conf come segue:
Codice: [Seleziona]
#======== Share Definitions ===========
[ripostiglio]
path = /ripostiglio
browsable =yes
writable = yes
guest ok = yes
read only = no
- ho dato l'accesso a Samba sul firewall con questo comando:
Codice: [Seleziona]
firewall-cmd --permanent --zone=public --add-service=samba- poi ho impostato i permessi alla cartella con questi comandi:
Codice: [Seleziona]
chmod -R 0755 ripostiglio/
chown -R nobody:nobody ripostiglio/
- infine ho dato i permessi per SELinux alla cartella così:
Codice: [Seleziona]
chcon -t samba_share_t ripostiglio/
Non riesco ad entrare con un computer con Windows ovvero cercando di accedere al server mi chiede le credenziali, tra l'altro inserendo root e la password non mi permette l'accesso. Root è l'unico utente del server.
Ho provato di tutto ma non riesco a risolvere questa situazione.
Grazie a tutti.

Pagine: 1 [2] 3