Autore Topic: Problema sugli aggiornamenti - Transaction Check Error  (Letto 4125 volte)

Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Problema sugli aggiornamenti - Transaction Check Error
« il: 26 Febbraio 2015, 01:25:31 »
Salve a tutt*,
per motivi legati al gestore della mia macchina virtuale sono dovuto passare da un architettura a 32 bit a 64. Ora quando provo a fare l'aggiornamento mi vengono restituiti i seguenti errori:

Codice: [Seleziona]
Transaction Check Error:
  package libxml2-2.7.6-17.el6_6.1.x86_64 is already installed
  package libsepol-2.0.41-4.el6.x86_64 is already installed
  package zlib-1.2.3-29.el6.x86_64 is already installed
  package libudev-147-2.57.el6.x86_64 is already installed
  package nss-softokn-freebl-3.14.3-22.el6_6.x86_64 is already installed
  package readline-6.0-4.el6.x86_64 is already installed
  package glibc-2.12-1.149.el6_6.5.x86_64 is already installed
  package device-mapper-libs-1.02.90-2.el6_6.1.x86_64 is already installed
  package libselinux-2.0.94-5.8.el6.x86_64 is already installed
  package ncurses-libs-5.7-3.20090208.el6.x86_64 is already installed
  file /sbin/matchpathcon from install of libselinux-2.0.94-5.8.el6.x86_64 conflicts with file from package libselinux-2.0.94-5.8.el6.i686
  file /sbin/ldconfig from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686
  file /sbin/sln from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686
  file /usr/sbin/iconvconfig from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686
  file /usr/bin/xmlcatalog from install of libxml2-2.7.6-17.el6_6.1.x86_64 conflicts with file from package libxml2-2.7.6-17.el6_6.1.i686
  file /usr/bin/xmllint from install of libxml2-2.7.6-17.el6_6.1.x86_64 conflicts with file from package libxml2-2.7.6-17.el6_6.1.i686

Come posso fare per risolverli?

Ho una centos:
6.6 (Final)

Con kernel
3.18.3-x86_64

Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #1 il: 26 Febbraio 2015, 01:29:24 »
ho utilizzato questa soluzione,
https://access.redhat.com/solutions/158883

blacklistando i pacchetti i686 pero adesso mi ritrovo questi errori

Codice: [Seleziona]
Packages skipped because of dependency problems:
    apr-1.3.9-5.el6_2.x86_64 from base
    apr-util-1.3.9-3.el6_0.1.x86_64 from base
    augeas-libs-1.0.0-7.el6_6.1.x86_64 from updates
    cyrus-sasl-lib-2.1.23-15.el6_6.1.x86_64 from updates
    db4-4.7.25-18.el6_4.x86_64 from base
    1:dbus-libs-1.2.24-7.el6_3.x86_64 from base
    device-mapper-libs-1.02.90-2.el6_6.1.x86_64 from updates
    expat-2.0.1-11.el6_2.x86_64 from base
    glibc-2.12-1.149.el6.x86_64 from base
    glibc-2.12-1.149.el6_6.4.x86_64 from updates
    glibc-2.12-1.149.el6_6.5.x86_64 from updates
    glibc-common-2.12-1.149.el6.x86_64 from base
    glibc-common-2.12-1.149.el6_6.4.x86_64 from updates
    gnutls-2.8.5-14.el6_5.x86_64 from base
    hivex-1.3.3-4.2.el6.x86_64 from base
    keyutils-libs-1.4-5.el6.x86_64 from base
    kpartx-0.4.9-80.el6_6.3.x86_64 from updates
    krb5-libs-1.10.3-33.el6.x86_64 from base
    libattr-2.4.44-7.el6.x86_64 from base
    libcap-2.16-5.5.el6.x86_64 from base
    libcom_err-1.41.12-21.el6.x86_64 from base
    libgcc-4.4.7-11.el6.x86_64 from base
    libgcrypt-1.4.5-11.el6_4.x86_64 from base
    libgpg-error-1.7-4.el6.x86_64 from base
    libproxy-0.3.0-10.el6.x86_64 from base
    libselinux-2.0.94-5.8.el6.x86_64 from base
    libsepol-2.0.41-4.el6.x86_64 from base
    libstdc++-4.4.7-11.el6.x86_64 from base
    libtasn1-2.3-6.el6_5.x86_64 from base
    libudev-147-2.57.el6.x86_64 from base
    libuuid-2.17.2-12.18.el6.x86_64 from base
    libxml2-2.7.6-14.el6_5.2.x86_64 from base
    libxml2-2.7.6-17.el6_6.1.x86_64 from updates
    ncurses-libs-5.7-3.20090208.el6.x86_64 from base
    neon-0.29.3-3.el6_4.x86_64 from base
    nss-softokn-freebl-3.14.3-18.el6_6.x86_64 from updates
    nss-softokn-freebl-3.14.3-19.el6_6.x86_64 from updates
    nss-softokn-freebl-3.14.3-22.el6_6.x86_64 from updates
    pakchois-0.4-3.2.el6.x86_64 from base
    perl-Class-MethodMaker-2.16-6.el6.x86_64 from base
    perl-hivex-1.3.3-4.2.el6.x86_64 from base
    readline-6.0-4.el6.x86_64 from base
    sqlite-3.6.20-1.el6.x86_64 from base
    subversion-1.6.11-12.el6_6.x86_64 from updates
    zlib-1.2.3-29.el6.x86_64 from base
[root@lattuga owncloud_data]#

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #2 il: 27 Febbraio 2015, 15:14:09 »
Ciao,
puoi postare il risultato del comando: yum repolist


Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #3 il: 01 Marzo 2015, 20:59:06 »
ecco
Codice: [Seleziona]
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.vorboss.net
 * epel: epel.check-update.co.uk
 * extras: mirror.vorboss.net
 * updates: mirror.vorboss.net
repo id                               repo name                                                        status
base                                  CentOS-6 - Base                                                  4,986+1,532
epel                                  Extra Packages for Enterprise Linux 6 - x86_64                   9,222+1,999
extras                                CentOS-6 - Extras                                                         37
kbs-CentOS-Extras                     CentOS.Karan.Org-EL6 - Stable                                              0
kbs-CentOS-Testing                    CentOS.Karan.Org-EL6 - Testing                                             0
sourcefabric                          Sourcefabric's YUM repo                                                   16
sourcefabric-source                   Sourcefabric's YUM repo - Source                                           0
updates                               CentOS-6 - Updates                                                   598+190
repolist: 14,859



Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #4 il: 02 Marzo 2015, 10:57:47 »
Ci sono dei repository che non vanno bene insieme.
Probabilmente hai necessitÓ di disabilitare prima i kbs e poi i sourcefabric per capire quali ti danno problemi.

Io solitamenteo utilizzo come repository : base,epel,rpmfusion,elrepo-kernel

P.S.
http://elrepo.org/tiki/tiki-index.php
http://rpmfusion.org/Configuration

Ciao

Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #5 il: 17 Marzo 2015, 10:40:01 »
mi scuso per il ritardo mostruoso.
Ho provato a disabilitare i repository che mi hai indicato ma ho sempre lo stesso

Codice: [Seleziona]
[root@lattuga jops]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.vorboss.net
 * epel: epel.check-update.co.uk
 * extras: mirror.vorboss.net
 * updates: mirror.vorboss.net
Resolving Dependencies
--> Running transaction check
---> Package augeas-libs.i686 0:1.0.0-7.el6 will be updated
--> Processing Dependency: libaugeas.so.0 for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0) for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0) for package: netcf-libs-0.2.4-1.el6.i686
---> Package augeas-libs.x86_64 0:1.0.0-7.el6_6.1 will be an update
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30)(64bit) for package: augeas-libs-1.0.0-7.el6_6.1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.8)(64bit) for package: augeas-libs-1.0.0-7.el6_6.1.x86_64
--> Processing Dependency: libxml2.so.2()(64bit) for package: augeas-libs-1.0.0-7.el6_6.1.x86_64
--> Processing Dependency: libselinux.so.1()(64bit) for package: augeas-libs-1.0.0-7.el6_6.1.x86_64
---> Package bind-libs.i686 32:9.8.2-0.30.rc1.el6_6.1 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.30.rc1.el6_6.2 will be an update
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libz.so.1()(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libgssapi_krb5.so.2()(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libcrypto.so.10()(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libcap.so.2()(64bit) for package: 32:bind-libs-9.8.2-0.30.rc1.el6_6.2.x86_64
---> Package bind-utils.i686 32:9.8.2-0.30.rc1.el6_6.1 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.30.rc1.el6_6.2 will be an update
--> Processing Dependency: libidn.so.11(LIBIDN_1.0)(64bit) for package: 32:bind-utils-9.8.2-0.30.rc1.el6_6.2.x86_64
--> Processing Dependency: libidn.so.11()(64bit) for package: 32:bind-utils-9.8.2-0.30.rc1.el6_6.2.x86_64
---> Package hivex.i686 0:1.3.3-4.el6 will be updated
---> Package hivex.x86_64 0:1.3.3-4.2.el6 will be an update
--> Processing Dependency: libreadline.so.6()(64bit) for package: hivex-1.3.3-4.2.el6.x86_64
---> Package kpartx.i686 0:0.4.9-80.el6_6.2 will be updated
---> Package kpartx.x86_64 0:0.4.9-80.el6_6.3 will be an update
--> Processing Dependency: libdevmapper.so.1.02(Base)(64bit) for package: kpartx-0.4.9-80.el6_6.3.x86_64
--> Processing Dependency: libdevmapper.so.1.02()(64bit) for package: kpartx-0.4.9-80.el6_6.3.x86_64
---> Package ntp.i686 0:4.2.6p5-2.el6.centos will be updated
---> Package ntp.x86_64 0:4.2.6p5-3.el6.centos will be an update
--> Processing Dependency: libedit.so.0()(64bit) for package: ntp-4.2.6p5-3.el6.centos.x86_64
---> Package ntpdate.i686 0:4.2.6p5-2.el6.centos will be updated
---> Package ntpdate.x86_64 0:4.2.6p5-3.el6.centos will be an update
---> Package perl-Class-MethodMaker.i686 0:2.16-4.el6 will be updated
---> Package perl-Class-MethodMaker.x86_64 0:2.16-6.el6 will be an update
---> Package perl-hivex.i686 0:1.3.3-4.el6 will be updated
---> Package perl-hivex.x86_64 0:1.3.3-4.2.el6 will be an update
---> Package subversion.i686 0:1.6.11-10.el6_5 will be updated
---> Package subversion.x86_64 0:1.6.11-12.el6_6 will be an update
--> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libsasl2.so.2()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libneon.so.27()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libexpat.so.1()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: subversion-1.6.11-12.el6_6.x86_64
--> Running transaction check
---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed
--> Processing Dependency: libuuid.so.1(UUID_1.0)(64bit) for package: apr-1.3.9-5.el6_2.x86_64
--> Processing Dependency: libuuid.so.1()(64bit) for package: apr-1.3.9-5.el6_2.x86_64
---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package augeas-libs.i686 0:1.0.0-7.el6 will be updated
--> Processing Dependency: libaugeas.so.0 for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0) for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0) for package: netcf-libs-0.2.4-1.el6.i686
---> Package cyrus-sasl-lib.x86_64 0:2.1.23-15.el6_6.1 will be installed
---> Package db4.x86_64 0:4.7.25-18.el6_4 will be installed
---> Package device-mapper-libs.x86_64 0:1.02.90-2.el6_6.1 will be installed
--> Processing Dependency: libudev.so.0()(64bit) for package: device-mapper-libs-1.02.90-2.el6_6.1.x86_64
--> Processing Dependency: libsepol.so.1()(64bit) for package: device-mapper-libs-1.02.90-2.el6_6.1.x86_64
---> Package expat.x86_64 0:2.0.1-11.el6_2 will be installed
---> Package glibc.x86_64 0:2.12-1.149.el6_6.5 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3)(64bit) for package: glibc-2.12-1.149.el6_6.5.x86_64
--> Processing Dependency: libfreebl3.so()(64bit) for package: glibc-2.12-1.149.el6_6.5.x86_64
---> Package krb5-libs.x86_64 0:1.10.3-33.el6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3)(64bit) for package: krb5-libs-1.10.3-33.el6.x86_64
--> Processing Dependency: libkeyutils.so.1()(64bit) for package: krb5-libs-1.10.3-33.el6.x86_64
--> Processing Dependency: libcom_err.so.2()(64bit) for package: krb5-libs-1.10.3-33.el6.x86_64
---> Package libcap.x86_64 0:2.16-5.5.el6 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0)(64bit) for package: libcap-2.16-5.5.el6.x86_64
--> Processing Dependency: libattr.so.1()(64bit) for package: libcap-2.16-5.5.el6.x86_64
---> Package libedit.x86_64 0:2.11-4.20080712cvs.1.el6 will be installed
--> Processing Dependency: libncurses.so.5()(64bit) for package: libedit-2.11-4.20080712cvs.1.el6.x86_64
---> Package libidn.x86_64 0:1.18-2.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-5.8.el6 will be installed
---> Package libxml2.x86_64 0:2.7.6-17.el6_6.1 will be installed
---> Package neon.x86_64 0:0.29.3-3.el6_4 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: neon-0.29.3-3.el6_4.x86_64
--> Processing Dependency: libproxy.so.0()(64bit) for package: neon-0.29.3-3.el6_4.x86_64
--> Processing Dependency: libpakchois.so.0()(64bit) for package: neon-0.29.3-3.el6_4.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: neon-0.29.3-3.el6_4.x86_64
---> Package openssl.x86_64 0:1.0.1e-30.el6_6.5 will be installed
---> Package readline.x86_64 0:6.0-4.el6 will be installed
---> Package sqlite.x86_64 0:3.6.20-1.el6 will be installed
---> Package zlib.x86_64 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package augeas-libs.i686 0:1.0.0-7.el6 will be updated
--> Processing Dependency: libaugeas.so.0 for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0) for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0) for package: netcf-libs-0.2.4-1.el6.i686
---> Package gnutls.x86_64 0:2.8.5-14.el6_5 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2)(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libtasn1.so.3()(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libgcrypt.so.11()(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: gnutls-2.8.5-14.el6_5.x86_64
---> Package keyutils-libs.x86_64 0:1.4-5.el6 will be installed
---> Package libattr.x86_64 0:2.4.44-7.el6 will be installed
---> Package libcom_err.x86_64 0:1.41.12-21.el6 will be installed
---> Package libproxy.x86_64 0:0.3.0-10.el6 will be installed
--> Processing Dependency: libdbus-1.so.3()(64bit) for package: libproxy-0.3.0-10.el6.x86_64
---> Package libsepol.x86_64 0:2.0.41-4.el6 will be installed
---> Package libudev.x86_64 0:147-2.57.el6 will be installed
---> Package libuuid.x86_64 0:2.17.2-12.18.el6 will be installed
---> Package ncurses-libs.x86_64 0:5.7-3.20090208.el6 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-22.el6_6 will be installed
---> Package pakchois.x86_64 0:0.4-3.2.el6 will be installed
--> Running transaction check
---> Package augeas-libs.i686 0:1.0.0-7.el6 will be updated
--> Processing Dependency: libaugeas.so.0 for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0) for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0) for package: netcf-libs-0.2.4-1.el6.i686
---> Package dbus-libs.x86_64 1:1.2.24-7.el6_3 will be installed
---> Package libgcc.x86_64 0:4.4.7-11.el6 will be installed
---> Package libgcrypt.x86_64 0:1.4.5-11.el6_4 will be installed
--> Processing Dependency: libgpg-error.so.0()(64bit) for package: libgcrypt-1.4.5-11.el6_4.x86_64
---> Package libstdc++.x86_64 0:4.4.7-11.el6 will be installed
---> Package libtasn1.x86_64 0:2.3-6.el6_5 will be installed
--> Running transaction check
---> Package augeas-libs.i686 0:1.0.0-7.el6 will be updated
--> Processing Dependency: libaugeas.so.0 for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0) for package: netcf-libs-0.2.4-1.el6.i686
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0) for package: netcf-libs-0.2.4-1.el6.i686
---> Package libgpg-error.x86_64 0:1.7-4.el6 will be installed
--> Finished Dependency Resolution
Error: Package: netcf-libs-0.2.4-1.el6.i686 (@base)
           Requires: libaugeas.so.0(AUGEAS_0.8.0)
           Removing: augeas-libs-1.0.0-7.el6.i686 (@base)
               libaugeas.so.0(AUGEAS_0.8.0)
           Updated By: augeas-libs-1.0.0-7.el6_6.1.x86_64 (updates)
               Not found
Error: Package: netcf-libs-0.2.4-1.el6.i686 (@base)
           Requires: libaugeas.so.0(AUGEAS_0.1.0)
           Removing: augeas-libs-1.0.0-7.el6.i686 (@base)
               libaugeas.so.0(AUGEAS_0.1.0)
           Updated By: augeas-libs-1.0.0-7.el6_6.1.x86_64 (updates)
               Not found
Error: Package: netcf-libs-0.2.4-1.el6.i686 (@base)
           Requires: libaugeas.so.0
           Removing: augeas-libs-1.0.0-7.el6.i686 (@base)
               libaugeas.so.0
           Updated By: augeas-libs-1.0.0-7.el6_6.1.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #6 il: 17 Marzo 2015, 10:46:44 »
girando un po' in giro ho trovato questo link
http://serverfault.com/questions/322911/centos-6-yum-update-packages-skipped-because-of-dependency-problems

e il problema potrebbe riguardare il pacchetto epel che ho installato. Tuttavia il link proposto sembra rotto. Ti sembra una strada da tentare?

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #7 il: 20 Marzo 2015, 17:45:48 »
L'idea Ŕ quella di rimuovere i pacchetti dei repository extra e poi reinstallarli utilizzando il repository corretto altrimenti avrai sembre conflitti
rpm -qa oppure yum list  verifichi i pacchetti installati (con yum list devi guadare quelli che nella parte repo iniziano con la @) alla ricerca di quelli "estranei". Li annoti su un file di testo e poi li rimuovi a mano con yum remove nomepackage ed infine ripulisci tutto con yum clean all e poi ritenti con i repository che non ti servono disabilitati la reinstallazione dei pacchetti a te necessari.
Fammi sapere se Ŕ tutto chiaro.



Offline jops82

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #8 il: 26 Marzo 2015, 16:34:07 »
quindi tu dici che dovrei togliere a mano tutti questi pacchetti e re-installarli

https://own.lattuga.net/public.php?service=files&t=54e68d6a3f5aafee4dd9345632542af2

sinceramente un po' mi spaventa. Va bene che e' un serverino che uso per giocare pero' non vorrei che diventasse ingovernabile, dato che si tratta di un server virtuale. Ad esempio, seguendo il tuo consiglio ho provato a togliere il pacchetto "unzip" e poi a reinstallarlo.
Tuttavia in fase di reinstallazione mi dice questo:

Transaction Check Error:
  package glibc-2.12-1.149.el6_6.5.x86_64 is already installed
  package bzip2-libs-1.0.5-7.el6_0.x86_64 is already installed
  package nss-softokn-freebl-3.14.3-22.el6_6.x86_64 is already installed
  file /sbin/ldconfig from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686
  file /sbin/sln from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686
  file /usr/sbin/iconvconfig from install of glibc-2.12-1.149.el6_6.5.x86_64 conflicts with file from package glibc-2.12-1.149.el6_6.5.i686

secondo te posso provare a reinstallare glibc ? Non e' che per qualche motivo se provo a reinstallarlo mi crea qualche problema?
Non credo sia possibile sopravvivere senza la glibc... o sbaglio?
Inoltre se provo a togliere glibc oltre a darmi una marea di dipenze mi dice:

--> Finished Dependency Resolution
Error: Trying to remove "yum", which is protected

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re:Problema sugli aggiornamenti - Transaction Check Error
« Risposta #9 il: 09 Aprile 2015, 17:19:53 »
yum remove glibc-2.12-1.149.el6_6.5.i686

e poi provi a reinstallare unzip

Ciao