* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
22 Ottobre 2019, 01:16:53

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: openVpn  (Letto 1608 volte)

Offline agenore

  • Full Member
  • ***
  • Post: 93
    • Mostra profilo
    • E-mail
openVpn
« il: 21 Agosto 2015, 16:41:45 »
Salve a tutti,
sto installando un server vpn e sto incontrando dei problemi che mi lasciano un po perplesso....
L'installazione del server e la creazione dei certificati sembra essere andata a buon fine, il servizio parte, l'interfaccia tun attiva ed il client (window 7) si collega .... il dubbio che malgrado abbia messo la direttiva lato server
server 100.100.100.16 255.255.255.240
il client ottiene un indirizzo tipo:
100.100.100.22/255.255.255.252
la domanda : dove la prende quella netmask?
utilizzo un client openvpn portable che crea in automatico la dev tap su windows ... e l'ho reinstallata diverse volte pulendo anche la chiave di registro associata alla periferica.
Grazie

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re:openVpn
« Risposta #1 il: 23 Agosto 2015, 20:30:51 »
Scusa ma la cfg della vpn lato server?

I client prendono indirizzo subnet gateway in auto?

Se si chi passa i parametri?
Mayers

Where there is a shell, there is a way

Offline agenore

  • Full Member
  • ***
  • Post: 93
    • Mostra profilo
    • E-mail
Re:openVpn
« Risposta #2 il: 24 Agosto 2015, 08:55:11 »
la direttiva lato server quella indicata sopra:

server 100.100.100.16 255.255.255.240

quindi mi aspetto che il client prenda quella rete, ed in parte lo fa...

100.100.100.22/255.255.255.252 (dati passati al client)

solo che mette una subnet diversa e purtroppo pi restrittiva.... :P

Offline divagazioni

  • Jr. Member
  • **
  • Post: 25
    • Mostra profilo
Re:openVpn
« Risposta #3 il: 24 Agosto 2015, 15:47:59 »
ciao agenore,
la buona notizia non c' nulla di strano o che non va nella tua configurazione.

cito da:  https://openvpn.net/index.php/open-source/documentation/howto.html

"Uncomment out the client-to-client directive if you would like connecting clients to be able to reach each other over the VPN. By default, clients will only be able to reach the server"
 
in sostanza per ogni client viene creata una piccola subnet con 4 ip che compongono appunto la subnet, il broadcast, l'ip openvpn del client ed il gateway openvpn del client.

onestamente non ho mai avuto l'esigenza di far parlare assieme i client di una openvpn. se quello il tuo obiettivo credo che oltre ad abilitare la direttiva di cui sopra ci sia da lavorare un po' di iptables (e questa era la cattiva notizia).

ciao

Offline agenore

  • Full Member
  • ***
  • Post: 93
    • Mostra profilo
    • E-mail
Re:openVpn
« Risposta #4 il: 25 Agosto 2015, 08:08:42 »
ciao, grazie per risposta.... ma era quel default che mi lasciava speranzoso. c' da dire che ho utilizzato un tunnel ip e non un bridge ethernet ma il concetto dovrebbe essere identico. Usando il tun effettivamente avrei dovuto utilizzare un firewall ... ma ci potrebbe anche stare.
Per ripeto .... il default che mi lascia perplesso.
grazie comunque.

Offline agenore

  • Full Member
  • ***
  • Post: 93
    • Mostra profilo
    • E-mail
Re:openVpn
« Risposta #5 il: 25 Agosto 2015, 10:08:51 »

 

Notizie

Registrati ora per avere pieno accesso a tutte le risorse della community , necessaria anche per area download, i link nei post, e altre funzioni.

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 6291
  • Ultimo: brux
Statistiche
  • Post in totale: 13029
  • Topic in totale: 2923
  • Online Oggi: 259
  • Massimi online: 975
  • (03 Novembre 2018, 08:19:28)
Utenti Online
Utenti: 0
Visitatori: 259
Totale: 259

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50