Autore Topic: Problema con systemd [Risolto]  (Letto 3729 volte)

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1396
    • Mostra profilo
    • Traversate dei laghi
Problema con systemd [Risolto]
« il: 07 Gennaio 2019, 10:01:48 »
Nelle ultime 2 settimane mi sono capitati starni problemi su un CentOS Linux release 7.5.1804 (Core), come ad esempio il comando df che non si completa e rimane "zombie", i servizi che rilevano spazio insufficiente sul disco (in realtà ci sono oltre 2 tera disponibili!), ecc problemi che con il riavvio di proc-sys-fs-binfmt_misc.mount si risolvono, ma non definitivamente.

Oggi rientrando in ufficio trovo i cronjob di yum "zombie", yum che non funziona, servizi che non si avviano perchè non rilevano spazio, a parte yum con il riavvio del processo come indicato sopra tutto torna normale.

Da una ricerca in rete sembra ci sia un problema con le tabelle di routing, proprio dall 7.5 di centos; controllando la tbella di routing però non vedo nulla di strano:
Codice: [Seleziona]
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         pfsense         0.0.0.0         UG    100    0        0 eno1
x.x.x.0       0.0.0.0         255.255.255.0   U     100    0        0 eno1

Se provo il ping tutto funziona regolarmente, gli indirizzi vengono risolti e le risposte arrivano.

Questo problema si dovrebbe anche risolvere con un aggiornamento di systemd, che però non riesco ad eseguire in quanto yum rimane bloccato.

Edit:
dopo aver "eliminato" i file /var/lib/rpm/__db.00* yum è tornato a funzionare, ho fatto l'update di systemd, verificherò se è la soluzione definitiva o meno, poi aggiornerò il topic.

Ri-Edit:
Aggiornato systemd il problema non si è ripresentato.
« Ultima modifica: 10 Gennaio 2019, 16:28:36 da LonelyWolf »