* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
13 Dicembre 2019, 22:39:44

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Problema mail php RISOLTO  (Letto 5376 volte)

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Problema mail php RISOLTO
« il: 20 Maggio 2009, 14:36:41 »
Ciao a tutti non capisco come mai le mail non vengano iniviate tramite php. Non uso un server di posta interno dato che indirizzo ad un'altro server il lavoro.

1 - Le mail non si resco a inviare a nessuno se non gmail
2 - Nessun gestore di posta installato
3 - se le mando alla casella del mio sito viene inviato tipo info@miosito.com

Non so che pensare vi posto anche la config del php.ini

[mail function]
; For Win32 only.
;SMTP = localhost
;smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = "/usr/sbin/sendmail -t -i"

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =


qualche idea grazie a tutti
« Ultima modifica: 16 Giugno 2009, 17:18:53 di Ablius »

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Re: Problema mail php
« Risposta #1 il: 20 Maggio 2009, 17:12:57 »
allora le mail vengono spedite ma i server di libero , gli altri non le accettano come posso risolvere la cosa ???

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Re: Problema mail php
« Risposta #2 il: 21 Maggio 2009, 15:48:39 »
Ho seguito questa guida :
http://mpickering.homeip.net/phpwiki/HomePage/2004-06-24.html

ma non ho risolto nulla qualche idea perfavore

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1354
    • Mostra profilo
    • Traversate dei laghi
Re: Problema mail php
« Risposta #3 il: 21 Maggio 2009, 16:47:28 »
Se sei sicuro che non le accettano loro hai poche soluzioni:
1 - verificare di non essere in una blacklist
2 - verificare il dns inverso del mittente, se non raggiungibile alcuni provider cestinano direttamente le mail

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Re: Problema mail php
« Risposta #4 il: 21 Maggio 2009, 22:24:22 »
ho provato a mandare mail da shell :

[root@web etc]# echo "Test message" | sendmail -v xxxxxxxxxxx@gmail.com
xxxxxxxxxxxxxx@gmail.com... Connecting to [127.0.0.1] via relay...
220 web ESMTP Exim 4.63 Thu, 21 May 2009 22:14:19 +0200
>>> EHLO xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
250-web Hello xxxxxxxxxxxxxxxxxxxxxxxxxx [127.0.0.1]
250-SIZE 52428800
250-PIPELINING
250-STARTTLS
250 HELP
>>> STARTTLS
220 TLS go ahead
>>> EHLO xxxxxxxxxxxxxxxxxxxxxxxxxxxx
250-web Hello xxxxxxxxxxxxxxxxxxxxxxxxxxxx[127.0.0.1]
250-SIZE 52428800
250-PIPELINING
250 HELP
>>> MAIL From:<root@xxxxxxxxxxxx> SIZE=13
250 OK
>>> RCPT To:<xxxxxxxxx2001@gmail.com>
>>> DATA
550-Verification failed for <root@xxxxxxxxxxx>
550-Unrouteable address
550 Sender verify failed
503 valid RCPT command must precede DATA
>>> RSET
250 Reset OK
>>> RSET
250 Reset OK
root... Using cached ESMTP connection to [127.0.0.1] via relay...
>>> MAIL From:<> SIZE=1037
250 OK
>>> RCPT To:<root@xxxxxxxxxxx>
>>> DATA
250 Accepted
354 Enter message, ending with "." on a line by itself
>>> .
250 OK id=1M7Eeh-0007FV-Bg
root... Sent (OK id=1M7Eeh-0007FV-Bg)
Closing connection to [127.0.0.1]
>>> QUIT
221 web closing connection

mi sa che ce qualcosa che non va

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1354
    • Mostra profilo
    • Traversate dei laghi
Re: Problema mail php
« Risposta #5 il: 22 Maggio 2009, 08:58:59 »
Citazione da: Ablius
550-Verification failed for <root@xxxxxxxxxxx>
550-Unrouteable address
550 Sender verify failed

E' quello che ti dicevo nel mio post precedente, il server destinatario non riesce a risolvere "all'indietro" il dominio del mittende e quindi rifiuta!

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Re: Problema mail php
« Risposta #6 il: 22 Maggio 2009, 10:42:15 »
Grazie per il tempo dedicato a questo posto il server infatti inivia non come ip :

62.149.197.246

ma lo invia cosi :

root@host62-149-197-246.serverdedicati.aruba.it

come posso risolvere la questione ???

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1354
    • Mostra profilo
    • Traversate dei laghi
Re: Problema mail php
« Risposta #7 il: 22 Maggio 2009, 11:53:59 »
far sistemare i dns di aruba in mdo che il dominio che risulta nell'invio sia raggiungibile, cambiare il mittente in modo che sia raggiungibile!

Offline Ablius

  • Full Member
  • ***
  • Post: 87
    • Mostra profilo
Re: Problema mail php
« Risposta #8 il: 16 Giugno 2009, 17:18:35 »
Scusate del Ritardo ho risolto e posto magari qualcuno serve. Molti provider quando ricevono la mail controllano chi la manda, se e un sito attivo viene accettato se non non viene accettato. Ecco risolto l'arcano motivo per cuoi la mail non arrivara. Cambiato hostname con il nome del sito principale tutto ha funzionato con sedmail attiva. Grazie a tutti e scusare la niubbaggine mia..

 

Notizie

CentOS-Italia.Org nasce con l'obiettivo di creare una community per la condivisione delle conoscenze nell' interesse di tutta la communita' e non come servizio al utente che cerca solo una soluzione al suo problema.

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 6300
  • Ultimo: DSalvo
Statistiche
  • Post in totale: 13040
  • Topic in totale: 2925
  • Online Oggi: 809
  • Massimi online: 1301
  • (02 Dicembre 2019, 11:04:32)
Utenti Online
Utenti: 0
Visitatori: 761
Totale: 761

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50