* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
16 Giugno 2019, 21:46:08

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: problemi con nslcd  (Letto 1307 volte)

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1335
    • Mostra profilo
    • Traversate dei laghi
problemi con nslcd
« il: 02 Novembre 2017, 17:24:56 »
Sto diventando matto per cercare di risolvere un problema che, all'atto pratico non mi sembra stia creando seri problemi, ma non capendo da dove nasce non lo posso escludere.

Ho un server centos 6.9, con autenticazione utenti linux/samba su server ldap locale (no niente AD/dominio), chiamiamolo server1, funziona benissimo e ogni tanto compare nel log:
nslcd_passwd_byname(//ip_del_server): invalid user name

Avevo una vm con centos 5 che si è "rotta", quindi in emergenza (non chiediamo perchè) ho dovuto crearne un'altra, l'avrei fatta con centos 7 ma kvm dell'host (centos 5) non riusciva a gestirla, quindi sono partito con centos 6.9, chiamiamolo server2.

Dato che gli utenti sono gli stessi di server1 (prima erano utenti locali suquesta macchina) ho deciso di impostare l'autenticazione su ldap da server1;  quindi dopo aver avuto un po' di difficoltà, getent mi restituisce utenti/gruppi, l'autenticazione linux funziona e copio la configurazione di samba4 da server1 a server2 (ovviamente modificando uri del server ldap); tutto sembra funzionare correttamente però l'accesso ai file delle condivisioni è veramente molto lento, samba non indica nulla nei propri log, e noto che uno dei log del server si riempie in modo esagerato di:
nslcd_passwd_byname(//xxxxx): invalid user name
dove xxxxx è indicato come: nome del vecchio server in minuscolo/in maiuscolo/indirizzo ip.

I server dns locali (ovvero server1 master e server2 slave) risolvono correttamente i nomi, (anche se dovrei controllare meglio la configurazione per eventuali modifiche intervenute.)

Cercando con google non ho trovato nulla di risolutivo, tantomeno indizi rilevanti.

Quando resto in attesa con nlscd in debug sulla console, il log registra tutt'altri errori e nella console vengono visualizzate le richieste corrette!

Non so proprio cosa controllare, qualsiasi suggerimento è ben accetto.

 

Notizie

Registrati ora per avere pieno accesso a tutte le risorse della community , necessaria anche per area download, i link nei post, e altre funzioni.

Collegamenti

Posts Recenti

Utenti
Statistiche
  • Post in totale: 12993
  • Topic in totale: 2914
  • Online Oggi: 227
  • Massimi online: 975
  • (03 Novembre 2018, 08:19:28)
Utenti Online
Utenti: 0
Visitatori: 91
Totale: 91

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

inetryconydot

08 Settembre 2017, 07:44:23

inetryconydot

20 Maggio 2017, 10:00:13
Stromectol is used for treating infections caused by certain parasites. Stromectol is an anthelmintic. It works by killing sensitive parasites.
 
Stromectol as known as: Ivectin, Ivenox, Ivera, Ivergot, Ivermec, Ivermectina, Ivermectine, Ivermectinum, Ivert, Ivexterm, Kilox, Mectizan, Quan

Mostra ultimi 50