Autore Topic: Aggiornamento PHP non riuscito  (Letto 2447 volte)

Offline INVY

  • Full Member
  • ***
  • Post: 61
    • Mostra profilo
    • E-mail
Aggiornamento PHP non riuscito
« il: 27 Febbraio 2013, 07:31:19 »
Ciao,

su un server con CentOS6.3 - con reposity atomic attivato oltre che quelli di default - ho provato ad aggiornare PHP dalla versione 5.3.21 alla 5.3.22, cosa che ho eseguito su altri server senza problemi, ma non ci sono riuscito per via di "Protected multilib versions":

Loading mirror speeds from cached hostfile
 * atomic: mir01.syntis.net
 * base: mirrors.prometeus.net
 * extras: mirrors.prometeus.net
 * updates: mirrors.prometeus.net
183 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
....
Error: Protected multilib versions: php-common-5.3.22-15.el6.art.x86_64 != php-common-5.3.21-14.el6.art.i686
Error: Protected multilib versions: php-5.3.21-14.el6.art.i686 != php-5.3.22-15.el6.art.x86_64
Error: Protected multilib versions: php-cli-5.3.21-14.el6.art.i686 != php-cli-5.3.22-15.el6.art.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
.. install failed!

No packages were installed. Check the messages above for the cause of the error.

Prima di combinare guai, mi date delle "dritte" su come proseguire?

Grazie :-)

Offline INVY

  • Full Member
  • ***
  • Post: 61
    • Mostra profilo
    • E-mail
Re: Aggiornamento PHP non riuscito
« Risposta #1 il: 27 Febbraio 2013, 08:35:58 »
mi rispondo da me:

ho disinstallato php-eaccelerator (pacchetto obsoleto) con

yum remove php-eaccelerator.x86_64

ed bastato questo per permettere l'update di PHP e di tutte le sue dipendenze :-)