* * *
Benvenuto! Effettua l'accesso oppure registrati.
12 Maggio 2021, 23:21:10

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: errore sendEmail  (Letto 3123 volte)

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
errore sendEmail
« il: 28 Marzo 2013, 13:01:43 »
ciao a tutti.
utilizzando sendEmail, per l'invio di una mail a backup eseguito, mi restituisce questo errore:
Output dal comando /usr/local/bin/backupext.sh giornaliero.cfg ...

Rsync in esecuzione...
Mar 28 12:58:59 srv sendEmail[3650]: ERROR => Connection attempt to localhost:25 failed: IO::Socket::INET: connect: Connection refused


premetto che postfix funzionante.
[root@srv ~]# telnet out.alice.it 25
Trying 82.57.200.132...
Connected to out.alice.it.
Escape character is '^]'.
220 smtp205.alice.it ESMTP Service ready
quit
221 smtp205.alice.it QUIT

avete qualche idea?

grazie in anticipo
« Ultima modifica: 28 Marzo 2013, 13:12:04 di scansione_1 »

Offline kernel

  • Moderator
  • Hero Member
  • *****
  • Post: 636
    • Mostra profilo
    • Centos Italia
Re:errore sendEmail
« Risposta #1 il: 28 Marzo 2013, 13:56:38 »
pare si colleghi a localhost e non ad out.alice.it ..
a meno che nel main.cf non ci sia il relay verso alice ..
Hai fatto i backup oggi ? CentOS la classe linux superiore www.centos-italia.org - Se il tuo problema e' stato risolto, per favore comunicacelo e condiviti la conoscenza.

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
Re:errore sendEmail
« Risposta #2 il: 28 Marzo 2013, 14:01:18 »
ciao
si il relay verso alice, nel file main.cf per inviare la posta
in tutte le configurazioni ad oggi ho sempre fatto cos.

ad oggi ho sempre configurato solo postfix ed andava tutto bene.

adesso ho modificato in /usr/local/bin/sendEmail

localhost ----> con out.alice.it
Rsync in esecuzione...
Mar 28 14:03:07 srv sendEmail[3271]: Email was sent successfully!

ogni nuova configurazione, c' sempre qualcosa che cambia.
grazie


« Ultima modifica: 28 Marzo 2013, 14:05:31 di scansione_1 »

Offline kernel

  • Moderator
  • Hero Member
  • *****
  • Post: 636
    • Mostra profilo
    • Centos Italia
Re:errore sendEmail
« Risposta #3 il: 28 Marzo 2013, 14:07:26 »
fai un

Codice: [Seleziona]
telnet localhost 25
e invia un email e vedi se la ricevi , poi posta qua output

helo me
mail from:
rcpt to:
data
prova
.
quit
Hai fatto i backup oggi ? CentOS la classe linux superiore www.centos-italia.org - Se il tuo problema e' stato risolto, per favore comunicacelo e condiviti la conoscenza.

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
Re:errore sendEmail
« Risposta #4 il: 28 Marzo 2013, 14:09:05 »
la mail stata inviata, ricevuta correttamente, con un secondo messaggio:

 Mail Delivery Service
 These recipients of your message have been processed by the mail server:
backup@lineacasa.it; Failed; 5.1.3 (bad destination mailbox address syntax)

    Remote MTA mail.register.it: SMTP diagnostic: 553 5.1.1 sorry, no mailbox here by that name.  (questo errore lo ricevo solo se le mail vengono inviate dal cron)
se invio le mail da webmin "postfix" nessun errore.
ho fatto il test:

[root@srv ~]# telnet localhost 25
Trying ::1...
Connected to localhost.
Escape character is '^]'.
220 srv.lineacasa.local ESMTP Postfix (2.6.6)
helo me
250 srv.lineacasa.local
mail from:
501 5.5.4 Syntax: MAIL FROM:<address>
mail from: pcsupport@pcsupport.it
250 2.1.0 Ok
rcpt to: backup@lineacasa.it           
250 2.1.5 Ok
data
354 End data with <CR><LF>.<CR><LF>
prova
.
250 2.0.0 Ok: queued as 0178E1120499
quit
221 2.0.0 Bye
Connection closed by foreign host.
« Ultima modifica: 28 Marzo 2013, 14:14:26 di scansione_1 »

Offline kernel

  • Moderator
  • Hero Member
  • *****
  • Post: 636
    • Mostra profilo
    • Centos Italia
Re:errore sendEmail
« Risposta #5 il: 28 Marzo 2013, 14:12:23 »
cosa vuol dire con un secondo messaggio ?
Hai fatto i backup oggi ? CentOS la classe linux superiore www.centos-italia.org - Se il tuo problema e' stato risolto, per favore comunicacelo e condiviti la conoscenza.

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
Re:errore sendEmail
« Risposta #6 il: 28 Marzo 2013, 14:22:47 »
quando cron esegue una operazione "backup"

Rsync in esecuzione...
Mar 28 14:03:07 srv sendEmail[3271]: Email was sent successfully!

ricevo la mail di conferma del backup con log ecc ecc.

poi ricevo un messaggio di errore:
da: Mail Delivery Service <postmaster@alice.it>
oggetto: Delivery Status Notification
- These recipients of your message have been processed by the mail server:
backup@lineacasa.it; Failed; 5.1.3 (bad destination mailbox address syntax)

    Remote MTA mail.register.it: SMTP diagnostic: 553 5.1.1 sorry, no mailbox here by that name.

Offline kernel

  • Moderator
  • Hero Member
  • *****
  • Post: 636
    • Mostra profilo
    • Centos Italia
Re:errore sendEmail
« Risposta #7 il: 28 Marzo 2013, 14:28:08 »
Codice: [Seleziona]
cat /var/log/maillog | grep 0178E1120499
Hai fatto i backup oggi ? CentOS la classe linux superiore www.centos-italia.org - Se il tuo problema e' stato risolto, per favore comunicacelo e condiviti la conoscenza.

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
Re:errore sendEmail
« Risposta #8 il: 28 Marzo 2013, 14:34:20 »
[root@srv ~]# cat /var/log/maillog | grep 0178E1120499
Mar 28 14:11:35 srv postfix/smtpd[3444]: 0178E1120499: client=localhost.localdomain[::1]
Mar 28 14:11:50 srv postfix/cleanup[3460]: 0178E1120499: message-id=<20130328131135.0178E1120499@srv.lineacasa.local>
Mar 28 14:11:50 srv postfix/qmgr[1792]: 0178E1120499: from=<pcsupport@pcsupport.it>, size=359, nrcpt=1 (queue active)
Mar 28 14:11:50 srv postfix/local[3461]: 0178E1120499: to=<backup@lineacasa.it>, relay=local, delay=87, delays=87/0.02/0/0.05, dsn=2.0.0, status=sent (delivered to mailbox)
Mar 28 14:11:50 srv postfix/qmgr[1792]: 0178E1120499: removed
[root@srv ~]#

le modifiche che ho fatto in main.cf sono:

[root@srv ~]# nano /etc/aliases
root:           backup
nano  /etc/postfix/sender_canonical
root    backup@lineacasa.it

masquerade_domains = $mydomain
lineacasa.it

Offline kernel

  • Moderator
  • Hero Member
  • *****
  • Post: 636
    • Mostra profilo
    • Centos Italia
Re:errore sendEmail
« Risposta #9 il: 28 Marzo 2013, 14:36:40 »
ma non fa il relay ad alice .

relay=local,


spedisce da se stesso
Hai fatto i backup oggi ? CentOS la classe linux superiore www.centos-italia.org - Se il tuo problema e' stato risolto, per favore comunicacelo e condiviti la conoscenza.

Offline scansione_1

  • Full Member
  • ***
  • Post: 54
    • Mostra profilo
    • E-mail
Re:errore sendEmail
« Risposta #10 il: 28 Marzo 2013, 14:38:49 »
come posso risolvere?
grazie


 

Notizie

Se vuoi migrare il tuo server windows a CentOS sei nel posto giusto !!

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 5959
  • Ultimo: Sina
Statistiche
  • Post in totale: 13160
  • Topic in totale: 2962
  • Online Oggi: 270
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 239
Totale: 239

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50