* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
27 Maggio 2020, 10:50:54

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: problema configurazione bind  (Letto 1592 volte)

Offline Simo7

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
problema configurazione bind
« il: 22 Luglio 2017, 12:28:44 »
bungiorno esperti
ho configurato il servizio bind come da guida scolastica e mi risolta questo errore . non riesco ad allegarvi il file di testo con la configurazione completa quindi vi lascio questo
di cosa si tratta?
ringrazio


[root@simone ~]# service named restart
Stopping named:                                            [  OK  ]
Starting named:
Error in named configuration:
zone simone.local/IN: NS 'simone.local.simone.local' has no address records (A or AAAA)
zone simone.local/IN: not loaded due to errors.
_default/simone.local/IN: bad zone
zone 0.168.192.in-addr.arpa/IN: NS 'simone.local.0.168.192.in-addr.arpa' has no address records (A or AAAA)
zone 0.168.192.in-addr.arpa/IN: not loaded due to errors.
_default/0.168.192.in-addr.arpa/IN: bad zone
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0

non riesco a mandare un allegato per la configurazione completa
di cosa si tratta?
« Ultima modifica: 22 Luglio 2017, 12:34:15 di Simo7 »

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1362
    • Mostra profilo
    • Traversate dei laghi
Re:problema configurazione bind
« Risposta #1 il: 24 Luglio 2017, 09:07:52 »
zone simone.local/IN: NS 'simone.local.simone.local' has no address records (A or AAAA)
zone 0.168.192.in-addr.arpa/IN: NS 'simone.local.0.168.192.in-addr.arpa' has no address records (A or AAAA)

non hai messo i record di tipo A o AAA nel file di configurazione della zona
https://www.centos.org/forums/viewtopic.php?t=8907

Offline Simo7

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
Re:problema configurazione bind
« Risposta #2 il: 24 Luglio 2017, 11:33:17 »
zone simone.local/IN: NS 'simone.local.simone.local' has no address records (A or AAAA)
zone 0.168.192.in-addr.arpa/IN: NS 'simone.local.0.168.192.in-addr.arpa' has no address records (A or AAAA)

non hai messo i record di tipo A o AAA nel file di configurazione della zona
https://www.centos.org/forums/viewtopic.php?t=8907
ti ringrazio per la risposta.
io ho fatto cos come mi hanno insegnano al corso
Codice: [Seleziona]
zona forward

$TTL 86400
@ IN SOA    simone.local. root.simone.local.(
           2011071001   ;Serial
           3600         ;Refresh
           1800         ;Retry
           604800 ;Expire
           86400        ;Minimum TTL
)

@           IN  NS simone.local
@           IN  A 192.168.0.15
@           IN  A 192.168.0.2
simone      IN  A 192.168.0.15
@           IN  A 192.168.0.2



reverse

  GNU nano 2.0.9                 File: /var/named/reverse.simone.local                                         
                                   

@ IN SOA simone.local. root.simone.local. (
                2014070501 ;Serial
                3600            ;Refresh
                1800            ;Retry
                604800          ;Expire
                86400           ;Minimum TTL
)

@               IN NS simone.local
@               IN PTR     192.168.0.15
@               IN A 192.168.0.2
15              IN PTR     simone.local
2         IN PTR 192.168.0.2

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1362
    • Mostra profilo
    • Traversate dei laghi
Re:problema configurazione bind
« Risposta #3 il: 24 Luglio 2017, 12:04:08 »
manca il record per il "NS"

simone.local IN  A xxxxxxxx

Offline Simo7

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
Re:problema configurazione bind
« Risposta #4 il: 25 Luglio 2017, 11:43:28 »
manca il record per il "NS"

simone.local IN  A xxxxxxxx
ti ringrazio per l'aiuto. sono ancora alle prime armi uscito da scuola.

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1362
    • Mostra profilo
    • Traversate dei laghi
Re:problema configurazione bind
« Risposta #5 il: 25 Luglio 2017, 12:00:27 »
Ok, per impara a leggere con attenzione i messaggi di errore, adesso te lo evidenzio, era scritto per bene:
zone simone.local/IN: NS 'nome_host' has no address records (A or AAAA)

Offline Simo7

  • Newbie
  • *
  • Post: 5
    • Mostra profilo
Re:problema configurazione bind
« Risposta #6 il: 25 Luglio 2017, 12:47:58 »
ti ringrazio molto. a scuola non ci hanno spiegato molto bene il significato delle singole opzioni tipo A IN PTR ecc
grazie :)

 

Notizie

Per problemi di registrazione scrivere a centos (at) centos-italia (dot) org

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 6320
  • Ultimo: gspira
Statistiche
  • Post in totale: 13078
  • Topic in totale: 2941
  • Online Oggi: 180
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 1
Visitatori: 171
Totale: 172

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50