* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
27 Settembre 2020, 20:12:18

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: vncserver al boot del sistema  (Letto 1889 volte)

Offline fabcri

  • Full Member
  • ***
  • Post: 120
    • Mostra profilo
vncserver al boot del sistema
« il: 03 Maggio 2012, 15:41:02 »
ho installato  tigervnc-server.x86_64 nel seguente modo:

yum install tigervnc-server.x86_64
modificato /etc/sysconfig/vncservers togliendo i commenti a

    VNCSERVERS="2:utente1"
    VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -localhost"

creato la password con "vncpasswd" ed avviato il servizio manualmente "vncserver :2"

connettendomi con : 192.168.10.10:2 riesco a collegarmi al server vnc.

se lancio "chkconfig vncserver on" per attivare vncserver all'avvio del sistema e provo a connettermi non riesco a visualizzare il desktop remoto.

per attivare il servizio all'avvio non basta "chkconfig vncserver on"  ?

Offline ciso39

  • Full Member
  • ***
  • Post: 79
    • Mostra profilo
Re: vncserver al boot del sistema
« Risposta #1 il: 04 Maggio 2012, 01:34:54 »
Ciao fabcri,
prova "netstat -naupdt | grep Xvnc" e vedi su che IP e porta ascolta
vnc sul server. VNC ascolta su 5900+<il numero del display>,
nel tua caso dovrebbe essere 5902.
Non capisco come tu possa collegarti da un altro pc
se non togli gli altri 2 parametri. Fai MOLTA attenzione
perchè senza quei parametri il server risulterà molto
esposto...... Come sei messo a firewall ????
ciao

Offline fabcri

  • Full Member
  • ***
  • Post: 120
    • Mostra profilo
Re: vncserver al boot del sistema
« Risposta #2 il: 04 Maggio 2012, 09:06:47 »
ciao,

allora il firewall è aperto per le porte 5900 5901 5902

entrando a # e digitando:

# su utente1
# vncserver :2

il vnc crea dei file temporanei in /home/utente1/./vnc

poi con il visualizzatore di desktop di ubuntu entro all'indirizzo 192.168.10.10:2

il problema sta quando cerco di attivare il tutto come servizio all'avvio di centos.

Per quanto riguarda la sicurezza mi spieghi meglio ?

Offline ciso39

  • Full Member
  • ***
  • Post: 79
    • Mostra profilo
Re: vncserver al boot del sistema
« Risposta #3 il: 04 Maggio 2012, 23:07:21 »
ciao,
avvia il server, usa il comando netstat (o ps) per controllare se il servizio
è partito. Se non è partito prova:
service vncserver restart e vedi cosa ti dice.
Sotto la home dell'utente/.vnc dovrebbe esserci anche
il log. Riusa i comadi per vedere se il servizio è partito,
altrimenti controlla il log.
Per quanto riguarda la sicurezza, volevo solo sottolineare
quello che c'è gia scritto nel file che hai modificato:
-nolisten tcp (non ascolta su tcp, come fai a collegarti da un altro PC????)
-localhost (ascolta solo su localhost, ti "consiglia" di collegarti al server vnc
via tunneling.... su google trovi molti esempi).
Quindi questi 2 parametri vanno tolti (soprattutto in fase di installazione e prova
del servizio); togliendo questi parametri il server ascolterà su 0.0.0.0:5902,
permetterà tutte le connessioni, anche quelle non desiderate.
Per questo ti ho detto del firewall.
Ciao



 

Notizie

Registrati ora per avere pieno accesso a tutte le risorse della community , necessaria anche per area download, i link nei post, e altre funzioni.

Collegamenti

Posts Recenti

Utenti
Statistiche
  • Post in totale: 13106
  • Topic in totale: 2953
  • Online Oggi: 265
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 250
Totale: 250

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c'è mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50