Autore Topic: [RISOLTO]problema smbldap-populate + join dei client al dominio  (Letto 30176 volte)

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #45 il: 24 Ottobre 2011, 10:56:41 »
scolta riesci a darmi accesso ssh alla macchina

possiamo organizzare se vuoi un appuntamento per fare un assistenza

skype tipo ed ssh se ti va
Mayers

Where there is a shell, there is a way

Offline masterizzatore

  • Jr. Member
  • **
  • Post: 49
    • Mostra profilo
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #46 il: 24 Ottobre 2011, 16:01:09 »
mi dispiace ma non posso fidarmi di qualcuno che non conosco,anche se l'idea mi piaceva..mi disp,cmq ho trovato altre guide in inglese,che aggiungono un sacco di schemi ldif e la procedura è un pò più simile a quelle che avevo fatto anche io su debian..però il risultato non cambia.ora riprovo a reinstallare il server da capo anziche ripristinare l'immagine..un curiosità te avevi fatto la netinstall impostata su "basic server"??

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #47 il: 24 Ottobre 2011, 16:11:03 »
si net install basic server cmq secondo me non è un problema di pacchetti
Mayers

Where there is a shell, there is a way

Offline masterizzatore

  • Jr. Member
  • **
  • Post: 49
    • Mostra profilo
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #48 il: 27 Ottobre 2011, 15:18:08 »
allora ho provato a configurare ldap,senza convertire slapd.con ma ggiungendo tutti gli schemi ldif a mano..il problema ovviamente non cambia..sempre lo stesso.ora il cerchio si restringe e secondo me è colpa di samba,nella guida si fa riferimento a samba 3.5.11,ma nei repo per centos a 32 bit c'è solo la 3.5.9 questo può incidere?mayers il tuo server è un 64 bit giusto?

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #49 il: 27 Ottobre 2011, 16:14:05 »
si usa la 3.5.11 anche se io sono partito usando la 3.5.4
Mayers

Where there is a shell, there is a way

Offline masterizzatore

  • Jr. Member
  • **
  • Post: 49
    • Mostra profilo
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #50 il: 27 Ottobre 2011, 17:38:50 »
CE L'HO FATTAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

credo che la soluzione era in ldap.conf

ho aggiunto:
rootbinddn cn=admin,dc=dominio,dc=ext_dominio
bind_policy soft
host 127.0.0.1

poi ldap non l'ho configurato secondo la tua guida.sostanzialmente ho cancellato il contenuto slapd.conf lasciando solamente due righe:

pidfile     /var/run/openldap/slapd.pid
argsfile    /var/run/openldap/slapd.args

poi ho aggiunto gli schemi di default in /etc/opneldap/schema tipo:cosine.ldif,core.ldif,samba.ldif ecc.

poi ho creato un file backend.ldif e uno frontend.ldif e dove dentro ho inserito le oppurtune stringhe.

e poi il resto uguale alla tua guida,cambiando però come ho detto ldap.conf e una voce in /etc/sysconfig/ldap (SLAPD_LDAPI=yes)

per consentire di usare il comando "ldapadd -Y EXTERNAL -H ldapi:/// -f "

poi ho usato samba 3.5.4 e ora fungeeeeeeeeeeeeeeeeee evvai! a breve scrivo la mia di guida magari può tornare utile ;) grazie di tutto ciao


Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #51 il: 27 Ottobre 2011, 18:33:02 »
strano cmq io non ho mai dovuto effettuare quei passaggi!!! :o :o :o

Ho fatto pdc partendo da samba 3.5.4 ma ho usato anche direttamente 3.5.11 senza aver nessun problema in merito
Mayers

Where there is a shell, there is a way

Offline masterizzatore

  • Jr. Member
  • **
  • Post: 49
    • Mostra profilo
Re: smb+ldap centos6 problema smbldap-populate
« Risposta #52 il: 27 Ottobre 2011, 18:59:52 »
boh non lo so...ma è normale ogni cosa che io faccio è sempre più complessa del normale  :( però ce l'ho fatta.cmq in realtà non c'è differenza alla base tra il mio metedo e il tuo,è uguale e ti spiego il perchè,te hai configurato ldap scrivendo prima in slapd.conf per poi convertirlo in cn,io ho convertito slapd.conf in cn con slapd vuoto(o meglio con solo le due righe che ti ho scritto su) e poi l'ho configurato tramite cn,ovvero aggiungendo tutti i dati necessari tramite gli schemi ldif che mi creavo.dati che avrebbe preso da slapd.conf al momento della conversione se ce li avessi inseriti.e cmq non andava,ho aggiunto le righe che ti dicevo in ldap.conf e zack!magia.ora è tutto ok come dovrebbe essere un classico PDC! :) mi dici come mettere risolto??grazie

Offline mayers81

  • Hero Member
  • *****
  • Post: 613
    • Mostra profilo
    • E-mail
Risolto: smb+ldap centos6 problema smbldap-populate
« Risposta #53 il: 27 Ottobre 2011, 22:15:42 »
lo scrivi nella risposta
Mayers

Where there is a shell, there is a way

Offline masterizzatore

  • Jr. Member
  • **
  • Post: 49
    • Mostra profilo
Re: [RISOLTO]smb+ldap centos6 problema smbldap-populate
« Risposta #54 il: 28 Ottobre 2011, 12:40:45 »
mayers una cosa,questo problema lo avevo anche su sul pdc con ubuntu,perchè i client non possono cambiare la password?cioè la cambiano solo se disabilito unix passwd sync= no,problema di permessi?di passwd chat?