* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
27 Settembre 2020, 19:19:46

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Installazione Hylafax su centos  (Letto 8573 volte)

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Installazione Hylafax su centos
« il: 24 Ottobre 2012, 11:47:38 »
Salve a tutti :)

Ho la necessita di configurazione un server fax,
Ho installato il modem e installato hylafax. Ma non riesco a farlo funzionare.
quando eseguo il comando "faxstat" mi viene restituito questo errore :

[root@faxServer ~]# faxstat
Warning, getaddrinfo failed with -2: Name or service not known

Qualcuno mi sa dire a cosa si riferisce ?

La configurazione di hylafax e molto semplice.
Ho provato ad utilizzare il modem con minicom, riesco a fare una telefonata ma se provo a chiamare il modem non ho nessuna risposta  ???

Non capisco se l'errore dipende da hylafax se dipende da un errata configurazione del modem e da entrambi :)

grazie

Offline LonelyWolf

  • Moderator
  • Hero Member
  • *****
  • Post: 1371
    • Mostra profilo
    • Traversate dei laghi
Re: Installazione Hylafax su centos
« Risposta #1 il: 24 Ottobre 2012, 12:55:42 »
Così a occhio sembrerebbe un problema di configurazione, faxstat è un client per hylafax prova a verificare cosa succede usando l'opzione -v.

Prova anche a dare un'occhiata a questa guida:
http://www.centos-italia.org/index.php?page=Semplice%20e%20veloce%20soluzione%20per%20gestire%20i%20fax%20in%20modo%20centralizzato

Ulteriori informazioni sarebbero state più utili per risponderti (a.e. ver hylafax/centos, ecc)

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #2 il: 24 Ottobre 2012, 14:38:18 »
Le versioni sono
Centos 6.3 final
hylafax 6.0.6

Non so ho letto la guida ma ho ripetuto i passaggi e sembra che sia tutto ok ora proverà ad installare apache e php cosa che prima non avevo, ma potrebbe essere quello il problema ?

Faro sapere

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re: Installazione Hylafax su centos
« Risposta #3 il: 24 Ottobre 2012, 15:50:14 »
hai già eseguito faxsetup?

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #4 il: 24 Ottobre 2012, 16:38:16 »
Si faxsetup gia fatto
ora faxstat mi restituisce HylaFAX scheduler on localhost.localdomain: Running
era un problema dovuto al file hosts.

Il modem riceve le chiamate (se mi connetto con minocom vedo i RING)
Ma sembra non rispondere e quindi non riceve i fax  ??? ???

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re: Installazione Hylafax su centos
« Risposta #5 il: 24 Ottobre 2012, 17:03:04 »
posta il risultato di

Codice: [Seleziona]
grep -i getty /etc/inittab
ps aux | grep fax

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #6 il: 24 Ottobre 2012, 19:00:56 »
Codice: [Seleziona]
[root@localhost ~]# grep -i getty /etc/inittab
# Terminal gettys are handled by /etc/init/tty.conf and /etc/init/serial.conf,
mo:2345:respawn:/usr/sbin/faxgetty ttyS0
[root@localhost ~]# ps aux | grep fax
uucp      1833  0.0  0.1   6640  1308 ?        Ss   16:51   0:00 /usr/sbin/faxq
uucp      1836  0.0  0.0   5364   968 ?        Ss   16:51   0:00 /usr/sbin/hfaxd -l 172.16.16.19 -i hylafax
uucp      2233  0.0  0.1   7108  1420 ?        Ss   16:57   0:00 /usr/sbin/faxgetty -D ttyS0
root      2827  0.0  0.0   4364   764 pts/0    S+   18:54   0:00 grep fax

Sono riuscito a farlo funzionare avviando manuale faxgetty
/usr/sbin/faxgetty -D ttyS0
quindi deduco che il comando inserito in inittab
"mo:2345:respawn:/usr/sbin/faxgetty ttyS0 "
sia errato ?



Offline ciso39

  • Full Member
  • ***
  • Post: 79
    • Mostra profilo
Re: Installazione Hylafax su centos
« Risposta #7 il: 25 Ottobre 2012, 00:35:03 »
Ciao,
anch'io ho avuto un po di problemi di ricezione fax.
Poi ho preso un modem Robotics e ho googleggiato un po....
Di seguito riporto il config.ttyS0 che uso su Centos
5.8 e hylafax 6.0.6 (con la configurazione sono partito
dalla 6.0.5).
Ciao.

CountryCode:            0039
AreaCode:               0565
FAXNumber:              "+39 0565 xxxxxx"
LongDistancePrefix:     0
InternationalPrefix:    00
DialStringRules:        etc/dialrules
ServerTracing:          1
SessionTracing:         11
RecvFileMode:           0666
LogFileMode:            0666
DeviceMode:             0666
RingsBeforeAnswer:      3
SpeakerVolume:          off
GettyArgs:              "-h %l dx_%s"
LocalIdentifier:        "xxxxxxxxx"
LogFacility:            local5
TagLineFont:            etc/lutRS18.pcf
TagLineFormat:          "Da %%l|%c|Pagina %%P di %%T"
MaxRecvPages:           25
#
# Modem-related stuff: should reflect modem command interface
# and hardware connection/cabling (e.g. flow control).
#
ModemType:              Class1          # use class 1 interface
ModemRate:              19200           # rate for DCE-DTE communication
ModemFlowControl:       xonxoff         # software flow control
#
ModemSetupDTRCmd:       ATS13=1&D2      # setup so DTR drop resets modem
ModemSetupDCDCmd:       AT&C1           # setup so DCD reflects carrier (or not)
ModemNoFlowCmd:         AT&H0&I0&R1     # setup modem for no flow control
ModemHardFlowCmd:       AT&H1&I0&R2     # setup modem for hardware flow control
ModemSoftFlowCmd:       AT&H2&I2&R1     # setup modem for software flow control
ModemResultCodesCmd:    ATQ0X3          # enable result codes
#
# Per problema di Blacklist sui Modem USRobotics
ModemResetCmds:         ATS40=2

# Per fare lo zero prima del numero
ModemDialCmd:           ATDT%s

ModemMfrQueryCmd:       !USR
ModemModelQueryCmd:     ATI3
ModemRevQueryCmd:       ATI7            # XXX returns a multi-line result
#
# When AT+FCLASS=1 is issued the modem automatically switches
# to software flow control; these parameters let the fax software
# reset flow control as needed after entering Class 1.
#
Class1NFLOCmd:          AT&H0&I0&R1     # setup modem for no flow control
Class1HFLOCmd:          AT&H1&I0&R2     # setup modem for hardware flow control
Class1SFLOCmd:          ""              # modem does this automatically
#
# This should resolve "DIS/DTC received 3 times" errors:
#
Class1ResponseWaitCmd:  AT+FRS=1        # wait after sending TCF for response
#
# The remainder of this configuration is included so that the
# modem "idles" in Class 0 while not sending or receiving facsimile.
#
ModemSetupAACmd:        AT+FCLASS=0     # leave modem idling in class 0
######### ModemAnswerCmd:               AT+FCLASS=1A    # answer in Class 1
#
# When using AT+FRS=n we see USR modems reset themselves in the middle of sessions
# this is not good.  So, we seem to work-around that problem by not using the
# command.  Unfortunately, this isn't an ideal thing.
#
Class1SwitchingCmd:     "<delay\0727>"
#
#
ModemRingResponse:      "AT#CLS=8\nAT#VLS=4\nATA"
CallIDPattern:          SHIELDED_DTMF
CallIDAnswerLength:     4
ModemAnswerCmd:         "<delay:100>AT+FCLASS=1\nATA"
#
FaxRcvdCmd: bin/faxrcvd

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #8 il: 25 Ottobre 2012, 11:22:59 »
Ciao allora funziona tutto tranne che se invio un fax da comando (sendfax -n -D -d 241 /testfax)
il fax viene inviato correttamente mentre se invio utilizzando winprint mi viene restituito l'errore

Codice: [Seleziona]

Your job to 241 failed because:


    ---- Transcript of session follows ----

ott 25 11:07:23.92: [ 3059]: SESSION BEGIN 000000013 241
ott 25 11:07:23.92: [ 3059]: HylaFAX (tm) Version 6.0.6
ott 25 11:07:23.92: [ 3059]: SEND FAX: JOB 8 DEST 241 COMMID 000000013 DEVICE '/dev/ttyS0' FROM 'faxmail <faxmail@**.it>' USER faxmail
ott 25 11:07:23.92: [ 3059]: <-- [14:AT+FCLASS=1.0\r]
ott 25 11:07:23.94: [ 3059]: --> [2:OK]
ott 25 11:07:23.94: [ 3059]: DIAL 241
ott 25 11:07:23.94: [ 3059]: <-- [17:ATDT241\r]
ott 25 11:07:37.97: [ 3059]: --> [7:CONNECT]
ott 25 11:07:39.34: [ 3059]: --> [2:OK]
ott 25 11:07:39.34: [ 3059]: REMOTE NSF "86 00 11 00 00 E4 01 C8 40 F0 03 18 80 00 00"
ott 25 11:07:39.34: [ 3059]: NSF remote fax equipment: unknown - Korea 11
ott 25 11:07:39.34: [ 3059]: <-- [9:AT+FRH=3\r]
ott 25 11:07:39.35: [ 3059]: --> [7:CONNECT]
ott 25 11:07:40.11: [ 3059]: --> [2:OK]
ott 25 11:07:40.11: [ 3059]: REMOTE CSI ""
ott 25 11:07:40.11: [ 3059]: <-- [9:AT+FRH=3\r]
ott 25 11:07:40.12: [ 3059]: --> [7:CONNECT]
ott 25 11:07:40.49: [ 3059]: --> [2:OK]
ott 25 11:07:40.49: [ 3059]: REMOTE best rate 33600 bit/s
ott 25 11:07:40.49: [ 3059]: REMOTE max A4 page width (215 mm)
ott 25 11:07:40.49: [ 3059]: REMOTE max unlimited page length
ott 25 11:07:40.49: [ 3059]: REMOTE best vres 300 x 300 dpi
ott 25 11:07:40.49: [ 3059]: REMOTE format support: MH, MR, MMR
ott 25 11:07:40.49: [ 3059]: REMOTE supports T.30 Annex A, 256-byte ECM
ott 25 11:07:40.49: [ 3059]: REMOTE best 10 ms/scanline
ott 25 11:07:40.49: [ 3059]: USE 14400 bit/s
ott 25 11:07:40.49: [ 3059]: USE error correction mode
ott 25 11:07:40.49: [ 3059]: <-- [9:AT+FRS=7\r]
ott 25 11:07:40.61: [ 3059]: --> [2:OK]
ott 25 11:07:40.61: [ 3059]: <-- [9:AT+FTH=3\r]
ott 25 11:07:40.66: [ 3059]: --> [7:CONNECT]
ott 25 11:07:40.66: [ 3059]: <-- data [3]
ott 25 11:07:40.66: [ 3059]: <-- data [2]
ott 25 11:07:41.97: [ 3059]: --> [2:OK]
ott 25 11:07:42.97: [ 3059]: <-- [5:ATH0\r]
ott 25 11:07:44.51: [ 3059]: --> [2:OK]
ott 25 11:07:44.51: [ 3059]: SESSION END

Non capisco cosa possa non andare
winprint è configurato correttamente ed effettua il login al server.
Il fax appare nella cartella sendq
Il modem esegui l'invio
Ma mi viene restituito l'errore

Non capisco  :-\

Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #9 il: 25 Ottobre 2012, 12:43:09 »
Trovato il problema, è causato dai driver.
In windows vista o windows 7 non sono presenti i driver apple per la stampante Apple LaserWriter 12/640 PS.

Ho provato altre stampanti post scripting ma non va mi restituisce l'errore.

Avete qualche idea ?

Offline ciso39

  • Full Member
  • ***
  • Post: 79
    • Mostra profilo
Re: Installazione Hylafax su centos
« Risposta #10 il: 27 Ottobre 2012, 00:08:37 »
Ciao,
xerox phaser 6120 ps.


Offline blade832

  • Newbie
  • *
  • Post: 11
    • Mostra profilo
    • E-mail
Re: Installazione Hylafax su centos
« Risposta #11 il: 29 Ottobre 2012, 10:14:44 »
Ciao, avevo provato la xerox ma non andava comunque ho risolto installando il programma adatto per 7 e vista.. windprint reloaded.

Un altra cosa invece, le conferme di invio mi arrivano dall'indirizzo fax@localhost e vanno a finire nello spam.. se volessi cambiare l'indirizzo mittente come posso fare ?

Nel file etc/aliases ho fax:    root
potrebbe funzionare cambiando in
fax:     indirizzo@dominio.it ???

Offline ciso39

  • Full Member
  • ***
  • Post: 79
    • Mostra profilo
Re: Installazione Hylafax su centos
« Risposta #12 il: 31 Ottobre 2012, 17:41:28 »
Si, credo funzioni ugualmente.
Comunque puoi controllare i file FaxDispatch e FaxNotify.
Da me funziona così:
in FaxDispatch SENDTO=FaxMaster
FaxMaster in /etc/aliases è configurato per l'utente
hylafax (FaxMaster: hylafax - come di default). Nella
home dell'utente hylafax ho configurato il file .procmailrc per
smistare i fax che arrivano (mando i fax a vari indirizzi email).
In FaxNotify ho commentato SENDTO e i messaggi giornalieri
di "HylaFAX Usage Report" mi arrivano sull'utente root
dall'utente root.
Ciao

 

Notizie

Tutti posso inserire guide nel portale. Per inserire cliccare in basso a destra su Inserisci nuova Guida/How-To!

Collegamenti

Posts Recenti

Utenti
Statistiche
  • Post in totale: 13106
  • Topic in totale: 2953
  • Online Oggi: 265
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 211
Totale: 211

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c'è mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50