* * *
Benvenuto! Effettua l'accesso oppure registrati.
14 Aprile 2021, 13:50:54

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: app java su centos 5.7  (Letto 2312 volte)

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
app java su centos 5.7
« il: 20 Gennaio 2012, 00:45:32 »
salve a tutti, ho installato centos 5.7 sul mio server.
ho un applicazione sviluppata in java che si chiama app.jar
sul server centos ho installato una versione desktop gnome per dare la possibilit a coloro che utilizzeranno il server oltre me, di startare tale applicazione.
l'app java composta da una cartella principale che ho momentaneamente appoggiato su /home/admin/javaprog/. dall' applicazione app.jar e da un file config.ini che passa al jar alcuni parametri.
il mio problema il seguente:
se da terminale come admin faccio cd /home/admin/javaprog/ e poi java - jar app.jar il programma funziona correttamente al contrario se faccio questa operazione in modo visuale dal desktop gnome facendo doppio click il programma parte ma mi restituisce un errore: impossibile trovare config.ini sapreste spiegarmi il motivo e magari darmi qualche consiglio? grazie.

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
Re: app java su centos 5.7
« Risposta #1 il: 23 Gennaio 2012, 20:05:42 »
c' da qualche parte un log che posso leggere o una console java per capire che problema abbia il software? nei messages e nel secure non c' nulla a riguardo

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re: app java su centos 5.7
« Risposta #2 il: 23 Gennaio 2012, 21:35:51 »
l'operazione visuale da desktop lo fai come utente admin?
come lo script che cerchi di lanciare? la sintassi esatta che usi, intendo..

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
Re: app java su centos 5.7
« Risposta #3 il: 24 Gennaio 2012, 01:56:28 »
Sia da terminale che da desktop lancio l'applicazione come admin.
Nella versione desktop apro la cartella del programma e faccio doppio click sul file eseguibile jar che gi riconosciuto come file java perch ci ho installato il jre 1.6.30.
Infatti il programma parte ma non trova il config.ini.
La procedura esattamente uguale a come se lo facessi su un pc Windows.
Grazie

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re: app java su centos 5.7
« Risposta #4 il: 24 Gennaio 2012, 07:41:45 »
centos non windows.. crea un file di testo con la riga di comando esatta, es.
java -jar percorso-completo-al-jar
dagli i permessi di esecuzione ed usa quello

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
Re: app java su centos 5.7
« Risposta #5 il: 24 Gennaio 2012, 11:57:28 »
Grazie, il file di testo deve avere un estensione particolare o lo creo senza estensione?

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
Re: app java su centos 5.7
« Risposta #6 il: 24 Gennaio 2012, 19:07:41 »
allora dunque grazie al tuo consiglio sono arrivato a capo del problema. Tenuto conto che:
il file tmi.jar con il suo config.ini risiedono in una cartella di nome Client.
Ovunque io poggi questa cartella anche in "/", java si va a cercare il file config.ini in /home/admin/.
infatti se il jar con il suo ini lo metto in /home/admin/ senza la sua cartella di appartenenza, il programma funziona, sia che lo lanci da script che da terminale che semplicemente con doppio click da desktop. sapete spiegarmi il perch?

Offline smeserver

  • Hero Member
  • *****
  • Post: 1313
    • Mostra profilo
Re: app java su centos 5.7
« Risposta #7 il: 24 Gennaio 2012, 19:11:10 »
il jar forse che glielo dice.. perch java non sa cosa sta eseguendo :-)

Offline morcas

  • Newbie
  • *
  • Post: 7
    • Mostra profilo
    • E-mail
Re: app java su centos 5.7
« Risposta #8 il: 24 Gennaio 2012, 20:00:39 »
probabile anche se da terminale il programma funziona anche sotto una cartella. quindi non credo sia legato al jar in se stesso ma a quelche funzione particolare della versione desktop che che esegue soltato da /home/admin. Va bhe possiamo considerarlo risolto. Grazie

 

Notizie

Benvenuto su CentOS-Italia.org , disponibile anche su mobile con Tapatalk

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 5959
  • Ultimo: Sina
Statistiche
  • Post in totale: 13156
  • Topic in totale: 2961
  • Online Oggi: 169
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 122
Totale: 122

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi il css solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c' mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50