CentOS-Italia.org - La Community degli Utenti Italiani di Linux CentOS Forum e Guide How To

Supporto Tecnico a Centos => Software => Topic aperto da: mayers81 - 03 Agosto 2011, 01:01:52

Titolo: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 01:01:52
sto reinstallando openaudit

software network inventory su centos 6 [non ho selezionato installazione web server ma basic server]

su centos 5.6 non avevo avuto problemi ma molto probabilmente perchè aveva qualche pacchetto necessario di default

cmq mi collego all'indirizzo e vedo invece del sito network inventory vedo i file come se fosse un ftp in http

se digito il link/setup.php che è la pagina di setup del software vedo la pagina malissimo i caratteri sono dei ??????

nei log di http non ho trovato niente di utlie qualcuno ha qualche idea?

 ???
Titolo: Re: problemi con apache
Inserito da: kernel - 03 Agosto 2011, 15:29:22
forse manca il php o qualche suo pacchetto .. prova a fare il diff di
rpm -qa | grep php
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 15:33:23
php-pdo-5.3.2-6.el6_0.1.i686
php-pear-1.9.0-2.el6.noarch
php-common-5.3.2-6.el6_0.1.i686
php-cli-5.3.2-6.el6_0.1.i686
php-mysql-5.3.2-6.el6_0.1.i686
php-gd-5.3.2-6.el6_0.1.i686
Titolo: Re: problemi con apache
Inserito da: kernel - 03 Agosto 2011, 15:41:23
php-pdo-5.3.2-6.el6_0.1.i686
php-pear-1.9.0-2.el6.noarch
php-common-5.3.2-6.el6_0.1.i686
php-cli-5.3.2-6.el6_0.1.i686
php-mysql-5.3.2-6.el6_0.1.i686
php-gd-5.3.2-6.el6_0.1.i686

sul sentos 5.6 sono gli stessi ? diff del php.ini ?
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 15:51:04
allora puo essere un componente apache per la visualizzazione corretta della pagina?
Titolo: Re: problemi con apache
Inserito da: kernel - 03 Agosto 2011, 15:56:13
forse manca

imagick extensions for PHP ?
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 16:09:27
vediamo sto installando ImageMagick
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 16:17:47
installato ma non cambia nulla

to ho allegato due file ecco cosa succede se apro il sito file 1

nel due invece digito l'indirizzo della prima cfg
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 16:18:03
ecco il 2
Titolo: Re: problemi con apache
Inserito da: kernel - 03 Agosto 2011, 16:24:59
in /etc/httpd/conf.d  cè il file php.conf ?

con httpd -M si vede il modulo php caricato ?
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 16:29:11
No non c'è sai dirmi come faccio a caricarlo
Titolo: Re: problemi con apache
Inserito da: kernel - 03 Agosto 2011, 16:44:21
scrivi un file php.conf

dentro

LoadModule php5_module modules/libphp5.so
AddHandler php5-script .php
AddType text/html .php
DirectoryIndex index.php


poi riavvia apache
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 16:59:36
ecco dovevo installare questo php.i686 0:5.3.2-6.el6_0.1
Titolo: Re: problemi con apache
Inserito da: mayers81 - 03 Agosto 2011, 17:02:56
confermo mancava quel pacchetto