CentOS-Italia.org - La Community degli Utenti Italiani di Linux CentOS Forum e Guide How To

Supporto Tecnico a Centos => Supporto Generale => Topic aperto da: Rubens - 10 Ottobre 2017, 12:54:14

Titolo: Di funzionare Webmin non ne vuole sapere...
Inserito da: Rubens - 10 Ottobre 2017, 12:54:14
Ciao a tutti,
chiedo a una mano a qualcuno di buona volonta...
su centos 7 ho installato server web, mysql,  phpmyadmin, vsftpd,  configurato le porte con iptables e  tutto funziona.

Ho installato webmin, configurato porte e iptables
ma niente... nel browser gira in continuazione e non visualizza nulla.....
con #services status webmin
 mi dice is running
ma niente
puo aiutarmi qualcuno ?
grazie
Titolo: Re:Di funzionare Webmin non ne vuole sapere...
Inserito da: smeserver - 10 Ottobre 2017, 18:57:44
Si, i log
Senza una evidenza di errore non possiamo fare nulla
Titolo: Re:Di funzionare Webmin non ne vuole sapere...
Inserito da: Rubens - 12 Ottobre 2017, 11:02:55
Innanzitutto un grazie a smeserver per aver risposto.

ho copiato quello che il file miniserv.error mi mostra, sperando che tu riesca a capire cosa posso fare.
Non ho molta esperienza come avrai capito...
comunque grazie

 miniserv.pl started
[04/Oct/2017:16:02:26 +0200] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec
/webmin /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) a
t (eval 11) line 1.
BEGIN failed--compilation aborted at (eval 11) line 1.

[04/Oct/2017:16:02:26 +0200] Continuing without the Authen::PAM perl module
Failed to bind to port 10000 : Address already in use
Could not listen on any ports at /usr/libexec/webmin/miniserv.pl line 456.
[04/Oct/2017:16:11:51 +0200] miniserv.pl started
[04/Oct/2017:16:11:51 +0200] PAM authentication enabled
[04/Oct/2017:16:13:06 +0200] miniserv.pl started
[04/Oct/2017:16:13:06 +0200] PAM authentication enabled
Titolo: Re:Di funzionare Webmin non ne vuole sapere...
Inserito da: smeserver - 12 Ottobre 2017, 12:02:23
ok, come hai installato il tutto (server web, mysql,  phpmyadmin, vsftpd, webmin)?
Titolo: Re:Di funzionare Webmin non ne vuole sapere...
Inserito da: LucaDell - 17 Ottobre 2017, 11:07:10
Prova cosė. Sembra mancare questo modulo di perl.

# yum install perl-CPAN

And : 'perl-Authen-PAM' is in the EPEL.repo
https://fedoraproject.org/wiki/EPEL
"Extra Packages for Enterprise Linux"
# rpm -Uvh http://ftp.crc.dk/fedora-epel/6/i386...6-7.noarch.rpm
# yum install perl-Authen-PAM


speriamo sia questo il problema