* * *
Benvenuto! Effettua l'accesso oppure registrati.
Hai perso l'e-mail di attivazione?
09 Agosto 2020, 13:32:25

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: problema con nautilus  (Letto 2141 volte)

Offline james2221

  • Newbie
  • *
  • Post: 12
    • Mostra profilo
    • E-mail
problema con nautilus
« il: 22 Agosto 2011, 19:52:09 »
ciao
CentOS 6.0 2.6.32-71.29.1.el6.x86_64   -  gnome 2.*
ho installato CentOS da circa 15 gg e funziona a meraviglia  per cui ci lavoro tranquillamente.
Ho due problemi estetici relativi a nautilus:
1) settando una texture di sfondo con il solito sistema (nautilus>modifica>sfondi e simboli>scegliere motivo, ecc) succede che l'immagine si visualizza correttamente ma ad una successiva riapertura di una finestra qualsiasi l'immagine non c'è piu, mi compare il solito sfondo tinta unita
2) nel menu >visualizza, sempre di nautilus, non c'è l'opzione "riquadro aggiuntivo" per dividere la vista a metà che invece ho su altre distro con gnome

qualcuno è tornato dalle ferie???
grazie
james
« Ultima modifica: 22 Agosto 2011, 20:52:50 di james2221 »

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: problema con nautilus
« Risposta #1 il: 23 Agosto 2011, 19:15:18 »
Ti consiglio un trucco per fare reverse engineering.
Vai sul sistema linux dove funziona e apri la finestra che ti consente l'opzione del riquadro aggiuntivo.
Lasciala così senza cliccare nulla ed apri una shell lanciando un
ps -ef
Nella parte finale dovresti vedere il processo applicativo che consente la funzionalità dell'opzione "riquadro aggiuntivo", te ne accorgi dall'orario di avvio del processo.
dai il comando

rpm -qf pathdelprocesso

e scoprirai qual'è il pacchetto rpm che contiene quell'applicazione.
Fatto questo prova a verificare sul tuo sistema se il pacchetto è installato e disponibile nel repository.
rpm -qa |grep nomepacchetto
yum list|grep nomepacchetto
oppure
yum search nomepacchetto

Una volta trovato il pacchetto se non è installato

yum install nomepacchetto

Ciao

Offline james2221

  • Newbie
  • *
  • Post: 12
    • Mostra profilo
    • E-mail
Re: problema con nautilus
« Risposta #2 il: 24 Agosto 2011, 16:28:15 »
ciao
quel comando non mi sa dire niente di chiaro, compaiono dei processi, per esempio
Codice: [Seleziona]
[kworker/u:2]
oppure
Codice: [Seleziona]
/sbin/getty hvc0 9600 linuxma non regolarmente, nel senso che qualche volta sono segnalati  altre invece no.
e comunque quel getty e quel worker non c'entrano affatto, worker per esempio è un file manager che su debian 64 wheezy da cui sto provando non è nemmeno installato
penso che la procedura che mi hai suggerito sia giusta ma il comando non vada bene

grazzzz  comunqqq

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: problema con nautilus
« Risposta #3 il: 25 Agosto 2011, 10:23:37 »
Se utilizzi centos/redhat/fedora/sl il comando và più che bene visto che sono tutte distro che usano rpm come gestore dei pacchetti.
Il comando di ps và lanciato quando la tua applicazione (riquadro aggiuntivo) è aperta.
Il ps ti mostrerà una lunga lista di processi e quelli avviati in ultimo si presume siano quelli relativi alla tua applicazione. Ovviamente il mio era un trucco generico.
Nel tuo caso visto che la funzionalità è integrata in nautilus ti seresti dovuto concentrare su quel processo per capire se richiamava un estensione.
Per comprendere e risolvere il tuo problema però ho dovuto usare una tecnologia diversa e molto potente la "5G" ed ho scoperto che :

http://library.gnome.org/misc/release-notes/2.30/#rna11y
3.1. Visualizzare molti più file

In GNOME 2.30 sono stati apportati molti aggiornamenti a Nautilus, il file manager di GNOME. Diversi cambiamenti all'interfaccia grafica hanno introdotto in Nautilus una nuova "vista affiancata" e la modalità predefinita è ora quella "di esplorazione", sostituendo quella "spaziale".

Detto questo fai tu le dovute valutazioni.

Ciao

Offline james2221

  • Newbie
  • *
  • Post: 12
    • Mostra profilo
    • E-mail
Re: problema con nautilus
« Risposta #4 il: 10 Settembre 2011, 09:09:33 »
ciao
dunque: sono andato su debian in cui tutto funziona bene e ho dato il comando ps -ef in 3 momenti diversi:
con nautilus aperto
con nautilus con riquadro aggiuntivo
con nautilus riquadro aggiuntivo e cambio sfondo nautilus

e ho ottenuto questo da terminale:
solo nautilus
Codice: [Seleziona]
piero     3962  3956  0 08:56 pts/0    00:00:00 bash
root      4022     2  0 08:56 ?        00:00:00 [kworker/1:0]
root      4023     2  0 08:56 ?        00:00:00 [kworker/0:0]
root      4024  1490  0 08:56 ?        00:00:00 run-parts --report /etc/cron.dai
root      4028  4024  0 08:56 ?        00:00:00 /bin/sh /etc/cron.daily/apt
root      4061     2  0 08:56 ?        00:00:00 [kworker/u:0]
root      4081  4028  0 08:56 ?        00:00:00 sleep 278
piero     4096  3962  0 08:57 pts/0    00:00:00 ps -ef

con riquadro aggiuntivo
Codice: [Seleziona]
piero     3962  3956  0 08:56 pts/0    00:00:00 bash
root      4022     2  0 08:56 ?        00:00:00 [kworker/1:0]
root      4023     2  0 08:56 ?        00:00:00 [kworker/0:0]
root      4024  1490  0 08:56 ?        00:00:00 run-parts --report /etc/cron.dai
root      4028  4024  0 08:56 ?        00:00:00 /bin/sh /etc/cron.daily/apt
root      4061     2  0 08:56 ?        00:00:00 [kworker/u:0]
root      4081  4028  0 08:56 ?        00:00:00 sleep 278
piero     4127     1  7 08:58 ?        00:00:00 gedit /home/piero/Scrivania/riqu
piero     4131  3962  0 08:58 pts/0    00:00:00 ps -ef

con riquadro e sfondo nautilus
Codice: [Seleziona]
piero     3962  3956  0 08:56 pts/0    00:00:00 bash
root      4022     2  0 08:56 ?        00:00:00 [kworker/1:0]
root      4023     2  0 08:56 ?        00:00:00 [kworker/0:0]
root      4024  1490  0 08:56 ?        00:00:00 run-parts --report /etc/cron.dai
root      4028  4024  0 08:56 ?        00:00:00 /bin/sh /etc/cron.daily/apt
root      4061     2  0 08:56 ?        00:00:00 [kworker/u:0]
root      4081  4028  0 08:56 ?        00:00:00 sleep 278
piero     4148     1  1 08:58 ?        00:00:00 gedit /home/piero/Scrivania/camb
root      4154     1  0 08:58 ?        00:00:00 /sbin/getty hvc0 9600 linux
piero     4155  3962  0 08:59 pts/0    00:00:00 ps -ef


Sinceramente devo dirti che non ci ho capito un granchè, vedo che getty ha una parte importante ma non riesco a capire quale e come intervenire.

Eventualmente è possibile scaricare una diversa versione di Nautilus e dove prenderla?

grazie
scusa il tempo domanda-risposta ma problemi lavoro...
james

Offline dankan77

  • Moderator
  • Hero Member
  • *****
  • Post: 1365
    • Mostra profilo
    • E-mail
Re: problema con nautilus
« Risposta #5 il: 10 Settembre 2011, 12:24:44 »
Ciao, purtroppo il problema è il solito e probabilmente è anche molto diffuso. Nessuno legge più con attenzione!!!
La funzionalità che ricerchi è dentro gnome 2.30.
La versione di default di centos 6 utilizza la 2.28 quindi su centos diversamente da debian non hai quella funzione.
Cosa puoi fare per avere quella funzione a te tanto cara?
Usare 5G (5 secondi su google) e cercare i pacchetti rpm della versione 2.30 di gnome e/o successive per la tua distro centos ed installarli.


Ciao

 

Notizie

Tutti posso inserire guide nel portale. Per inserire cliccare in basso a destra su Inserisci nuova Guida/How-To!

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 6337
  • Ultimo: merthin
Statistiche
  • Post in totale: 13083
  • Topic in totale: 2945
  • Online Oggi: 337
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 302
Totale: 302

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo più il css è solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c'è mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50