CentOS-Italia.org - La Community degli Utenti Italiani di Linux CentOS Forum e Guide How To

Supporto Tecnico a Centos => Supporto Generale => Topic aperto da: Siok - 15 Marzo 2011, 13:05:19

Titolo: Problema al file system?
Inserito da: Siok - 15 Marzo 2011, 13:05:19
Salve.
Ho installato centos 5.5 sul mio pc con 2 dischi in raid 1 per il boot e 4 dischi in raid 5 per lo storage
La macchina funzionava tranquillamente. Stamattina accendendola, mi viene fuori questo errore
fsck.ext3 Invalid argument while trying to open /dev/md3 (sarebbe il raid 5)

Si è verificato un errore durante il controllo del file system
Permanenza in una shell; il sistema si riavvierà alla chiusura della shell.
etc etc etc..
Che devo fare? non ditemi che devo rifare nuovamente il sistema da 0
Titolo: Re: Problema al file system?
Inserito da: LonelyWolf - 15 Marzo 2011, 14:15:09
E' un raid software?

Intanto puoi fare un controllo dei dischi con fsck dei dischi e verificare che sia tutto a posto, poi fai il riavvio.

Se ancora non risolvi potresti provare ad aggiungere questa opzione all'avvio: rootdelay=30 potrebbe essere che il radi non "si alzi" in tempo rispetto al resto del sistema.

Se possibile controllare i log e mdstat per vedere che dice, perchè con così poche informazioni è difficile capire dove sta il problema.
Titolo: Re: Problema al file system?
Inserito da: Siok - 15 Marzo 2011, 14:45:56
si è un raid software.
facendo mdstat, mi dice che il raid 5 non è attivo (inactive hda1, hdb1 hdc1 hdd1).
se faccio un fsck sul raid 5 (md3) mi viene fuori:
The superblock could not be read or does not descrive a correct ext2 filesystem.if the device i s valid and it really contains an ext2 filesystem(and not swap or ufs or something else),then the superblock is corrupt, and you might try running e2fsck with an alternate superblock
Titolo: Re: Problema al file system?
Inserito da: LonelyWolf - 15 Marzo 2011, 15:21:41
Controlla i singoli dischi, è normale che hai errori a controllare un raid che è inattivo.

cat /proc/mdstat che dice?
Titolo: Re: Problema al file system?
Inserito da: Siok - 15 Marzo 2011, 15:28:56
md3 inactive hda1[0] hdd[1] hdc[1] hdb[1]

md0 active sde1 sdf1
md1 acrive sde2 sdf2
md2 active sde3 sdf3
Titolo: Re: Problema al file system?
Inserito da: LonelyWolf - 15 Marzo 2011, 17:27:17
md3 inactive hda1[0] hdd[1] hdc[1] hdb[1]

md0 active sde1 sdf1
md1 acrive sde2 sdf2
md2 active sde3 sdf3

Mancano un po' di dati!

cmq mi sembra strano che hdd,hdc e hdb stiano a [1]
Titolo: Re: Problema al file system?
Inserito da: Siok - 18 Marzo 2011, 01:56:08
ho risolto forzando l'avvio del raid 5 :D