* * *
Benvenuto! Effettua l'accesso oppure registrati.
12 Maggio 2021, 23:07:54

Inserisci il nome utente, la password e la durata della sessione.

Links

ads

Benvenuto


Benvenuto su la Community CentOS-Italia.Org

La Community Italiana di Linux CentOS e' lieta di averti tra noi , CentOS-Italia.Org e' un risorsa di guide e forum dal principiante al sistemista senior.
Clicca qua per registrati ora

La registrazione e' gratuita e ti consente di avere pieno accesso alle risorse di CentOS-Italia.org , come uso della ricerca avanzata , le funzioni interattive del portale e visualizzare i links nei post.
Gli utenti registrati non visualizzano gli ads, quindi registrati subito se non l'hai gia fatto.

Lo staff di CentOS-Italia.Org cerca di rendere la community un posto piacevole e il piu' produttivo possibile, invitiamo quindi i nuovi utenti a leggere le regole base.
Per info o problemi di registrazione scrivere a centos (at) centos-italia.org .

Autore Topic: Installare programmi - Yum repositories  (Letto 1901 volte)

Offline Loppetto

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Installare programmi - Yum repositories
« il: 12 Agosto 2017, 14:44:23 »
Ciao a tutti, sono nuovo nel forum e neofita del mondo Linux, premetto che non ho particolari velleitÓ da programmatore o amministratore Linux, ho bisogno di imparare le basi per poter utilizzare alcuni software che uso per lavoro e girano su Linux CentOS.
Arrivo al duque, appena installato CentOS 7 su un portatile per fare pratica e mi accingo ad imparare i primi comandi per l'installazione di pacchetti banali tipo Vlc, google crome, gimp ecc ecc.
Scoperta l'esistenza di Yum cerco i comandi su internet e provo ad eseguirli per installare i pacchetti scaricati (rpm)
(yum install ecc ecc) mi appare il seguente messaggio:

1. Contact the upstream for the repository and get them to fix the problem.
2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).
3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

e qui mi perdo e non so cosa fare... non male come inizio direi!! aiuto!!

ho provato anche con i comandi base dopo (rpm -ivh) ma mi da errore, "Failed dependencies: lsb - libxss ecc ecc)

Offline monsee

  • Full Member
  • ***
  • Post: 106
    • Mostra profilo
Re:Installare programmi - Yum repositories
« Risposta #1 il: 15 Agosto 2017, 18:12:20 »
Stai mica utilizzando un Proxy? Prova a connetterti alla Rete senza usare Proxy.
Qui puoi leggere dello stesso problma che hai incontrato tu e della risposta (in inglese) che Ŕ stata data su di un altro Forum: https://www.centos.org/forums/viewtopic.php?t=50536
Qui puoi trovare un caso simile (ma risalente al 2015, dunque riferito alla versione 7.1), con relativa risposta (sempre in inglese, naturalmente): https://stackoverflow.com/questions/32524675/centos-7-1-error-repository

Qui puoi trovare i vari Repo "upstream" (tutto in inglese, ovviamente): https://github.com/luckyrocketshipunderpants/centos7-repos

Qui puoi dare un'occhiata ad un'interessante pagina Wiki (in inglese, tanto per cambiare) relativa ai cosiddetti Repo "aggiungivi": https://wiki.centos.org/AdditionalResources/Repositories

Offline Loppetto

  • Newbie
  • *
  • Post: 2
    • Mostra profilo
Re:Installare programmi - Yum repositories
« Risposta #2 il: 29 Agosto 2017, 10:41:09 »
Grazie Mille Monsee, ho risolto grazie alle tue indicazioni, effettivamente mancavano delle repo per poter installare i software.

Grazie mille.

Offline monsee

  • Full Member
  • ***
  • Post: 106
    • Mostra profilo
Re:Installare programmi - Yum repositories
« Risposta #3 il: 29 Agosto 2017, 16:07:45 »
Ben fatto, Loppetto. :) Lietissimo che tu abbia risolto, amico!

Offline FabioB

  • Jr. Member
  • **
  • Post: 31
    • Mostra profilo
    • E-mail
Re:Installare programmi - Yum repositories
« Risposta #4 il: 19 Settembre 2017, 14:53:55 »
Qualche giorno fa ho installato CentOS server da zero utilizzando l'ultima versione 7.4.1708 e ho avuto lo stesso problema, stesso messaggio di errore e di conseguenza impossibilitÓ di fare alcun aggiornamento e installare epel, nemmeno tramite rpm.
Sperando che sia utile condivido la soluzione che mi ha risolto il problema e precisamente con il comando "dhclient" senza nessun parametro. Per me Ŕ stato risolutivo solo questo di tutte le soluzioni che si trovano in giro che non hanno avuto successo.
Comunque ho fatto una nuova installazione anche stamattina e non c'Ŕ stato alcun problema, credo che abbiano aggiustato qualcosa che non andava.

Offline monsee

  • Full Member
  • ***
  • Post: 106
    • Mostra profilo
Re:Installare programmi - Yum repositories
« Risposta #5 il: 19 Settembre 2017, 22:11:54 »
 :)  Grazie, Fabio, di avere condiviso qui la tua positiva esperienza. Son certo che potrÓ risultare utilissima anche ad altri.

 

Notizie

NON REGISTRATEVI CON EMAIL HOTMAIL/LIVE/OUTLOOK SPESSO NON ARRIVANO LE MAIL

Collegamenti

Posts Recenti

Utenti
  • Utenti in totale: 5959
  • Ultimo: Sina
Statistiche
  • Post in totale: 13160
  • Topic in totale: 2962
  • Online Oggi: 270
  • Massimi online: 9639
  • (14 Gennaio 2020, 10:20:21)
Utenti Online
Utenti: 0
Visitatori: 256
Totale: 256

Permessi

-no content-

ShoutBox!

Ultimo 5 Shout:

fzphoto

19 Febbraio 2018, 09:18:24
Ciao a tutti. Ho installato l'ultima versione di centos 7 per poter lavorare comodamente con DaVinci resolve 14. Solo che non riesco, ne a installare il programma Davinci, ne tanto meno, il driver nvidia per la scheda grafica geoforce 1080 ti. Sul web non trovo niente che mi aiuti. Premetto che sono

aner64

07 Febbraio 2018, 11:21:40
Buongiorno. Ho installato l'ultima versione di CENTOS7 aggiornata alla 7.0.4.1708. Ho bisogno di fare un restore di file da un filesystem reiserfs. CENTOS7 non ha reiserfs tra i FS e bisogna installarlo. Quando di cerca di installare kmod-reiserfs-0.0-2.el7.elrepo.x86_64.rpm escono errori per mancan
 

LonelyWolf

28 Dicembre 2017, 08:37:34
da ieri non vedo pi¨ il css Ŕ solo un problema mio?

trattore

28 Settembre 2015, 03:30:48
ma qui non c'Ŕ mai nessuno
 ;)

ivo

26 Agosto 2015, 16:01:14
Ho configurato il DHCP creato il file /etc/dhcpd.conf con il seguente contenuto
-------------------------------------------------------------------------------
ddns-update-style interim;
ignore client-updates;

authoritative;

subnet 172.16.208.96 netmask 255.255.255.240 {
    option routers      

Mostra ultimi 50